02-05-2019 12:38 PM
Aloha,
I ran into a issue at work, and labbed it to see where is the error.
Router 1 and Router 2 are sending BGP aggregated routes into Router 3
Router 1 is sending 10.200.10.0/24 Router 2 is sending 10.200.20.0/24
Router 3 redistributes all BGP routes into Router 4 via OSPF
Router 4 receives the aggregated routes via OSPF and redistributes into Router 5 via BGP
However I do not see the routes being sent out to router 5 using soft-configuration from R4 and I obviously do not see Router 5 receiving the aggregated routes via the soft-configuration command from R4
I can ping everything behind Router 1 and Router 2 from Router 4, however, can't ping from R5 to R1 or R2
Is this a bug on GNS3? The configuration looks good to me. I think there is an issue redistributing BGP sourced aggregated routes into OSPF? Because when I remove the redistribution from R4 to R5, R5 looses all its redistrubuted learned routes from R4. So this indicates that redistribution seems to be working correctly. Seems like only the aggregated routes is not being redistributed.
R4 routing configuration:
router ospf 100
log-adjacency-changes
redistribute bgp 80 subnets
passive-interface default
no passive-interface GigabitEthernet0/0
network 10.200.70.0 0.0.0.3 area 0
network 10.200.80.10 0.0.0.0 area 0
network 10.200.80.20 0.0.0.0 area 0
router bgp 80
no synchronization
bgp log-neighbor-changes
network 10.200.80.30 mask 255.255.255.255
network 172.17.1.0 mask 255.255.255.252
redistribute ospf 100
neighbor 172.17.1.255 remote-as 100
neighbor 172.17.1.255 description ASB-EDGE
neighbor 172.17.1.255 ebgp-multihop 2
neighbor 172.17.1.255 soft-reconfiguration inbound
no auto-summary
Router 4 ip route table
172.17.0.0/16 is variably subnetted, 7 subnets, 2 masks
S 172.17.1.255/32 [1/0] via 172.17.1.2
B 172.17.1.40/32 [20/0] via 172.17.1.255, 00:30:59
B 172.17.1.30/32 [20/0] via 172.17.1.255, 00:30:59
B 172.17.1.20/32 [20/0] via 172.17.1.255, 00:30:59
B 172.17.1.10/32 [20/0] via 172.17.1.255, 00:30:59
C 172.17.1.0/30 is directly connected, GigabitEthernet1/0
B 172.17.2.0/30 [20/0] via 172.17.1.255, 00:30:59
10.0.0.0/8 is variably subnetted, 16 subnets, 3 masks
C 10.200.70.0/30 is directly connected, GigabitEthernet0/0
C 10.200.80.20/32 is directly connected, Loopback20
C 10.200.80.30/32 is directly connected, Loopback30
C 10.200.80.10/32 is directly connected, Loopback10
O E2 10.200.50.70/32 [110/1] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.50.50/32 [110/3] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O E2 10.200.10.0/30 [110/1] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O E2 10.200.10.0/24 [110/1] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.40/32 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O E2 10.200.20.0/30 [110/1] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O E2 10.200.20.0/24 [110/1] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.30/32 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.20/32 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.50.0/30 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.10/32 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.0/30 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
Router 4 BGP table
Network Next Hop Metric LocPrf Weight Path
*> 10.200.50.0/30 10.200.70.2 2 32768 ?
*> 10.200.50.50/32 10.200.70.2 3 32768 ?
*> 10.200.60.0/30 10.200.70.2 2 32768 ?
*> 10.200.60.10/32 10.200.70.2 2 32768 ?
*> 10.200.60.20/32 10.200.70.2 2 32768 ?
*> 10.200.60.30/32 10.200.70.2 2 32768 ?
*> 10.200.60.40/32 10.200.70.2 2 32768 ?
*> 10.200.70.0/30 0.0.0.0 0 32768 ?
*> 10.200.80.10/32 0.0.0.0 0 32768 ?
*> 10.200.80.20/32 0.0.0.0 0 32768 ?
*> 10.200.80.30/32 0.0.0.0 0 32768 i
*> 172.17.1.0/30 0.0.0.0 0 32768 i
*> 172.17.1.10/32 172.17.1.255 0 0 100 ?
*> 172.17.1.20/32 172.17.1.255 0 0 100 ?
*> 172.17.1.30/32 172.17.1.255 0 0 100 i
*> 172.17.1.40/32 172.17.1.255 0 0 100 i
*> 172.17.2.0/30 172.17.1.255 0 0 100 ?
Router 5 routing configuration:
router bgp 100
no synchronization
bgp log-neighbor-changes
network 172.17.1.0 mask 255.255.255.255
network 172.17.1.30 mask 255.255.255.255
network 172.17.1.40 mask 255.255.255.255
redistribute eigrp 200
neighbor 172.17.1.1 remote-as 80
neighbor 172.17.1.1 description HT-ASB-PE
neighbor 172.17.1.1 soft-reconfiguration inbound
no auto-summary
Router 5 routing table
Gateway of last resort is not set
172.17.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.17.1.255/32 is directly connected, Loopback100
C 172.17.1.40/32 is directly connected, Loopback40
C 172.17.1.30/32 is directly connected, Loopback30
C 172.17.1.20/32 is directly connected, Loopback20
C 172.17.1.10/32 is directly connected, Loopback10
C 172.17.1.0/30 is directly connected, FastEthernet0/0
C 172.17.2.0/30 is directly connected, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
B 10.200.70.0/30 [20/0] via 172.17.1.1, 00:11:22
B 10.200.80.20/32 [20/0] via 172.17.1.1, 00:11:22
B 10.200.80.30/32 [20/0] via 172.17.1.1, 00:26:34
B 10.200.80.10/32 [20/0] via 172.17.1.1, 00:11:22
B 10.200.50.50/32 [20/3] via 172.17.1.1, 00:11:22
B 10.200.60.40/32 [20/2] via 172.17.1.1, 00:11:22
B 10.200.60.30/32 [20/2] via 172.17.1.1, 00:11:22
B 10.200.60.20/32 [20/2] via 172.17.1.1, 00:11:22
B 10.200.50.0/30 [20/2] via 172.17.1.1, 00:11:22
B 10.200.60.10/32 [20/2] via 172.17.1.1, 00:11:22
B 10.200.60.0/30 [20/2] via 172.17.1.1, 00:11:22
Router 5 BGP table
Network Next Hop Metric LocPrf Weight Path
*> 10.200.50.0/30 172.17.1.1 2 0 80 ?
*> 10.200.50.50/32 172.17.1.1 3 0 80 ?
*> 10.200.60.0/30 172.17.1.1 2 0 80 ?
*> 10.200.60.10/32 172.17.1.1 2 0 80 ?
*> 10.200.60.20/32 172.17.1.1 2 0 80 ?
*> 10.200.60.30/32 172.17.1.1 2 0 80 ?
*> 10.200.60.40/32 172.17.1.1 2 0 80 ?
*> 10.200.70.0/30 172.17.1.1 0 0 80 ?
*> 10.200.80.10/32 172.17.1.1 0 0 80 ?
*> 10.200.80.20/32 172.17.1.1 0 0 80 ?
*> 10.200.80.30/32 172.17.1.1 0 0 80 i
r> 172.17.1.0/30 172.17.1.1 0 0 80 i
*> 172.17.1.10/32 0.0.0.0 0 32768 ?
*> 172.17.1.20/32 0.0.0.0 0 32768 ?
*> 172.17.1.30/32 0.0.0.0 0 32768 i
*> 172.17.1.40/32 0.0.0.0 0 32768 i
*> 172.17.2.0/30 0.0.0.0 0 32768 ?
Solved! Go to Solution.
02-05-2019 12:53 PM
Hello,
not sure if this is a bug, what if you specifically configure:
R4
redistribute ospf 100 match internal external 1 external 2
02-05-2019 01:31 PM
02-05-2019 12:53 PM
Hello,
not sure if this is a bug, what if you specifically configure:
R4
redistribute ospf 100 match internal external 1 external 2
02-05-2019 01:02 PM
02-05-2019 01:04 PM
02-05-2019 01:13 PM
Hello,
in theory, without the keywords, only OSPF intra-area and inter-area routes should have been redistributed into BGP. So you shoud get at least the 'O' routes.
Which IOS are you running this on in GNS3 ?
02-05-2019 01:16 PM
02-05-2019 01:20 PM
Hello,
I am testing with 15.6(2)T...will let you know...
02-05-2019 01:31 PM
02-05-2019 01:40 PM
Exactly. So by default you get only the 'O' and 'O-IA' routes (the latter you don't have')...
02-05-2019 01:35 PM
Hello,
it works as designed in 15(6)2T.
Actually, looking at the routing table of your R4 router and the routing table of your R5 router, I think all the redistributed 'O' routes are there ?
O 10.200.50.50/32 [110/3] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.40/32 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.30/32 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.20/32 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.50.0/30 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.10/32 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
O 10.200.60.0/30 [110/2] via 10.200.70.2, 00:31:25, GigabitEthernet0/0
B 10.200.70.0/30 [20/0] via 172.17.1.1, 00:11:22
B 10.200.80.20/32 [20/0] via 172.17.1.1, 00:11:22
B 10.200.80.30/32 [20/0] via 172.17.1.1, 00:26:34
B 10.200.80.10/32 [20/0] via 172.17.1.1, 00:11:22
B 10.200.50.50/32 [20/3] via 172.17.1.1, 00:11:22
B 10.200.60.40/32 [20/2] via 172.17.1.1, 00:11:22
B 10.200.60.30/32 [20/2] via 172.17.1.1, 00:11:22
B 10.200.60.20/32 [20/2] via 172.17.1.1, 00:11:22
B 10.200.50.0/30 [20/2] via 172.17.1.1, 00:11:22
B 10.200.60.10/32 [20/2] via 172.17.1.1, 00:11:22
B 10.200.60.0/30 [20/2] via 172.17.1.1, 00:11:22
02-05-2019 02:20 PM
02-05-2019 02:35 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide