cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
680
Views
10
Helpful
3
Replies

Redistribution of OSPFv3 routes into BGP - one route missing

Pedro Matias
Level 1
Level 1

I have a network like the one in the picture. Inside AS 92 I have OSPFv3 running, and in both R5 and R6 I have BGP as well. MLS are multi layer switches, so they also have OSPFv3.

I want to redistribute all the IPv6 subnets advertised in OSPFv3 into BGP, without aggregating them all into the big /48 prefix. For some reason, this is working for all but one subnet. The subnet in question, 2001:DB11:92:65::/64, corresponds to the connection between R5 and R6. I have checked and this subnet is properly advertised inside OSPFv3.

I have thought that maybe the reason this subnet is not being redistributed is because it is connecting only the 2 ASBR. However, I don't know why this would cause such behaviour.

I don't want to manually advertise the subnet into BGP using the network command, if at all possible.

Here is the part of the config of R6 corresponding to OSPF and BGP:

!OSPFv3

ipv6 unicast-routing
ipv6 router ospf 1
router-id 6.6.6.6
exit
int f0/1
ipv6 add 2001:DB11:92:64::6/64
ipv6 ospf 1 area 0
no shut

!here the relevant subnet
int f0/0
ipv6 add 2001:DB11:92:65::6/64
ipv6 ospf 1 area 0
no shut

!BGP
router bgp 92
bgp router-id 6.6.6.6
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:DB11:92:65::5 remote-as 92
neighbor 2001:DB8:FF:C000::8 remote-as 93
address-family ipv6
neighbor 2001:DB11:92:65::5 activate
neighbor 2001:DB11:92:65::5 next-hop-self
neighbor 2001:DB8:FF:C000::8 activate
redistribute ospf 1

 

The 2001:DB8:FF:C000::8 address corresponds to R8 on f0/0 interface.

R5 has a very similar configuration to R6.

The subnet is reachable inside AS92 from all points.

This is the BGP table of R6. I have removed from it all the subnets from outside AS 92. I couldn't paste it here because of formatting errors (it seems like this editor doesn't respect tabs): https://pastebin.com/n2mVtR63

Subnets ending in A,B and C correspond to VLANs inside the AS, 53 and 64 are the subnets corresponding the connections between R5-MLS3 and R6-MLS4, respectively.

This is the regular OSPF database at MLS3: https://pastebin.com/uzncPY2m

This is the router-LSA OSPF database at MLS3: https://pastebin.com/rnXj9nQq

This is the network-LSA OSPF database at MLS3: https://pastebin.com/sGYfg1Zt Note the second to last LSA, corresponding to the subnet that is not getting redistributed.

So, is something wrong with my redistribution of OSPF into BGP or is this normal behaviour? Am I supposed to manually advertise this subnet?

1 Accepted Solution

Accepted Solutions

Hello,

I couldn't access some links, but have you checked the routing table for that IPv6 network on R6. Since its directly connected it wouldnt show up in the routint table being learned from OSPF. That being said if you're only redistributing OSPF learned routes then it may bypass that since its not an OSPF learned route. Try redistributing connected as well into BGP under IPv6 to see if that solves your issue.

 

Hope that helps

-David

View solution in original post

3 Replies 3

Hello,

I couldn't access some links, but have you checked the routing table for that IPv6 network on R6. Since its directly connected it wouldnt show up in the routint table being learned from OSPF. That being said if you're only redistributing OSPF learned routes then it may bypass that since its not an OSPF learned route. Try redistributing connected as well into BGP under IPv6 to see if that solves your issue.

 

Hope that helps

-David


@David Ruess wrote:

Hello,

I couldn't access some links, but have you checked the routing table for that IPv6 network on R6. Since its directly connected it wouldnt show up in the routint table being learned from OSPF. That being said if you're only redistributing OSPF learned routes then it may bypass that since its not an OSPF learned route. Try redistributing connected as well into BGP under IPv6 to see if that solves your issue.

 

Hope that helps

-David


Yes, I have checked the IPv6 routing table for that network. As you say, it is directly connected, and not learned from OSPF. This is the relevant output:

R6#sh ipv6 route

C 2001:DB11:92:65::/64 [0/0]
via ::, FastEthernet0/0
L 2001:DB11:92:65::6/128 [0/0]
via ::, FastEthernet0/0

"That being said if you're only redistributing OSPF learned routes then it may bypass that since its not an OSPF learned route."

So, the functioning of OSPF redistribution into BGP is such that it only redistributes the routes learned from OSPF that are placed into the routing table, and disregards the routes learned from OSPF that are not placed into the routing table (in this case, because there is a direct connection)?

Edit- The last sentence refers to the functioning of the redistribute ospf process-id command. I realise the functioning might be different with redistribute connected

Hello

Try the following:
router bgp 92
no synchronization 
<  depending on how old the rtr ios is ?
redistribute connected
redistribute ospf 1 match internal external 1 external 2


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking for a $25 gift card