cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
420
Views
3
Helpful
5
Replies

Redistribution - Perplexing

jaighobahi
Level 1
Level 1

I greet everyone.  Please be patient with me.  Here I am supposed to have a very basic network.

Topology.JPG

The configurations are as follows:

R1#

!

!

ip cef

!

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

!

interface FastEthernet0/0

ip address 10.0.0.1 255.255.255.0

speed 100

full-duplex

!

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.252

speed 100

full-duplex

!

!

router bgp 100

no synchronization

bgp log-neighbor-changes

network 2.2.2.2 mask 255.255.255.255

network 10.0.0.0 mask 255.255.255.0

network 192.168.1.0 mask 255.255.255.252

neighbor 192.168.1.2 remote-as 100

no auto-summary

!

!

end

*************************************************************************************

R2#

!

!

ip cef

!

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

!

interface Loopback1

ip address 6.6.6.6 255.255.255.255

!

!

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.252

speed 100

full-duplex

!

!

interface FastEthernet0/1

ip address 172.16.1.1 255.255.255.0

speed 100

full-duplex

!

!

router eigrp 45

redistribute bgp 100 metric 1000 100 255 1 1500

network 6.6.6.6 0.0.0.0

network 172.16.1.0 0.0.0.255

no auto-summary

!

!

router bgp 100

no synchronization

bgp log-neighbor-changes

network 3.3.3.3 mask 255.255.255.255

network 192.168.1.0 mask 255.255.255.252

redistribute eigrp 45

neighbor 192.168.1.1 remote-as 100

no auto-summary

!

!

end

*********************************************************************************************

R3#

!

!

ip cef

!

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

!

!

interface FastEthernet0/0

ip address 172.16.1.2 255.255.255.0

speed 100

full-duplex

!

!

router eigrp 45

network 4.4.4.4 0.0.0.0

network 172.16.1.0 0.0.0.255

!

!

end

******************************************************************************************************

The verifications are as follows:

R1#show ip route

!

!

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     3.0.0.0/32 is subnetted, 1 subnets

B       3.3.3.3 [200/0] via 192.168.1.2, 00:04:57

     4.0.0.0/32 is subnetted, 1 subnets

B       4.4.4.4 [200/156160] via 172.16.1.2, 00:04:52

     6.0.0.0/32 is subnetted, 1 subnets

B       6.6.6.6 [200/0] via 192.168.1.2, 00:04:57

     172.16.0.0/24 is subnetted, 1 subnets

B       172.16.1.0 [200/0] via 192.168.1.2, 00:04:57

     10.0.0.0/24 is subnetted, 1 subnets

C       10.0.0.0 is directly connected, FastEthernet0/0

     192.168.1.0/30 is subnetted, 1 subnets

C       192.168.1.0 is directly connected, FastEthernet0/1

   

    No problems in this case.  I see all the routes to the remote subnets.

*****************************************************************************************************************

R2#show ip route
!
!
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [200/0] via 192.168.1.1, 00:23:33
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/156160] via 172.16.1.2, 00:23:49, FastEthernet0/1
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
B       10.0.0.0 [200/0] via 192.168.1.1, 00:23:35
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet0/0

This is okay, I see all the remote subnets.

************************************************************************************************************************

R3#show ip route

!

!

     3.0.0.0/32 is subnetted, 1 subnets

D EX    3.3.3.3 [170/2588160] via 172.16.1.1, 00:00:34, FastEthernet0/0

     4.0.0.0/32 is subnetted, 1 subnets

C       4.4.4.4 is directly connected, Loopback0

     6.0.0.0/32 is subnetted, 1 subnets

D       6.6.6.6 [90/156160] via 172.16.1.1, 00:00:34, FastEthernet0/0

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, FastEthernet0/0

     192.168.1.0/30 is subnetted, 1 subnets

D EX    192.168.1.0 [170/2588160] via 172.16.1.1, 00:00:36, FastEthernet0/0

As you can see, only two out of the four remote networks are in this routing table.  R2 simply redistributed the BGP networks that are directly connected to it.  What happened to the BGP networks that R2 learned from R1?  How come these BGP routes were not redistributed even though they are in R2's routing table?

Please, help in any way you can. 

1 Accepted Solution

Accepted Solutions

Hello Jaighobahi,

you are on the right track about iBGP and IGP redistribution, you need also a command under router bgp to allow injection of iBGP routes into IGP redistribution. I'm sorry I have missed it in my first replay.

BGP by default provides a protection mechanism to avoid to overload the IGP database being BGP much more scalable,

This protection can be disabled with the commands below:

on R2:

router bgp 100

bgp redistribute-internal

BGP AS number and EIGRP AS number are different concepts and they don't need to be equal and this does not change the behaviour

see

http://www.cisco.com/en/US/docs/ios-xml/ios/iproute_bgp/command/bgp-a1.html#wp4270480859

https://supportforums.cisco.com/docs/DOC-1575

Hope to help

Giuseppe

View solution in original post

5 Replies 5

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Jaighobahi,

the missing BGP routes have a nexthop of 192.168.1.1, that is another EIGRP external route.

Having an external route with a next-hop that relies on another external route is not allowed at all in OSPF.

EIGRP may allow for this, but the results may be unexpected as the routes may be injected or not depending on the processing order of the BGP routes in the redistribution into EIGRP process..

To have good results make the 192.168.1.0/30 published in EIGRP on R2 using the following commands:

R2:

router eigrp 45

network 192.168.1.0 0.0.0.3

in this way the BGP next-hop becomes an EIGRP internal route and this should solve your issue

Hope to help

Giuseppe

I have done according to your recommendation, but now there is only one route redistributed.

R3#show ip route

     3.0.0.0/32 is subnetted, 1 subnets

D EX    3.3.3.3 [170/2588160] via 172.16.1.1, 00:04:05, FastEthernet0/0

     4.0.0.0/32 is subnetted, 1 subnets

C       4.4.4.4 is directly connected, Loopback0

     6.0.0.0/32 is subnetted, 1 subnets

D       6.6.6.6 [90/156160] via 172.16.1.1, 00:04:05, FastEthernet0/0

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, FastEthernet0/0

     192.168.1.0/30 is subnetted, 1 subnets

D       192.168.1.0 [90/30720] via 172.16.1.1, 00:01:49, FastEthernet0/0

Thanks everybody.  I think I get what is going on.  R1 and R2 are in the same AS and iBGP is in operation.  According to the materials I have read, R1 or R2 will not advertise the iBGP routes learned from an iBGP neighbor to another router in the AS.  I did not expect that this condition would extend to redistribution since I was only trying to redistribute from BGP in AS 100 to EIGRP in AS 45.  However, I still would like to ask: 

BGP 100 and EIGRP 45 run in the same router.  Is it the case that BGP assumes the EIGRP is also in AS 100?   Please, confirm this.

Hello Jaighobahi,

you are on the right track about iBGP and IGP redistribution, you need also a command under router bgp to allow injection of iBGP routes into IGP redistribution. I'm sorry I have missed it in my first replay.

BGP by default provides a protection mechanism to avoid to overload the IGP database being BGP much more scalable,

This protection can be disabled with the commands below:

on R2:

router bgp 100

bgp redistribute-internal

BGP AS number and EIGRP AS number are different concepts and they don't need to be equal and this does not change the behaviour

see

http://www.cisco.com/en/US/docs/ios-xml/ios/iproute_bgp/command/bgp-a1.html#wp4270480859

https://supportforums.cisco.com/docs/DOC-1575

Hope to help

Giuseppe

bgp redistribute-internal resolved the issue.  Apology for the long delay in confirming your suggestion.

Thanks to everyone on this forum.

Review Cisco Networking for a $25 gift card