cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2982
Views
5
Helpful
11
Replies

Rommon

imanco671
Level 1
Level 1

Hello Community,

I just purchased a used ASA 5510. When I started it,  it boots into Rommon.

What should I do?

Rebooting....

Booting system, please wait...

CISCO SYSTEMS

Embedded BIOS Version 1.0(11)2 01/25/06 13:21:26.17

Low Memory: 631 KB

High Memory: 256 MB

PCI Device Table.

Bus Dev Func VendID DevID Class              Irq

00  00  00   8086   2578  Host Bridge

00  01  00   8086   2579  PCI-to-PCI Bridge

00  03  00   8086   257B  PCI-to-PCI Bridge

00  1C  00   8086   25AE  PCI-to-PCI Bridge

00  1D  00   8086   25A9  Serial Bus         11

00  1D  01   8086   25AA  Serial Bus         10

00  1D  04   8086   25AB  System

00  1D  05   8086   25AC  IRQ Controller

00  1D  07   8086   25AD  Serial Bus         9

00  1E  00   8086   244E  PCI-to-PCI Bridge

00  1F  00   8086   25A1  ISA Bridge

00  1F  02   8086   25A3  IDE Controller     11

00  1F  03   8086   25A4  Serial Bus         5

00  1F  05   8086   25A6  Audio              5

02  01  00   8086   1075  Ethernet           11

03  01  00   177D   0003  Encrypt/Decrypt    9

03  02  00   8086   1079  Ethernet           9

03  02  01   8086   1079  Ethernet           9

03  03  00   8086   1079  Ethernet           9

03  03  01   8086   1079  Ethernet           9

04  02  00   8086   1209  Ethernet           11

04  03  00   8086   1209  Ethernet           5

Evaluating BIOS Options ...

Launch BIOS Extension to setup ROMMON

Cisco Systems ROMMON Version (1.0(11)2) #0: Thu Jan 26 10:43:08 PST 2006

Platform ASA5510

Management0/0

Ethernet auto negotiation timed out.

Interface-4 Link Not Established (check cable).

Default Interface number-4 Not Up

Use ? for help.

rommon #0>

1 Accepted Solution

Accepted Solutions

John

In config mode do this -

ciscoasa(config)# config-register 0x1

then save your config and reboot.

Jon

View solution in original post

11 Replies 11

imanco671
Level 1
Level 1

I have actually booted using: boot asa804-28-k8.bin

But it keeps rebooting into Rommon,

Still researching.....

John

Can you post output of "sh version" or "sh running-config version" from your ASA when it is up and running.

Jon

Hi John,

Here is my sh ver.

ciscoasa> sh ver

Cisco Adaptive Security Appliance Software Version 8.0(4)28

Device Manager Version 6.1(5)

Compiled on Wed 18-Mar-09 17:25 by builders

System image file is "disk0:/asa804-28-k8.bin"

Config file at boot was "startup-config"

ciscoasa up 8 secs

Hardware:   ASA5510, 256 MB RAM, CPU Pentium 4 Celeron 1600 MHz

Internal ATA Compact Flash, 256MB

BIOS Flash M50FW080 @ 0xffe00000, 1024KB

Encryption hardware device : Cisco ASA-55x0 on-board accelerator (revision 0x0)

                             Boot microcode   :  CN1000-MC-BOOT-2.00

                             SSL/IKE microcode:  CNLite-MC-SSLm-PLUS-2.03

                             IPSec microcode  :  CNlite-MC-IPSECm-MAIN-2.05

0: Ext: Ethernet0/0         : address is 001f.9e3c.7da8, irq 9

1: Ext: Ethernet0/1         : address is 001f.9e3c.7da9, irq 9

2: Ext: Ethernet0/2         : address is 001f.9e3c.7daa, irq 9

3: Ext: Ethernet0/3         : address is 001f.9e3c.7dab, irq 9

4: Ext: Management0/0       : address is 001f.9e3c.7da7, irq 11

5: Int: Not used            : irq 11

6: Int: Not used            : irq 5

Licensed features for this platform:

Maximum Physical Interfaces  : Unlimited

Maximum VLANs                : 50

Inside Hosts                 : Unlimited

Failover                     : Disabled

VPN-DES                      : Enabled

VPN-3DES-AES                 : Enabled

Security Contexts            : 0

GTP/GPRS                     : Disabled

VPN Peers                    : 250

WebVPN Peers                 : 2

AnyConnect for Mobile        : Disabled

AnyConnect for Linksys phone : Disabled

Advanced Endpoint Assessment : Disabled

UC Proxy Sessions            : 2

This platform has a Base license.

Serial Number: JMX1215L1WW

Running Activation Key: 0x6f387d77 0xc09ded19 0xd8321914 0x98c0a8b4 0xc531adb1

Configuration register is 0x2142

Configuration has not been modified since last system restart.

ciscoasa>

John

In config mode do this -

ciscoasa(config)# config-register 0x1

then save your config and reboot.

Jon

Worked, but I am getting a username and password prompt. I have no idea what default username and password to use..

Hi Jon,

look below.

John

Cisco Adaptive Security Appliance Software Version 8.0(4)28

  ****************************** Warning *******************************

  This product contains cryptographic features and is

  subject to United States and local country laws

  governing, import, export, transfer, and use.

  Delivery of Cisco cryptographic products does not

  imply third-party authority to import, export,

  distribute, or use encryption. Importers, exporters,

  distributors and users are responsible for compliance

  with U.S. and local country laws. By using this

  product you agree to comply with applicable laws and

  regulations. If you are unable to comply with U.S.

  and local laws, return the enclosed items immediately.

  A summary of U.S. laws governing Cisco cryptographic

  products may be found at:

  http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

  If you require further assistance please contact us by

  sending email to export@cisco.com.

  ******************************* Warning *******************************

Copyright (c) 1996-2008 by Cisco Systems, Inc.

                Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

                Cisco Systems, Inc.

                170 West Tasman Drive

                San Jose, California 95134-1706

....WARNING: interface Management0/0 security level is 10.

*** Output from config line 186, "logging host management ..."

..

Cryptochecksum (unchanged): 51b49586 fa35f680 805cfd6b d411a9d7

Username:

So you haven't configured a username or password ?

If not try a combination of "cisco/cisco"  or "cisco/ (as in press enter key)

Jon

Also try just hitting "enter" for both username and password.

Jon

Hi Jon,

Neither worked. I think I have to reset the username and password somehow.

Is this a good guide to follow?

Thanks

John

John

My apologies. I have just reread your original question and realised it was a used ASA you bought and not an original one so it may be that the previous owner setup a username/password.

So you need to a password recovery procedure to boot up the ASA without it's current config and then enter your own username/password so you can then login. See this link for details -

http://www.cisco.com/en/US/docs/security/asa/asa82/configuration/guide/admin_trouble.html#wp1049302

Note after doing this recovery proedure you then need to set the config register back to 0x1 for it to boot automatically.

Alternatively if you are still in touch with the seller then he/she may be able to provide username/password.

Jon

@jon.marshall

Thank you for your solution, i encountered the same problem and this solution worked peerfectly.

Review Cisco Networking for a $25 gift card