cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1285
Views
0
Helpful
4
Replies
Highlighted
Beginner

Router 2911 with sm-es2-16p that does not do intervlan routing

hi, i have  problem with a router 2900 with a card switch 16 ports (sm-es2-16p) that does not doing the intervlan routing. i have attached 2 show tech one of the router and one of the card switch 16 ports (sm-es2-16p). I connected physically the switch card to a router interface and it seem to be working because i can do a ping from my pc  ( in user vlan 26) to my gateway on the router (172.20.26.1) but i can not do ping to the others vlan like  (172.10.26.1) or others. .. i want to know what is happening and if it there is a way to do the trunk conectivity between the switch card and the router internally without a phyisical connection.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

G'day

The (sm-es2-16p) has interface Gi0/1 connected through the backplane to the Router interface Gi1/0.
To get your routing working you should remove the physical cable and apply the below configuration to the router.

Hope it helps


conf t
default interface GigabitEthernet 1/0
default interface GigabitEthernet 0/2
interface GigabitEthernet 1/0
ip address 172.20.10.1 255.255.254.0
no shut
!
interface GigabitEthernet1/0.12
description IMPRESORAS
encapsulation dot1Q 12
ip address 172.20.12.1 255.255.254.0
!
interface GigabitEthernet1/0.14
description SERVIDORES
encapsulation dot1Q 14
ip address 172.20.14.1 255.255.254.0
!
interface GigabitEthernet1/0.16
description VOZ SOBRE IP
encapsulation dot1Q 16
ip address 172.20.16.1 255.255.254.0
!
interface GigabitEthernet1/0.18
description RADIOS IP
encapsulation dot1Q 18
ip address 172.20.18.1 255.255.254.0
!
interface GigabitEthernet1/0.20
description SEGURIDAD FISICA
encapsulation dot1Q 20
ip address 172.20.20.1 255.255.254.0
!
interface GigabitEthernet1/0.22
description WLAN DE VISITANTES
encapsulation dot1Q 22
ip address 172.20.22.1 255.255.254.0
!
interface GigabitEthernet1/0.24
description RESERVADA
encapsulation dot1Q 24
ip address 172.20.24.1 255.255.254.0
!
interface GigabitEthernet1/0.26
description Usuarios
encapsulation dot1Q 26
ip address 172.20.26.1 255.255.254.0
exit
end
wr

View solution in original post

4 REPLIES 4
Highlighted

G'day

The (sm-es2-16p) has interface Gi0/1 connected through the backplane to the Router interface Gi1/0.
To get your routing working you should remove the physical cable and apply the below configuration to the router.

Hope it helps


conf t
default interface GigabitEthernet 1/0
default interface GigabitEthernet 0/2
interface GigabitEthernet 1/0
ip address 172.20.10.1 255.255.254.0
no shut
!
interface GigabitEthernet1/0.12
description IMPRESORAS
encapsulation dot1Q 12
ip address 172.20.12.1 255.255.254.0
!
interface GigabitEthernet1/0.14
description SERVIDORES
encapsulation dot1Q 14
ip address 172.20.14.1 255.255.254.0
!
interface GigabitEthernet1/0.16
description VOZ SOBRE IP
encapsulation dot1Q 16
ip address 172.20.16.1 255.255.254.0
!
interface GigabitEthernet1/0.18
description RADIOS IP
encapsulation dot1Q 18
ip address 172.20.18.1 255.255.254.0
!
interface GigabitEthernet1/0.20
description SEGURIDAD FISICA
encapsulation dot1Q 20
ip address 172.20.20.1 255.255.254.0
!
interface GigabitEthernet1/0.22
description WLAN DE VISITANTES
encapsulation dot1Q 22
ip address 172.20.22.1 255.255.254.0
!
interface GigabitEthernet1/0.24
description RESERVADA
encapsulation dot1Q 24
ip address 172.20.24.1 255.255.254.0
!
interface GigabitEthernet1/0.26
description Usuarios
encapsulation dot1Q 26
ip address 172.20.26.1 255.255.254.0
exit
end
wr

View solution in original post

Highlighted

Also on Switch

Run This command

interface vlan 10

no shut

interface vlan 12

no shut

interface  vlan 14

no shut

interface vlan 16

no shut

interface Vlan 18

no shut

interface vlan 20

no shut

interface vlan 22

no shut

interface vlan 24

  no shut

interface vlan 26

no shut

Jawad
Highlighted

Hi your configuration works fine, thanks but after of this the dhcp stopped working or start to work intermittently. Coud you or any one tell me if i forget something on dhcp config.

my dhcp on etherswitch is:

ip dhcp excluded-address 172.20.16.1 172.20.16.20

ip dhcp pool dhcpurbina_voip

network 172.20.16.0  255.255.254.0

default-router 172.20.16.1

ip dhcp excluded-address 172.20.18.1 172.20.18.20

ip dhcp pool dhcpurbina_Radios_IP

network 172.20.18.0  255.255.254.0

default-router 172.20.18.1

ip dhcp excluded-address 172.20.20.1 172.20.20.100

ip dhcp pool dhcpurbina_Seguridad_Fisica

network 172.20.20.0  255.255.254.0

default-router 172.20.20.1

ip dhcp excluded-address 172.20.22.1 172.20.22.20

ip dhcp pool dhcpurbina_Wireless_Lan_Visitantes

network 172.20.22.0  255.255.254.0

default-router 172.20.22.1

ip dhcp excluded-address 172.20.24.1 172.20.24.20

ip dhcp pool dhcpurbina_Reservadas

network 172.20.24.0  255.255.254.0

default-router 172.20.24.1

ip dhcp excluded-address 172.20.26.1 172.20.26.30

ip dhcp pool dhcpurbina_Usuarios

network 172.20.26.0  255.255.254.0

default-router 172.20.26.1

Highlighted

Looks good, perhaps move the dhcp config to the router