04-22-2018 08:54 AM - edited 03-05-2019 10:19 AM
Hello all,
I am new and working on my CCNA. I am extremely confused at this point and wanted to see if someone may be able to help me. I currently have a router (2611XM) that is configured and working properly. If I place a host connection on fa0/1 I have lan, and internet access. However when I place a connection between fa0/1 on my router to any port on my switch (2950) I do not have internet access. I have created vlan99 on ports fa0/1-8 and am currently working with this. If i connect a cable direct from my modem to any port on the switch I do have internet access on both vlan1, and 99. I think that it is a dns issue but can not figure it out. Any help would be appreciated. I have added my running config for the switch.
Thank you,
Devin
Current configuration : 1550 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch1
!
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
switchport access vlan 99
!
interface FastEthernet0/2
switchport access vlan 99
!
interface FastEthernet0/3
switchport access vlan 99
!
interface FastEthernet0/4
switchport access vlan 99
!
interface FastEthernet0/5
switchport access vlan 99
!
interface FastEthernet0/6
switchport access vlan 99
!
interface FastEthernet0/7
switchport access vlan 99
!
interface FastEthernet0/8
switchport access vlan 99
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan99
ip address 10.0.0.99 255.0.0.0
no ip route-cache
!
ip default-gateway 10.0.0.1
ip http server
!
line con 0
password cisco
login
line vty 0 4
login
line vty 5 15
login
!
!
end
Solved! Go to Solution.
04-22-2018 11:29 PM
Hi,
I think your laptop is getting the IP from DHCP and you configured wrong gateway address on DHCP pool.
ip dhcp pool MY_LAN
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
dns-server 1.1.1.1
Change it and try.
Regards,
Deepak Kumar
04-22-2018 12:58 PM
Hi
Could you please share the router configuration, probably the Router's port is not configured with sub interfaces. If you are going to use one VLAN is ok but if you have 2 or more VLANs the switchport must be configured as trunk and the router interface with subinterfaces using encapsulation dot1q.
04-22-2018 03:52 PM
Hello Julio,
I have added my running config on my router. I tried connecting fa0/1 from router to switch when everything was in vlan1 and still had the same issue. I then created the vlan99 on ports fa0/1 - 8 just to keep everything working on the vlan1.
Current configuration : 1264 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router3.mylab
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.0.0 10.0.0.99
!
ip dhcp pool MY_LAN
network 10.0.0.0 255.0.0.0
default-router 192.168.0.1
dns-server 1.1.1.1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description ## INTERNET ##
ip address dhcp
ip access-group MY_WAN in
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
description ## MY LAN ##
ip address 10.0.0.1 255.0.0.0
ip nat inside
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list MY_LAN interface FastEthernet0/0 overload
!
ip access-list standard MY_LAN
permit 10.0.0.0 0.255.255.255
!
ip access-list extended MY_WAN
permit tcp any any established
deny tcp any any
permit ip any any
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
Thank you for your help,
Devin
04-22-2018 07:21 PM
because on your router you have the following LAN ip address configured:
10.0.0.1 255.0.0.0
your default gateway that you have configured on your router is wrong. and needs to be 10.0.0.1 also
04-22-2018 07:29 PM
Hello Dennis,
Sorry if I am missing something as I am still new to this. However the router works fine. FA0/1 has a static up of 10.0.0.1 and with a client connected directly to FA0/1 works with no issues. However when connecting that port to my switch I do not get internet access.
Thank you,
Devin.
04-22-2018 10:48 PM
04-23-2018 01:40 PM
Hello Dennis,
To be sure I did a ipconfig release / renew on client. IP given when connected to switch is 10.0.0.100 via dhcp. I can ping 10.0.0.1 with no issues, but can not ping the gateway at 192.168.0.1 on the client pc, or the switch.
However if I connect the client directly to port fa0/1 on the router that is assigned 10.0.0.1 I am able to reach the internet with no issues.
Thank you,
Devin
04-22-2018 11:29 PM
Hi,
I think your laptop is getting the IP from DHCP and you configured wrong gateway address on DHCP pool.
ip dhcp pool MY_LAN
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
dns-server 1.1.1.1
Change it and try.
Regards,
Deepak Kumar
04-23-2018 01:51 PM
Hello Deepak,
Thank you for your input. I have made these changes, and am still having the same issue. Here is my current running config and issue.
To be sure I did a ipconfig release / renew on client. IP given when connected to switch is 10.0.0.100 via dhcp. I can ping 10.0.0.1 with no issues, but can not ping the gateway at 192.168.0.1 on the client pc, or the switch.
However if I connect the client directly to port fa0/1 on the router that is assigned 10.0.0.1 I am able to reach the internet with no issues.
Current configuration : 1261 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router3.mylab
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.0.0 10.0.0.99
!
ip dhcp pool MY_LAN
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
dns-server 1.1.1.1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description ## INTERNET ##
ip address dhcp
ip access-group MY_WAN in
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
description ## MY LAN ##
ip address 10.0.0.1 255.0.0.0
ip nat inside
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list MY_LAN interface FastEthernet0/0 overload
!
ip access-list standard MY_LAN
permit 10.0.0.0 0.255.255.255
!
ip access-list extended MY_WAN
permit tcp any any established
deny tcp any any
permit ip any any
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
Thank you,
Devin
04-23-2018 09:45 PM
Hi,
This is becuase you don't have any route on your router and I am not sure about your Gateway (192.168.0.1).
Add a route on router:
IP route 0.0.0.0 0.0.0.0 FastEthernet0/0
and check the route on your Gateway for the 10.0.0.0/8. If not then you have to add.
Regards,
Deepak Kumar
04-24-2018 04:53 AM
Hello Deepak,
First let me say thank you to everyone that helped. I found that I had already and the router configured properly. I did not understand why it was not working and retraced my lines. I found that at some point during testing I had fa0/24 on the switch connected to fa0/0 on router therefor when I would disconnect main working line from switch I would loose access.
Sometimes it is good to start at 0 and work your way up.
Thanks again,
Devin
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide