cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
689
Views
0
Helpful
0
Replies

Router is not able to find proper routes.

prabinchand
Level 1
Level 1

Hello experts !

i am doing dmvpn with dual hub but the problem is HO-primary router is all OK but HO-secondary router is malfunctioning. HO-secondary & primary & branch is configured with EIGRP broadcasting the tunnel and LAN network.

HO-primary & branch is getting the route from tunnel-1 but only the HO-secondary router is getting route from fa0/1.

Note: 1. Topology and HO-secondary route picture is attached below:

         2. No any config is done on ISP & LAN-switch, it is just a L2 link.

CONFIGURATION:

HEAD-OFFICE-PRIMARY:

 

HEAD-OFFICE-PRIMARY#sh run
Building configuration...

Current configuration : 1979 bytes
!
! Last configuration change at 15:02:37 UTC Tue Jan 18 2022
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname HEAD-OFFICE-PRIMARY
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel1
description ***PRIMARY - TUNNEL****
ip address 50.50.50.1 255.255.255.248
no ip redirects
ip nhrp authentication SECURE
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip tcp adjust-mss 1340
delay 100
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 123456
tunnel path-mtu-discovery
!
interface Tunnel2
description ***SECONDARY -TUNNEL***
ip address 60.60.60.1 255.255.255.248
no ip redirects
ip nhrp authentication SECURE2
ip nhrp map multicast dynamic
ip nhrp network-id 2
ip tcp adjust-mss 1340
delay 200
tunnel source FastEthernet1/1
tunnel mode gre multipoint
tunnel key 456456
tunnel path-mtu-discovery
!
interface FastEthernet0/0
description ***PRIMARY ISP***
ip address 1.1.1.1 255.255.255.248
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
standby 1 ip 192.168.10.10
standby 1 priority 110
standby 1 preempt
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description ***SECONDARY ISP***
ip address 2.2.2.1 255.255.255.248
speed auto
duplex auto
!
!
router eigrp 100
network 50.50.50.0 0.0.0.7
network 60.60.60.0 0.0.0.7
network 192.168.10.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

HEAD-OFFICE SECONDARY:

 

HEAD-OFFICE-SECONDAR(config)#do sh run
Building configuration...

Current configuration : 1705 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname HEAD-OFFICE-SECONDARY
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel1
ip address 50.50.50.3 255.255.255.248
no ip redirects
ip nhrp authentication SECURE
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 123456
!
interface Tunnel2
description ***SECONDARY -TUNNEL***
ip address 60.60.60.3 255.255.255.248
no ip redirects
ip nhrp authentication SECURE2
ip nhrp map multicast dynamic
ip nhrp network-id 2
tunnel source FastEthernet1/1
tunnel mode gre multipoint
tunnel key 456456
!
interface FastEthernet0/0
ip address 1.1.1.3 255.255.255.248
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 192.168.10.2 255.255.255.0
standby 1 ip 192.168.10.10
standby 1 preempt
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description ***SEDONDARY - ISP***
ip address 2.2.2.3 255.255.255.248
speed auto
duplex auto
!
!
router eigrp 100
network 50.50.50.0 0.0.0.7
network 60.60.60.0 0.0.0.7
network 192.168.10.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

BRANCH:

 

BRANCH#sh run
Building configuration...

Current configuration : 2436 bytes
!
! Last configuration change at 15:05:28 UTC Tue Jan 18 2022
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname BRANCH
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 192.168.100.100 255.255.255.255
!
interface Tunnel1
description ***PRIMARY - TUNNEL***
ip address 50.50.50.2 255.255.255.248
no ip redirects
ip nhrp authentication SECURE
ip nhrp map multicast dynamic
ip nhrp map multicast 1.1.1.1
ip nhrp map 50.50.50.1 1.1.1.1
ip nhrp map 50.50.50.3 1.1.1.3
ip nhrp map multicast 1.1.1.3
ip nhrp network-id 1
ip nhrp nhs 50.50.50.1 priority 1 cluster 1
ip nhrp nhs 50.50.50.3 priority 2 cluster 1
ip nhrp nhs cluster 1 max-connections 1
ip nhrp nhs fallback 2
ip tcp adjust-mss 1340
delay 10
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 123456
!
interface Tunnel2
description ***SECONDARY - TUNNEL ***
ip address 60.60.60.2 255.255.255.248
no ip redirects
ip nhrp authentication SECURE2
ip nhrp map multicast 2.2.2.1
ip nhrp map 60.60.60.1 2.2.2.1
ip nhrp map 60.60.60.3 2.2.2.3
ip nhrp map multicast 2.2.2.3
ip nhrp network-id 2
ip nhrp nhs 60.60.60.1 priority 1 cluster 2
ip nhrp nhs 60.60.60.3 priority 2 cluster 2
ip nhrp nhs cluster 2 max-connections 1
ip nhrp nhs fallback 2
ip tcp adjust-mss 1340
delay 20
tunnel source FastEthernet1/1
tunnel mode gre multipoint
tunnel key 456456
!
interface FastEthernet0/0
description ***PRIMARY -ISP***
ip address 1.1.1.2 255.255.255.248
speed auto
duplex auto
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description ***SECONDARY -ISP***
ip address 2.2.2.2 255.255.255.248
speed auto
duplex auto
!
!
router eigrp 100
network 50.50.50.0 0.0.0.7
network 60.60.60.0 0.0.0.7
network 192.168.100.100 0.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

0 Replies 0
Review Cisco Networking for a $25 gift card