cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2312
Views
0
Helpful
9
Replies
iggiggitoo
Beginner

Router not using all available bandwidth?

I am having trouble with a T1 connection between a cisco 7200VXR and cisco 2600. I have no problem connecting across it, but when I run a download across the link I get a flat 6KB/s. I can't seem to find what is wrong in my configuration that would be causing this.

7200 Router:

#show running

Building configuration...

Current configuration : 2262 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RTR1

!

boot-start-marker

boot system flash disk0:c7200-a3jk9s-mz.124-25.bin

boot-end-marker

!

enable secret 5 ...

!

aaa new-model

!

!

!

aaa session-id common

!

!

ip cef

ip domain name RTR1

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

username root password 0 abcd

!

!

controller T1 1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

description T1 connection

!

controller T1 1/1

framing esf

linecode b8zs

!

controller T1 1/2

framing esf

linecode b8zs

!

controller T1 1/3

framing esf

linecode b8zs

!

controller T1 1/4

framing esf

linecode b8zs

!

controller T1 1/5

framing esf

linecode b8zs

!

controller T1 1/6

framing esf

linecode b8zs

!

controller T1 1/7

framing esf

linecode b8zs

!

ip ssh time-out 60

ip ssh authentication-retries 2

ip ssh version 1

!

!

!

!

!

interface FastEthernet0/0

description uplink

ip address 1.2.3.5 255.255.255.0 secondary

ip address 1.2.3.4 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

description uplink 2

ip address 1.2.4.5 255.255.255.0

duplex auto

speed auto

!

interface Serial1/0:0

description T1

ip address 10.2.1.1 255.255.255.248

ip nat inside

ip virtual-reassembly

!

!

ip default-gateway 209.124.33.1

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 1.2.3.1

ip route 10.2.7.0 255.255.255.0 10.2.1.2

!

no ip http server

no ip http secure-server

!

ip nat inside source static 10.2.7.2 1.2.3.5

!

access-list 99 permit 10.2.1.0 0.0.0.255

!

!

!

control-plane

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

transport output all

stopbits 1

line aux 0

transport output all

stopbits 1

line vty 0 4

transport input ssh

transport output all

line vty 5 15

access-class 99 in

transport input ssh

!

!

end

Controller:

#show controller T1

T1 1/0 is up.

  Applique type is Channelized T1

  Cablelength is long gain36 0db

  Description: T1

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Framing is ESF, Line Code is B8ZS, Clock Source is Internal.

  Data in current interval (270 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

  Total Data (last 24 hours)

     0 Line Code Violations, 3 Path Code Violations,

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

     1 Errored Secs, 1 Bursty Err Secs, 0 Severely Err Secs, 130 Unavail Secs

Interface:

#

Serial1/1:0 is up, line protocol is up

  Hardware is Multichannel T1

  Description: to the Flint Farmers Market

  Internet address is 10.2.1.1/29

  MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, crc 16, Data non-inverted

  Keepalive set (10 sec)

  Last input 00:00:02, output 00:00:00, output hang never

  Last clearing of "show interface" counters 02:27:54

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/3/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1152 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     6307 packets input, 512222 bytes, 0 no buffer

     Received 965 broadcasts, 1 runts, 0 giants, 0 throttles

     1 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     5594 packets output, 4701504 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     1 carrier transitions

  no alarm present

  Timeslot(s) Used:1-24, subrate: 64Kb/s, transmit delay is 0 flags

2600 Router:

#show running

Building configuration...

Current configuration : 839 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RTR2

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

enable secret 5 ...

enable password 7 ...

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

!

!

!

!

interface Ethernet0/0

description Link to Local Network

ip address 10.2.7.1 255.255.255.252

full-duplex

no cdp enable

!

interface Serial0/0

description Link to RTR1 Serial1/0:0

ip address 10.2.1.2 255.255.255.248

fair-queue

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.2.1.1

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password 7 ...

login

!

!

end

Interface:

#show interfaces serial 0/0

Serial0/0 is up, line protocol is up

  Hardware is PQUICC with Fractional T1 CSU/DSU

  Description: Link to RTR1 Serial1/0:0

  Internet address is 10.2.1.2/29

  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input 00:00:01, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/5/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1158 kilobits/sec

  5 minute input rate 1000 bits/sec, 1 packets/sec

  5 minute output rate 1000 bits/sec, 1 packets/sec

     8680 packets input, 1005109 bytes, 0 no buffer

     Received 2958 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     11361 packets output, 1766828 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 output buffer failures, 0 output buffers swapped out

     1 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

edit- added updates interface output

9 REPLIES 9
Leo Laohoo
VIP Community Legend

53747 input errors, 1895 CRC, 0 frame, 0 overrun, 0 ignored, 26043 abort

Maybe this is the reason?

Sometimes It takes another set of eyes to look at it, I made the mistake of reading 0 CRC on the 2600 side and didn't even pay attention to the 7200 CRC stats.

Thank you, I will have a tech look at the line and see if that is the problem.

Even after the technicians repaired the line and I am no longer seeing CRC errors on either side I am still getting poor performance (~6KB/s), any other thoughts?

Leo Laohoo
VIP Community Legend

If the link flat-lines at 6kbps then I'm suspecting the service provider is throttling it somewhere in their network.

Make sure you have no suspicious log entries on both routers.  Can you post the "sh proc cpu history" of both routers?

Is it slow one way or BOTH ways?

Hi Eric,

Either you can ask your SP to do an onsite throughput test or make an Iperf test yourself.

Sent from Cisco Technical Support iPhone App

Please try download after disabling fair-quque.

interface Serial0/0

description Link to RTR1 Serial1/0:0

ip address 10.2.1.2 255.255.255.248

fair-queue

thanks

ajay

2600#sh proc cpu history

RTR2  09:12:54 PM Tuesday Mar 2 1993 UTC

                                     11111

100

90

80

70

60

50

40

30

20

10

   0....5....1....1....2....2....3....3....4....4....5....5....

             0    5    0    5    0    5    0    5    0    5

               CPU% per second (last 60 seconds)

    22111111 2 1115653                      1       11  1

100

90

80

70

60

50

40

30

20

10               ***

   0....5....1....1....2....2....3....3....4....4....5....5....

             0    5    0    5    0    5    0    5    0    5

               CPU% per minute (last 60 minutes)

              * = maximum CPU%   # = average CPU%

                                         11 1   8

    611111111111111641411111111111111111115161116

100

90                                             *

80                                             *

70                                             *

60                                             *

50                                             *

40                                             *

30                                             *

20                                       * *   *

10 *              *                     ** *   *

   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7.

             0    5    0    5    0    5    0    5    0    5    0    5    0

                   CPU% per hour (last 72 hours)

                  * = maximum CPU%   # = average CPU%

7200:

#sh proc cpu history

ETS-DET-RTR1   08:08:06 AM Thursday Aug 11 2011 UTC

    999999999999999999999999999999999999999999999999999999999999

    777999999999999999999999999888887777777777766666555566666655

100 ************************************************************

90 ************************************************************

80 ************************************************************

70 ************************************************************

60 ************************************************************

50 ************************************************************

40 ************************************************************

30 ************************************************************

20 ************************************************************

10 ************************************************************

   0....5....1....1....2....2....3....3....4....4....5....5....6

             0    5    0    5    0    5    0    5    0    5    0

               CPU% per second (last 60 seconds)

    9999999999999999999

    8999899788899999998                      1      1

100 #####*############*

90 #####*############*

80 #####*############*

70 ###################

60 ###################

50 ###################

40 ###################

30 ###################

20 ###################

10 ###################

   0....5....1....1....2....2....3....3....4....4....5....5....6

             0    5    0    5    0    5    0    5    0    5    0

               CPU% per minute (last 60 minutes)

              * = maximum CPU%   # = average CPU%

    1111111 1111 1999 912   11    111111 917912  2  111   1 11 2    1111 11

    110211580491889999970696128768141433695190476468048897395570899940966407

100               *** *                  *  *

90               *** *                  *  *

80               *** *                  *  *

70               *** *                  * **

60               *** *                  * **

50               *** *                  * **

40               *** *                  * **

30               *** *                  * **

20       *   *  **** #**                **** *  *    *     ** *      **

10 **************##**#*********************#*******************************

   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..

             0    5    0    5    0    5    0    5    0    5    0    5    0

                   CPU% per hour (last 72 hours)

                  * = maximum CPU%   # = average CPU%

Now, that looks interesting, I have no idea why that is happening.

#sh proc cpu sorted

CPU utilization for five seconds: 99%/86%; one minute: 90%; five minutes: 69%

PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process

191      111604   1456919         76 13.39%  7.93%  4.38%   0 IP NAT Ager

  78       31932     20011       1595  0.16%  0.25%  0.96%   2 SSH Process

  39       45656     41723       1094  0.08%  0.02%  0.00%   0 Logger

  25      289496   3644350         79  0.08%  0.02%  0.00%   0 ARP Input

  67     3299712    416575       7921  0.08%  1.98%  1.30%   0 IP Input

  26         348    220233          1  0.08%  0.00%  0.00%   0 HC Counter Timer

   6        6476       720       8994  0.00%  0.00%  0.00%   0 Pool Manager

   8          20      9876          2  0.00%  0.00%  0.00%   0 Serial Backgroun

Looks like NAT is using a lot of CPU usage, but still does not add up to 100%. Any Ideas?

So I added some shorter timeouts to nat, but I am still seeing extremely high CPU usage.

#sh proc cpu sorted

CPU utilization for five seconds: 97%/96%; one minute: 98%; five minutes: 97%

PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process

   5      503596     76507       6582  0.49%  0.07%  0.06%   0 Check heaps

  39       63552     44058       1442  0.08%  0.02%  0.00%   0 Logger

  29       51456     76980        668  0.08%  0.03%  0.01%   0 EEM ED Syslog

105        6092   1034109          5  0.08%  0.00%  0.00%   0 CEF process

  41       23288    748560         31  0.08%  0.03%  0.02%   0 Per-Second Jobs

   2       30880    149949        205  0.00%  0.01%  0.00%   0 Load Meter

   6        6476       727       8907  0.00%  0.00%  0.00%   0 Pool Manager

   4           0         1          0  0.00%  0.00%  0.00%   0 EDDRI_MAIN

   9           0         2          0  0.00%  0.00%  0.00%   0 ATM Idle Timer

   3           0         1          0  0.00%  0.00%  0.00%   0 chkpt message ha

   1          28       248        112  0.00%  0.00%  0.00%   0 Chunk Manager

  12           0         2          0  0.00%  0.00%  0.00%   0 AAA high-capacit

   7           0         2          0  0.00%  0.00%  0.00%   0 Timers

   8          40      9918          4  0.00%  0.00%  0.00%   0 Serial Backgroun

  10           0         2          0  0.00%  0.00%  0.00%   0 ATM AutoVC Perio

  16           0         1          0  0.00%  0.00%  0.00%   0 RO Notify Timers

  17        8396    746977         11  0.00%  0.00%  0.00%   0 EnvMon

  18           0         1          0  0.00%  0.00%  0.00%   0 OIR Handler

  19           4     12515          0  0.00%  0.00%  0.00%   0 IPC Dynamic Cach

  11           0         2          0  0.00%  0.00%  0.00%   0 ATM VC Auto Crea

  13           0         1          0  0.00%  0.00%  0.00%   0 AAA_SERVER_DEADT