05-09-2021 08:11 AM
Hello, I recently started setting up a ccna lab and one of my main objectives was connecting internet through the serial interface for a Hwic T1 dsu/csu module. I am stuck after the intial point of applying my static addresses and pinging for connectivity. I do not have a default-gateway set up. nor a ip route.
Here is my router 0-
Router0#show run
Building configuration...
Current configuration : 1802 bytes
!
! Last configuration change at 14:21:02 UTC Sun May 9 2021
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router0
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
memory-size iomem 15
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip dhcp pool Practice2
network 192.168.138.0 255.255.255.0
default-router 192.168.138.1
dns-server 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO1921/K9 sn FTX1752835R
license accept end user agreement
license boot module c1900 technology-package securityk9
license boot module c1900 technology-package datak9
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.138.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/1/0
description LINK to R2
ip address 10.2.2.2 255.255.255.252
!
!
router eigrp 1
network 10.0.0.0
network 192.168.137.0
network 192.168.138.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ipv6 ioam timestamp
!
!
access-list 1 permit any
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
Router0#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/41/60 ms
__________________________________________________________
Here is my Router2:
Router2#show run
Building configuration...
Current configuration : 1871 bytes
!
! Last configuration change at 14:16:58 UTC Sun May 9 2021
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
!
no aaa new-model
memory-size iomem 15
!
!
!
Router2#show run
Building configuration...
Current configuration : 1871 bytes
!
! Last configuration change at 14:16:58 UTC Sun May 9 2021
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
!
no aaa new-model
memory-size iomem 15
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip dhcp pool Router3
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
dns-server 8.8.8.8
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO1921/K9 sn FJC1925E16C
license accept end user agreement
license boot module c1900 technology-package securityk9
license boot module c1900 technology-package datak9
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0/1/0
description LINK to R1
ip address 10.2.2.1 255.255.255.252
ip nat outside
ip virtual-reassembly in
service-module t1 remote-loopback payload v54
!
!
router eigrp 1
network 10.0.0.0
network 192.168.100.0
network 192.168.137.0
network 192.168.138.0
!
ip default-gateway 192.168.137.2
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat source list 1 interface Serial0/1/0 overload
!
ipv6 ioam timestamp
!
!
access-list 1 permit any
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
Router2#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
PLEASE MUCH HELP IS NEEDED
Solved! Go to Solution.
05-09-2021 01:06 PM
I figured it out. The NAT inside command wasnt applied on the s0/1/0 interface. Thankyou for your quick responses.
05-09-2021 11:56 AM
It looks like router0 is working and router2 is not. The most important issue on router2 is this
ip default-gateway 192.168.137.2
ip default-gateway is used when the router is operating as a host device (ip routing not enabled). When ip routing is enabled (the default on a router) then the default-gateway command is ignored. One way to fix the problem is to configure a static default route on router2.
05-09-2021 12:40 PM
I will try that. Thanks
05-09-2021 01:06 PM
I figured it out. The NAT inside command wasnt applied on the s0/1/0 interface. Thankyou for your quick responses.
05-09-2021 12:26 PM
For us to understand make a small network diagram of what ports connect to where?
Internet ----Router 0---Serial cable---Router X --Lan
Then Router 0 already doing NAT, so you no need to do NAt again on router X
make sure you need Routing working to reach Router 0, Router 0 routing going out to the Internet.
05-09-2021 12:40 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide