cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

3139
Views
0
Helpful
5
Replies
Highlighted
Beginner

Routing Magic packets

I am trying to allow magic packets from our management servers to client PCs located over routed links. 

The management servers are on addresses 172.22.200.54/16 and 172.22.200.63/16

They are directly connected to a 6500 to vlan 1 (GI 1/30 and GI 2/14)

Interface GI7/5 on the 6500 is a routed interface 172.25.200.213/30 and connects to a remote switch i am trying to send magic packets to.

At the far end, Connected via fibre to GI 7/5 is a 3750, port GI 1/0/1 is configured as a routed port and has address 172.25.200.214/30.

On the 3750 are two vlans one for data (vlan 100) 172.21.20.x/24 and one for voice (vlan 300) 172.18.20.x/24, the default gateway for all traffic is back to the 6500.  All other ports on the 3750 are assigned to vlan 100 and 300 for voice

I am trying to get magic packets (only) to be be routed, as far as i understand they are not routed as they are broadcast traffic.

Where do i need to place the ip helper-address and the ip directed-broadcast?  Here is what i have so far (but doesnt work) 

3750:

interface GigabitEthernet1/0/1

description Fibre to 6500

no switchport

ip address 172.25.200.214 255.255.255.252

ip directed-broadcast

mls qos trust dscp

interface Vlan100

description DATA VLAN

ip address 172.21.20.254 255.255.255.0

ip helper-address 172.22.200.50

6500:

interface GigabitEthernet7/5

description TTH-SWITCH18

ip address 172.25.200.213 255.255.255.252

ip helper-address 172.21.11.255

wrr-queue bandwidth 50 255

mls qos trust dscp

interface GigabitEthernet1/30

description Management-Server1

switchport

wrr-queue bandwidth 50 255

mls qos trust dscp

spanning-tree portfast edge

interface Vlan1

ip address 172.22.1.21 255.255.0.0

no ip redirects

ip pim sparse-dense-mode

standby 1 ip 172.22.1.20

standby 1 priority 120

standby 1 preempt

I first wanted to get the WOL working over the routed ports and then restrict it to only WOL traffic/from management servers, so was planning on including an ACL but havent done this part yet.

Can anyone assist me to get this to work?

Thanks

Jeff

Everyone's tags (3)
5 REPLIES 5
Hall of Fame Master

Routing Magic packets

Gelper address is always configure on the interface that initially received the UDP broadcast.

Also, the the destation port is not one of these forwarded by default, you will need to configure it explicitly.

Beginner

Routing Magic packets

Paolo, if the helper address goes on the interface that recives the broadcast, in this instance is that vlan1 that would need a helper address specified?

Are you also saying i need to configure an ACL to be able to specify the port used for it to work?

Thanks

Jeff

Rising star

Routing Magic packets

Hey Jeff,

to clarify the scenario, and then help... do you want broadcasts (magic packets) from the Servers reach your client segment and received by clients as broadcast there or u just need one client receive those packets as unicast?

two different approaches


Soroush.

Hope it Helps!

Soroush.
Beginner

Routing Magic packets

Soroush, i have about 6 client PC's that i need to be able to wake up so i was going to go to use broadcast since it will be the same management servers sending the magic packet, i thought it easier to do it this way.

Thanks

Jeff

Rising star

Routing Magic packets

right Jeff, then i think what you need to do is using Multicast helper address.

multicast helper address, captures the broadcast at the origination segment, then convert to multicast, send it to its destination and then again convert it back to broadcast. u need to know what UDP port is in use by the broadcast.

setup a multicast group and use below config as an example for ur network:

** Assuming that u have done the multicast part right, here is what you have to do for below diagram

Server----VLAN1---(6500)--Gi7/5------------Gi1/0/1--(3750)---VLAN100---Client

6500:

interface Vlan1

ip multicast helper-map broadcast 239.10.10.1 120  ---> multicast grp & ACL#

ip pim sparse-mode

exit

!

access-list 120 permit udp host x.x.x.x any udp 3000 ----> broadcast udp port

!

ip forward-protocol udp 3000 ----> config right port

3750:

int gi1/0/1

ip pim sparse-mode

ip multicast helper-map 239.10.10.1 172.21.20.255 120 ---> dst broadcast ip & ACL

!

int vlan 100

ip directed-broadcast

exit

!

access-list 120 permit udp host x.x.x.x any eq 3000

ip forward-protocol udp 3000

Hope it Helps,

plz Rate helpful posts,

Soroush.

Hope it Helps!

Soroush.
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here