cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

287
Views
0
Helpful
7
Replies
Beginner

Routing Options for a new backup link

Hi, 

 

I'd like to ask for some help on what the best option in this network that we have.

 

A little background. We have this 4Mbps DLL  that we used to link up at the other site. Last month we finally were able to purchase a back up link of 2Mbps for the site. Now, I want to aggregate both of these links to have a total bandwidth of 6Mbps however if its not possible I'd settle for an active-standby link.

 

The current network looks like this

 

site setup.PNG

 

All routing are statics. There is no router after the Distribution switches, it directly connects  to the telco's local switch at the site. SiteB I believe only has 1 router that receives both of our links and would be terminated at the same router.

My question is. 

 

1) If I want to combine my links, do I have to use bgp multi-path? I don't think i'll be able to combine them without a router in front of the distribution switches or by not using bgp multi-path

 

2) If I want to make them into an active passive  link, how do I tackle this? Should I use a floating static route with SLAs toward the primary link and in the event it goes down use the backup link static route? Or its possible to do this via int vlan hsrp ?

 

Thanks

7 REPLIES 7
Highlighted
VIP Advisor

Re: Routing Options for a new backup link

personally i do not believe you have aggregated bw here 6MB as single Pipe.

 

Instead, you can use a different way to utilize both the Links in a better way.

 

Do you have BGP in place ?

 

below options thinking you do not have BGP in place.

 

Options1 :

 

1. You can not have full redundant, since both the links are not equal. so if 4MB Link go down, you have only 2MB as standby, but not bad at least you have connectivity and there may be slowness reports here.

2. yes you need to configure IP SLA to track the link and failover if 4MB Fails to 2MB Links, once the 4MB Links up automatically restore the traffic back to 4MB for better performance.

 

Option2 :

 

1. you can use 4MB and 2MB Link both at a time, with PBR distribute the Load such a way, some Traffic go via 2MB Link.

2. Same way above IP SLA, you going to implement both the links

3. If 4MB Link go down, failover the traffic to 2MB.

4. if 2MB Link go down implement IP SLA to failover to 4MB

 

 

here good example kind of setup you looking.

 

http://letusexplain.blogspot.com/2014/04/ip-sla-tracking-configuration-with.html

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Routing Options for a new backup link

Hi all,


Apologies for the late reply as it took some time to obtain the configuration of the router at the remote site and I finally have a complete picture on the routing between the 2 sites.

@balaji.bandi

Thanks for the link. This mirror's the configuration we have right now at the moment although I h

@Georg Pauwen

yeah I agree. D101 and 102 are both old C3560s. I'm not really sure how to do GLBP on both since the one receiving them on the other end is just a single router terminating at their Fa0/1 and Fa0/2 respectively.

@paul driver

Is this in relation to the dual connectivity to/from site 2 - dual connectivity. basically want to use both of the links but active or passive is fine -

what about the corp core do you want to traffic engineer this also? - if dual connectivity cannot be obtained, I want to retain using the 4mbps as primary and only have the 2 Mbps act as a backup.


You mention you using static routing, but you also mention bgp also so can elaborate on this please? - all routes in the L3 switch are static, but I'm open on using bgp if it means I can aggregate both of the links

@Joseph W. Doherty

Hi Joseph, thanks. Do you have an example of this? I'm using route-maps right now to force the traffic to our SiteB. If I can't achieve aggregation of links I'm fine with a passive - active on our DLLs.


Also here are the configs

D101

=====================================

track 100 ip sla 100
!

interface GigabitEthernet0/1
description *** to siteB ***
no switchport
ip address 10.1.1.2 255.255.255.252


ip route 172.16.210.31 255.255.255.255 10.1.1.1 name SITEB
ip route 172.16.210.34 255.255.255.255 10.1.1.1 name SITEB



ip sla 100
icmp-echo 10.1.1.1 source-ip 10.1.1.2
frequency 5
ip sla schedule 100 life forever start-time now


access-list 101 permit ip 10.10.10.0 0.0.0.255 host 172.16.210.31
access-list 101 permit ip 10.10.10.0 0.0.0.255 host 172.16.210.34


route-map SITEB permit 30
match ip address 101
set ip next-hop 10.1.1.1



SITEB

======================================

Fa0/1
description ***TO CORP***
ip address 10.1.1.1 255.255.255.252
speed auto
full-duplex


ip route 10.10.10.0 255.255.255.0 10.1.1.2


Proposed config

Fa0/2
desc ***TO CORP BACKUP***
ip add 10.2.2.1 255.255.255.252

ip route 10.10.10.0 255.255.255.0 10.2.2.2 250


D102
=========================================

int Gi0/1
description *** to siteB secondary ***
no switchport
ip address 10.2.2.2 255.255.255.252

Thanks
VIP Mentor

Re: Routing Options for a new backup link

Hello,

 

in addition to Balaji's suggestions: not sure how your hosts are connected to the core, but since you have two links that you pay for, you might as well use them both. GLBP with weighted load-balancing could work. What devices exactly are D101 and D102 ?

VIP Mentor

Re: Routing Options for a new backup link

Hello


@ShadowoftheD wrote:

Hi, 

 

I'd like to ask for some help on what the best option in this network that we have.

 

A little background. We have this 4Mbps DLL  that we used to link up at the other site. Last month we finally were able to purchase a back up link of 2Mbps for the site. Now, I want to aggregate both of these links to have a total bandwidth of 6Mbps however if its not possible I'd settle for an active-standby link.

Is this in relation to the dual connectivity to/from site 2 or does this query relate to multiple site with the same design - what about the corp core do you want to traffic engineer this also?

You mention you using static routing, but you also mention bgp also so can elaborate on this please?

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
VIP Expert

Re: Routing Options for a new backup link

For outbound, perhaps the "best" way to take advantage of both link's bandwidth is PfR, which can perform dynamic load balancing. It can also do dynamic ingress load balancing too, but that's much more complicated.
VIP Mentor

Re: Routing Options for a new backup link

Hello


@ShadowoftheD wrote:

1) If I want to combine my links, do I have to use bgp multi-path? I don't think i'll be able to combine them without a router in front of the distribution switches or by not using bgp multi-path 

 

2) If I want to make them into an active passive  link, how do I tackle this? Should I use a floating static route with SLAs toward the primary link and in the event it goes down use the backup link static route? Or its possible to do this via int vlan hsrp ?

 


1-you are correct - you'll require a router interconnected between both switches  to perform bgp- multipath that is unless the switch's are stacked and bgp is applicable on 3560s or another option to load balance using any igp such as osp) and/or incorporate perfromance edge routing as suggest by Joseph.
However without a router your options are limited and I would say at this time PBR is the better option.

 

2 if they are stacked you do have options in addition to the other suggestions such as flex link or link state tracking

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Routing Options for a new backup link


@paul driver wrote:

1-you are correct - you'll require a router interconnected between both switches  to perform bgp- multipath that is unless the switch's are stacked and bgp is applicable on 3560s or another option to load balance using any igp such as osp) and/or incorporate perfromance edge routing as suggest by Joseph.

However without a router your options are limited and I would say at this time PBR is the better option.

 

2 if they are stacked you do have options in addition to the other suggestions such as flex link or link state tracking

 


Is there an option PBR to track the link? it does follow the route-map configuration but i need tracking for failover

EDIT: forgot the reachability option

 

not stacked. not a fan of stacked switches as well 

 

Thanks mate, will test this out in the lab and see how it works

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here