12-05-2018 11:58 PM - edited 03-05-2019 11:05 AM
Greetings,
So, I have traffic from the LAN side:
interface GigabitEthernet0/0/1.10
encapsulation dot1Q 10
ip dhcp relay information trusted
ip address 10.x.x.x 255.255.255.192
ip helper-address 10.y.y.y
ip policy route-map mymap
that needs to be routed into this tunnel:
interface Tunnel0
ip unnumbered GigabitEthernet0/0/1
ip tcp adjust-mss 1332
tunnel source GigabitEthernet0/0/0
tunnel mode ipip
tunnel destination 81.a.a.a
tunnel path-mtu-discovery
route-map mymap permit 10
set interface Tunnel0
ip route 0.0.0.0 0.0.0.0 217.b.b.b.b
ip route 10.0.0.0 255.0.0.0 Null0
ip route 10.r.r.r 255.255.255.0 Tunnel0
ip route 10.s.s.s 255.255.255.0 Tunnel0
ip route 10.t.t.t. 255.255.255.0 Tunnel0
This setup works as long as I don't use dot1q subinterfaces. With subinterfaces it only works if I use a vrf.
Can this be done without using vrfs?
12-06-2018 12:31 AM
Hello
@RemRem wrote:
Greetings,
So, I have traffic from the LAN side:
interface GigabitEthernet0/0/1.10
encapsulation dot1Q 10
ip dhcp relay information trusted
ip address 10.x.x.x 255.255.255.192
ip helper-address 10.y.y.y
ip policy route-map mymapthat needs to be routed into this tunnel:
interface Tunnel0
ip unnumbered GigabitEthernet0/0/1
ip tcp adjust-mss 1332
tunnel source GigabitEthernet0/0/0
tunnel mode ipip
tunnel destination 81.a.a.atunnel path-mtu-discovery
route-map mymap permit 10
set interface Tunnel0
ip route 0.0.0.0 0.0.0.0 217.b.b.b.b
ip route 10.0.0.0 255.0.0.0 Null0
ip route 10.r.r.r 255.255.255.0 Tunnel0
ip route 10.s.s.s 255.255.255.0 Tunnel0
ip route 10.t.t.t. 255.255.255.0 Tunnel0
This setup works as long as I don't use dot1q subinterfaces. With subinterfaces it only works if I use a vrf.
Can this be done without using vrfs?
Route-map mymap permit 10
No set interface tunnel 0
set is next-hop 8.a..a.a
12-06-2018 01:09 AM
I tried the route-map with set ip next-hop instead of set interface but I still can't reach the 10. nets at the other end of the tunnel.
12-06-2018 01:24 AM - edited 12-06-2018 01:27 AM
Hello
Why do you have a null static for that subnet?
Remove the policy-route from the interface and also the null route, test again..
no ip route 10.0.0.0 255.0.0.0 Null0
interface GigabitEthernet0/0/1.10
no ip policy route-map mymap
12-06-2018 04:02 AM
The Null route drops all traffic to the 10.0.0.0/8 net that is not routed to the specified nets from the other static routes.
I removed it but it made no difference. Same for removing the route-map from the interface GigabitEthernet0/0/1.10.
12-06-2018 04:20 AM
Hello
Do you have reachability over the tunnel - can you ping the tunnel destination
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide