cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
750
Views
0
Helpful
2
Replies

setting up vpdn on 2600 to connect ISP

OneCiscoGuy
Level 1
Level 1

I have configured VPDN/Dialer on router 2600 to connect to our ISP via Fibre Optics modem but its simply not connecting. I need someone to help out please. I'm new to this, so need a clear guide.


The router consists of 3 interfaces

- Inter fa0/0 = 10.0.0.6 255.255.255.248 (LAN 1)

- Inter fa0/1 = IP is unassigned (interface connected to Fibre Optics modem)

- Inter e1/0 = 192.168.200.1 255.255.255.0 (LAN 2)

The connection is planned to run like this:

LAN1 & LAN2 (Inter fa0/0 & Inter e1/0) <-> Inter fa0/1 <-> Dialer1 <-> Modem <-> ISP <-> Internet.

The Modem will just server as mere "modem" or just a bridge, as the actual routing is configured on "dialer interface" in the router.

We're not using a dedicated IP address to link to ISP but a public one.

After configuring the interfaces, VPDN, dialer interface, NAT, access-list, ISP's assigned username/password, etc I'm simply not connecting to our ISP, even when I do a ping. The ISP's IP address which we're pinging is 118.23.8.80

What am I missign out? How do I connect the dots here?

Below are the results for Running config, Ping, and Debug:

---------------

Running Config:

Router1#show running-config

Building configuration...

Current configuration : 3083 bytes

!

! Last configuration change at 17:39:43  Sun Apr 17 2011

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router1

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

logging monitor errors

enable secret 5 xxxxxxxxxxx

!

clock timezone

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

!

ip name-server 10.1.1.150

!

ip cef

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

interface FastEthernet0/0

ip address 10.0.0.6 255.255.255.248

duplex auto

speed auto

!

interface FastEthernet0/1

description Uplink WAN interface, to the ISP modem

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

duplex auto

speed auto

pppoe enable

no cdp enable

!

interface Ethernet1/0

ip address 192.168.200.1 255.255.255.0

ip nat inside

half-duplex

!

interface Dialer1

description Fibre Optics WAN dialer, to the ISP server

ip address negotiated

no ip unreachables

ip mtu 1492

ip nat outside

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxxxxx@xxx.com

ppp chap password 0 xxxxxx

ppp ipcp dns request accept

ppp ipcp address accept

!

router ospf 1

log-adjacency-changes

network 10.0.0.0 0.255.255.255 area 0

network 192.168.0.0 0.0.255.255 area 0

!

ip nat inside source list 10 interface Dialer1 overload

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

access-list 10 permit 10.1.0.0 0.0.255.255

access-list 10 permit 192.168.0.0 0.0.255.255

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

exec-timeout 40 0

line aux 0

line vty 0 4

exec-timeout 20 0

password xxxxxx

login

line vty 5 15

exec-timeout 20 0

password xxxxxx

login

!

End

-------------

Ping result:

Router1#ping 118.23.8.80

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 118.23.8.80, timeout is 2 seconds:

Apr 17 15:36:15.142: IP: tableid=0, s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), routed via RIB

Apr 17 15:36:15.146: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, sending

Apr 17 15:36:15.146: NAT: dialer not up for Dialer1, no translation, dial and drop

Apr 17 15:36:15.146: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, encapsulation failed.

Apr 17 15:36:17.142: IP: tableid=0, s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), routed via RIB

Apr 17 15:36:17.142: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, sending

Apr 17 15:36:17.142: NAT: dialer not up for Dialer1, no translation, dial and drop

Apr 17 15:36:17.142: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, encapsulation failed.

Apr 17 15:36:19.142: IP: tableid=0, s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), routed via RIB

Apr 17 15:36:19.142: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, sending

Apr 17 15:36:19.142: NAT: dialer not up for Dialer1, no translation, dial and drop

Apr 17 15:36:19.142: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, encapsulation failed

Apr 17 15:36:19.202: IP: s=10.0.10.1 (local), d=224.0.0.5 (FastEthernet0/0), len76, sending broad/multicast

Apr 17 15:36:19.202: IP: s=10.0.1.1 (local), d=224.0.0.5 (FastEthernet0/0.1), len 76, sending broad/multicast

Apr 17 15:36:19.202: IP: s=10.1.1.1 (local), d=224.0.0.5 (FastEthernet0/0.2), len 76, sending broad/multicast

Apr 17 15:36:19.206: IP: s=10.1.12.1 (local), d=224.0.0.5 (FastEthernet0/0.3), len 76, sending broad/multicast

Apr 17 15:36:19.206: IP: s=10.1.13.1 (local), d=224.0.0.5 (FastEthernet0/0.4), len 76, sending broad/multicast

Apr 17 15:36:19.206: IP: s=10.1.14.1 (local), d=224.0.0.5 (FastEthernet0/0.5), len 76, sending broad/multicast.

Apr 17 15:36:21.142: IP: tableid=0, s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), routed via RIB

Apr 17 15:36:21.142: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, sending

Apr 17 15:36:21.142: NAT: dialer not up for Dialer1, no translation, dial and drop

Apr 17 15:36:21.142: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, encapsulation failed.

Apr 17 15:36:23.142: IP: tableid=0, s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), routed via RIB

Apr 17 15:36:23.142: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, sending

Apr 17 15:36:23.142: NAT: dialer not up for Dialer1, no translation, dial and drop

Apr 17 15:36:23.142: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, encapsulation failed.

Success rate is 0 percent (0/5)

-------------------------------------------------

The Debug result:

Apr 17 15:59:34.926: CEF: background resolution thread state:

Apr 17 15:59:34.926: Thread fast_thread: Empty

Apr 17 15:59:34.926: Thread todothread: Empty

Apr 17 15:59:34.926: Thread slow_thread: Empty

Apr 17 15:59:35.926: CEF: background resolution thread state:

Apr 17 15:59:35.926: Thread fast_thread: Empty

Apr 17 15:59:35.926: Thread todothread: Empty

Apr 17 15:59:35.926: Thread slow_thread: Empty

Apr 17 15:59:36.302: SNMP: HC Timer 82C875A8 fired

Apr 17 15:59:36.302: SNMP: HC Timer 82C875A8 rearmed, delay = 5000

Apr 17 15:59:36.362: IP: tableid=0, s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), routed via RIB

Apr 17 15:59:36.362: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, sending

Apr 17 15:59:36.362: NAT: dialer not up for Dialer1, no translation, dial and drop

Apr 17 15:59:36.362: Di1 DDR: ip (s=10.1.12.1, d=118.23.8.80), 100 bytes, outgoing interesting (ip PERMIT)

Apr 17 15:59:36.362: DDR: 45000064 00910000 FF013097 0A010201 76170858 080041B2

Apr 17 15:59:36.366: DDR: 001D0000 00000000 4D86EEF4 ABCDABCD ABCDABCD ABCDABCD

Apr 17 15:59:36.370: Di1 DDR: dialer_fsm_idle()

Apr 17 15:59:36.370: Di1 DDR: Cannot place call, no dialer string set

Apr 17 15:59:36.370: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, encapsulation failed

Apr 17 15:59:36.482: crm_send_periodic_update

Apr 17 15:59:36.642: SNMP: HC Timer 82C2DFB4 fired

Apr 17 15:59:36.642: SNMP: HC Timer 82C2DFB4 rearmed, delay = 20000.

Apr 17 15:59:36.930: CEF: background resolution thread state:

Apr 17 15:59:36.930: Thread fast_thread: Empty

Apr 17 15:59:36.930: Thread todothread: Empty

Apr 17 15:59:36.930: Thread slow_thread: Empty

Apr 17 15:59:37.934:

Apr 17 15:59:37.934: Rudpv1 Sent: Pkts 0,  Data Bytes 0,  Data Pkts 0

Apr 17 15:59:37.934: Rudpv1 Rcvd: Pkts 0,  Data Bytes 0,  Data Pkts 0

Apr 17 15:59:37.938: Rudpv1 Discarded: 0,  Retransmitted 0

Apr 17 15:59:37.938:

Apr 17 15:59:37.938: CEF: background resolution thread state:

Apr 17 15:59:37.938: Thread fast_thread: Empty

Apr 17 15:59:37.938: Thread todothread: Empty

Apr 17 15:59:37.938: Thread slow_thread: Empty

Apr 17 15:59:38.358: IP: tableid=0, s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), routed via RIB

Apr 17 15:59:38.358: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, sending

Apr 17 15:59:38.358: NAT: dialer not up for Dialer1, no translation, dial and drop

Apr 17 15:59:38.358: Di1 DDR: ip (s=10.1.12.1, d=118.23.8.80), 100 bytes, outgoing interesting (ip PERMIT)

Apr 17 15:59:38.358: DDR: 45000064 00920000 FF013096 0A010201 76170858 080039E5

Apr 17 15:59:38.362: DDR: 001D0001 00000000 4D86F6C0 ABCDABCD ABCDABCD ABCDABCD

Apr 17 15:59:38.366: Di1 DDR: dialer_fsm_idle()

Apr 17 15:59:38.366: Di1 DDR: Cannot place call, no dialer string set

Apr 17 15:59:38.366: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, encapsulation failed

Apr 17 15:59:38.942: CEF: background resolution thread state:

Apr 17 15:59:38.942: Thread fast_thread: Empty

Apr 17 15:59:38.942: Thread todothread: Empty

Apr 17 15:59:38.942: Thread slow_thread: Empty

Apr 17 15:59:39.202: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0 from 10.0.10.1

Apr 17 15:59:39.202: IP: s=10.0.10.1 (local), d=224.0.0.5 (FastEthernet0/0), len76, sending broad/multicast

Apr 17 15:59:39.202: OSPF: Send hello to 224.0.0..5 area 0 on FastEthernet0/0.1 from 10.0.1.1

Apr 17 15:59:39.202: IP: s=10.0.1.1 (local), d=224.0.0.5 (FastEthernet0/0.1), len 76, sending broad/multicast

Apr 17 15:59:39.206: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0.2 from 10.1.1.1

Apr 17 15:59:39.206: IP: s=10.1.1.1 (local), d=224.0.0.5 (FastEthernet0/0.2), len 76, sending broad/multicast

Apr 17 15:59:39.210: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0.3 from 10.1.12.1

Apr 17 15:59:39.210: IP: s=10.1.12.1 (local), d=224.0.0.5 (FastEthernet0/0.3), len 76, sending broad/multicast

Apr 17 15:59:39.210: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0.4 from 10.1.13.1

Apr 17 15:59:39.210: IP: s=10.1.13.1 (local), d=224.0.0.5 (FastEthernet0/0.4), len 76, sending broad/multicast

Apr 17 15:59:39.214: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0.5 from 10.1.14.1

Apr 17 15:59:39.214: IP: s=10.1.14.1 (local), d=224.0.0.5 (FastEthernet0/0.5), len 76, sending broad/multicast

Apr 17 15:59:39.950: CEF: background resolution thread state:

Apr 17 15:59:39.950: Thread fast_thread: Empty

Apr 17 15:59:39.950: Thread todothread: Empty

Apr 17 15:59:39.950: Thread slow_thread: Empty

Apr 17 15:59:40.358: IP: tableid=0, s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), routed via RIB

Apr 17 15:59:40.358: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, sending

Apr 17 15:59:40.358: NAT: dialer not up for Dialer1, no translation, dial and drop

Apr 17 15:59:40.358: Di1 DDR: ip (s=10.1.12.1, d=118.23.8.80), 100 bytes, outgoing interesting (ip PERMIT)

Apr 17 15:59:40.358: DDR: 45000064 00930000 FF013095 0A010201 76170858 08003214

Apr 17 15:59:40.362: DDR: 001D0002 00000000 4D86FE90 ABCDABCD ABCDABCD ABCDABCD

Apr 17 15:59:40.366: Di1 DDR: dialer_.fsm_idle()

Apr 17 15:59:40.366: Di1 DDR: Cannot place call, no dialer string set

Apr 17 15:59:40.366: IP: s=10.1.12.1 (local), d=118.23.8.80 (Dialer1), len 100, encapsulation failed

Apr 17 15:59:40.814: %AMDP2_FE-5-LOSTCARR: Ethernet1/0 cable/transceiver problem?

2 Replies 2

samavedula_rama
Level 1
Level 1

Okay. I see the traffic sourced from 10.1.12.1 . Did you try to source it from 192.168.xx.xx ?? Because I see, there is no NAT applied on that FE interface.

And on ISP facing FE interface, may be a pppoe-client dial-pool-number 1 may help.

Hi,

Thanks for the response, but the 10.1.12.1 is a subinterface configured in the router. I'm not pinging from a client under this interface but rather pinging directly from the router's console to the ISP.

Because I see, there is no NAT applied on that FE interface.

I've added the NAT on the interface fa0/0 as you suggested,

and.........

And on ISP facing FE interface, may be a pppoe-client dial-pool-number 1 may help.


I added this as well but its not connecting either.

When I ping the ISP, below are the error message it returns every 10 seconds or there about:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 118.23.8.80, timeout is 2 seconds:

Apr 19 16:02:21.286: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

Apr 19 16:02:21.294: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

Apr 19 16:02:21.334: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

Apr 19 16:02:21.338: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down.....

Success rate is 0 percent (0/5) Router1#ping 118.23.8.80

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card