11-30-2015 03:45 PM - edited 03-05-2019 02:50 AM
Hi All,
i currently have a 1921 router and will have 3 different vlans. When the devices are connected to the 2960SW i cannot route any data? I have setup the VLAN id's on the 2960SW '5,6,7' but cannot even ping the router from the switch. What am i missing here and how can this be properly configured so that all devices connected to the switch can still com with each other ?
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
encapsulation dot1Q 5 native
ip address 10.0.1.1 255.255.255.0
ip helper-address 10.0.0.10
!
interface GigabitEthernet0/1.2
encapsulation dot1Q 6
ip flow ingress
ip address 10.0.2.1 255.255.255.0
ip helper-address 10.0.0.10
!
interface GigabitEthernet0/1.3
encapsulation dot1Q 7
ip address 10.0.3.1 255.255.255.0
ip helper-address 10.0.0.10
ip nat inside source list 100 interface GigabitEthernet0/1 overload
!
ip flow-export version 9
!
!
access-list 100 permit ip host 0.0.0.0 any
access-list 101 permit gre any any
access-list 101 permit ip 10.0.0.0 0.0.0.255 any
access-list 101 remark LAN NETWORK
11-30-2015 06:08 PM
Looks like your trying to setup essentially a "router on a stick". Your router is performing layer 3 routing between vlans.
This document may help with understanding the config and concepts with how this works
https://learningnetwork.cisco.com/docs/DOC-23481
HTH
Jay
11-30-2015 09:51 PM
Thanks Jay, Great article.
Now for somthing complex, ill be having 3 internet connections on this router as well. I have installed all the modules in the router (EHWIC-VA-DSL-A)
I want all VLANS to have there own seperate internet connection - But I want all of them to have a fail over.
Internet on vlan 1 goes down, i want it to use vlan 2, if 2 goes down, i want it to use vlan 1. if 3 goes down i want it go to vlan 2 or 1.
12-01-2015 11:42 AM
I've never seen a design as such, In my mind the better methodology is to leverage all 3 in a manor where there is a default route for 1 ISP for all egress traffic then another default route with a higher metric pointing to the 2nd ISP and then again the 3'rd ISP has a default route with a higher metric than the 2'nd isp default route.
Example:
ip route 0.0.0.0 0.0.0.0 x.x.x.x - Primary Default route pointing towards Next hop ip of ISP1
ip route 0.0.0.0 0.0.0.0 y.y.y.y 10 - Secondary Default route with higher AD (10) pointing towards Next hop ip of ISP2
ip route 0.0.0.0 0.0.0.0 z.z.z.z 20 - Tertiary Default route with higher AD (20) pointing towards Next hop ip of ISP3
!
Take a look at this article and see if it's something that may help in your design
NAT failover with DUAL ISP on a router Configuration Example
12-01-2015 03:20 PM
transferred post to appropriate community: Network Infrastructure>Routing
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide