cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1615
Views
0
Helpful
6
Replies

Share bandwidth

acazarkov
Level 1
Level 1

hi,

we have 2 offices connected , over leased lines with bendwidth 40 MBPS . We use IPsec. But we have congestion traffic.

I have two types of traffic , data and video . Can I share bandwidth on router interface, 80% for video and 20% data?

6 Replies 6

Bilal Nawaz
VIP Alumni
VIP Alumni

Hello, we can do this with the bandwidth percent option in the policy-map in the outbound direction.

Lets say my video is on the 10.0.0.x /24 network

All data traffic is on 192.168.1.x /24 network

I want to give 80% of the B/W for video and 20% for data.

ip access-list extended DATA

permit ip 192.168.1.0 0.0.0.255 any

!

ip access-list extended VIDEO

permit ip 10.0.0.0 0.0.0.255 any

!

!

class-map match-any DATA

match access-group name DATA

!

class-map match-any VIDEO

match access-group name VIDEO

!

!

policy-map BW_CONTROL

class VIDEO

  bandwidth percent 80

class DATA

  bandwidth percent 20

!

interface gi0/0

service-policy output BW_CONTROL

This way I am specifying the BW % allowed in the outbound direction. However when applying this.

The message I got was:

I/f GigabitEthernet0/0 class VIDEO requested bandwidth 80%, available only 75%

Shaping can be done like this:

policy-map BW

class VIDEO

  shape average percent 80

class DATA

  shape average percent 20

or CBWFQ

policy-map BW1

class VIDEO

  priority percent 80

class DATA

  priority percent 20

However, just remember that this may take in to account the bandwidth of the actual interface which may be gigabit so I would calculate it like this:

80% of 40mbps = 32mbps

20% of 40mbps = 8mbps

And this would be the configuration.

policy-map BW_CONTROL

class VIDEO

  bandwidth 32768

class DATA

  bandwidth 8192

!

policy-map BW

class class-default

  shape average 42000000

service policy BW_CONTROL

!

int gi0/0

service-policy output BW

Hope this helps

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

hello

I would suggest to use a nested policy to included LLQ for the video as this voice/video traffic is very sensitive to congestion and requires prioritising before any other of the defined data traffic and use bandwidth remaining your data traffic


Priority xxx ,- prioritise certain amount of bw to classes of the defined interface bw or from the specified shaped bw amount (does not increase if the interfaces bw increases)

Priority percent xx ( same as above but does increase if interface bw increases)

Class based shaping/policing:
Bandwidth xx / bandwidth percent xx /bandwidth remaining xx all allocate certain amount of bandwidth to classes from interface or shape amount as above but isn't prioritised like LLQ.

Bandwidth xx -specified bw does not increase if interface bw is increased


Note:
When shaping/policing is applied to an interface then you are only allowed to by default to allocate upto 75% of bw for all user define classes with and 25% going to the class class-default ( this is non defined class -best effort such as routing protocols ) if this default class is to large it can be utilised between defined classes per allocated percentage using the max-reserved-bandwidth command.

Note: On non Qos interfaces 100% is allowed

example: 20 mb bw
20480000 (defined or interface bw)
15360000 = 75% shared between all defined classes
5120000 = class class-default

This can be increase to 100% on the interface by the max-reserved-bandwidth command

Class-map video
Match access group name video

Class-map data
Match access-group name data

Policy-map Qos-child
Class video
Priority percent 80
Class data
Bandwidth remaining percent 20 ( the remaining bw after priority is accounted for)
Class class-default

Policy-map Qos-Parent
Class class-default
Shape average 20480000 (20mb)
Service policy Qos-child

Int xx (wan facing)
max-reserved-bandwidth 100
Service-policy output Qos-Parent

Or

Int xx (wan facing)
Bandwidth 20480
max-reserved-bandwidth 100
Service-policy output Qos-Child


Res
Paul

Sent from Cisco Technical Support iPad App


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello Friend,

As mentioned in above answer we can allocate bandwidth for specific services, this technic is called Qos and there are multiple ways of implementations are available.

I prefer Low latency queuing for your problem because voice traffic is involved.

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND/QoS-SRND-Book.html

Before Qos Configuration you can go through above link and understand the technology.

Hope Cisco LLQ will help You.


Sent from Cisco Technical Support iPhone App

This is a very good document. Thank you for sharing!

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

thx, I haven't yet tried this. When testing it I'll let you know the result.

I got a vacation...

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Yes, you might be able to do so.  What you can do depends on your platform, its IOS version and your WAN technology.  Also, different video types, e.g. streaming vs. real-time, benefit from different QoS techniques.

If you could provide additional detail, I might be able to suggest how to configure.

Review Cisco Networking for a $25 gift card