07-13-2011 12:51 PM - last edited on 03-25-2019 03:32 PM by ciscomoderator
Hi -
I have two goals on my Cisco 3750E -
* Limit bandwidth to match carrier provided bandwidth (10M ethernet port, but only 6M provisioned)
* Prioritize some traffic over others through the use of a priority queue.
I have come up with this design:
access-list 100 remark priority traffic
access-list 100 permit ip 10.1.1.0 0.0.3.255 any
access-list 100 permit ip any 10.1.1.0 0.0.3.255
class-map match-all priority-traffic
description Priority Traffic
match access-group 100
!
!
policy-map traffic-policy
description Traffic Policy
class priority-traffic
! Set priority traffic to dscp 46 EF
set ip dscp ef
interface GigabitEthernet1/0/1
description WAN link
switchport access vlan 2
bandwidth 6000
speed 10
duplex full
! Limit link to 6M
srr-queue bandwidth limit 60
priority-queue out
mls qos trust dscp
spanning-tree portfast
interface Vlan6
description User Network
ip address 192.168.16.1 255.255.255.0
service-policy input traffic-policy
Is this right?
How do I know? Is there a show command to show priority packets?
Am I right in assigning dscp 46 to this interesting traffic? That way it goes to queue 2?
Am I right in applying the priority-queue out command to the interface?
We also have voice traffic. But I think i can trust it to queue up into the router with trusted dscp
Thanks for any suggestions you may have!
07-14-2011 05:39 PM
Hi
- the bandwidth allocation on th eoutbound interface looks ok
however i noticed that you trying to marking using a policy on the vlan interface
if this is the case then you need to change the qos behaivor on the ingress switch interfaces where vlan 6 used either access vlan or trunk
mls qos
!
interface FastEthernet0/x
mls qos vlan-based
now you are using the proirity queue using DSCP
so you need to make sure that COS to DSCP cos 5 tp dscp 46
and make sure that both cos 5 and dscp 46 are alocated to the PQ
mls qos map cos-dscp 0 8 16 24 32 46 48 56
! Modifies CoS-to-DSCP mapping to map CoS 5 to DSCP EF
mls qos srr-queue output dscp-map queue 1 threshold 3 46
! Maps DSCP EF (VoIP) to Egress Queue 1 (PQ)
now make sur eyou trust DSCP not COS as you using DSCP all the way if you trust COS then the PQ wil linto COS value not the DSCP
for show commnads in the siwtches this is very limted if you are using Presendence vlaue not DSCP you might use the bellow for testing
policy-map VLAN
class TCP
set ip precedence 5
#sho int precedence
Ethernet0/0.100
Input
Precedence 3: 50 packets, 5900 bytes
Precedence 5: 46 packets, 2953 bytes
or you can use sow mls qos interface fax/x statistics
Good luck
if helpful Rate
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide