cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
577
Views
15
Helpful
8
Replies
Highlighted
Beginner

Static IP Route Not Working

Friends, I need your help again.  I'm trying a very basic Static IP Route. I cannot get it to work every time.  Firewalls on PC's are off.  Using Ubuntu 18.04 on physical machines.  Version 12.3 on routers.  Switches are using default VLAN 1.  All equipment has been reset to factory settings.

This is my network diagram:

Test 2 diagram.jpg

PC 1 can ping Router 1, but not router 2

Router 1 can ping PC 1 and Router 2

PC 2 can ping Router 2, but not router 1

Router 2 can ping PC 2 and Router 1

 

Here is the screen shot for static routes for router 1

Screenshot from 2019-04-11 11-56-57.png

 

Here is the screenshot for static IP routes on router 2.

 

Screenshot from 2019-04-11 12-05-22.png

 

Any suggestions are welcome.  Thank you.

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: Static IP Route Not Working

Thanks for everyone's help.  All the little pieces fell into place.  This is what I did thanks to your help.

 

Traceroute tried to go out the Internet interface, not the interface I was trying to use for the static route.  When I unplugged the internet, everything pinged just fine.

 

I found a command to allow pinging from a specific interface:

ping -I enp6s0 10.10.10.1

And it pinged just fine.

View solution in original post

8 REPLIES 8
Highlighted
Hall of Fame Master

Re: Static IP Route Not Working

Hello,

I apologize for the dumb question have you configured appropriate defaults gateways on the two linux PCs?

 

Because your static routes look like correct on the routers.

 

Hope to help

Giuseppe

 

Highlighted

Re: Static IP Route Not Working

Hi @DoubleTapNY,

From your configuration and description, the Static Routes and the Routers configuration should be OK.

What is the Default Gateway set on the Linux hosts?

Try looking via GUI.

If via CLI, try with the route -n or ip route commands.

Please paste the results here for both of your Linux hosts.

 

Highlighted
Beginner

Re: Static IP Route Not Working

This is the manual config for PC 1

Screenshot from 2019-04-11 15-08-55.png

 

This is PC 2

Screenshot from 2019-04-11 15-12-02.png

Highlighted

Re: Static IP Route Not Working

Beside ping, you should use traceroute at both endpoints to diagnose network path especially when managing complex and large topology.  

 

For your case, common problem is misconfiguration of default gateway and/or subnet mask.

Highlighted
Beginner

Re: Static IP Route Not Working

Traceroute tried to go through the Internet Interface and not the static LAN interface I am trying to setup.

 

 

Highlighted
Beginner

Re: Static IP Route Not Working

Thanks for everyone's help.  All the little pieces fell into place.  This is what I did thanks to your help.

 

Traceroute tried to go out the Internet interface, not the interface I was trying to use for the static route.  When I unplugged the internet, everything pinged just fine.

 

I found a command to allow pinging from a specific interface:

ping -I enp6s0 10.10.10.1

And it pinged just fine.

View solution in original post

Highlighted

Re: Static IP Route Not Working

I'm glad it is working OK now.
Highlighted
Beginner

Re: Static IP Route Not Working

Thank you so much for the help.  I never bothered with a trace route because it was only two hops.  Goes to show, never forget to use all the tools available.