cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
410
Views
5
Helpful
4
Replies
Highlighted
Beginner

Static Route not updating in EIGRP with IP SLA

image.png

 

I'm needing some configuration assistance/advice. Right now we have a remote site that's connected to our LAN via full-mesh VPLS uplink and EIGRP configured between sites. The remote branch has its own ISP connection that we'd like to have as its primary route to the internet. I've configured an IP SLA on the external interface of the Remote Branch Router that has a static default route going to the internet. The backup route sends all traffic back to the Core Switch to be routed (since EIGRP should reconverge and know to send all traffic through the VPLS connection). The issue I'm having is once the external interface goes down, the redistributed static route holds in EIGRP and the Branch Core still tries to send all internet traffic through the router. I'm not sure how to configure the router to redistribute the static routes properly so if the IP SLA kicks over, EIGRP updates and learns to send traffic through the VPLS connection until the external interface comes back up.

 

Here's the config of the Router and Core Switch-

 

Router:

 

Interface  g0/0

ip address 10.205.1.254 .255.255.255.0

 

ip route 0.0.0.0 0.0.0.0 *ISP NEXT HOP* track 1

ip route 0.0.0.0 0.0.0.0 10.205.1.1 10

 

router eigrp 1

network 10.205.1.0 0.0.0.255

redistribute static metric 10000 100 255 1 1500

 

ip sla 1

icmp-echo 8.8.8.8 source-interface g0/1

timeout 8000

frequency 10

ip sla schedule 1 life forever start-time now

track 1 ip sla 1 reachability

-----------------------------------------------

Core Switch:

 

Interface Vlan 1

ip address 10.205.1.1 255.255.255.0

 

router eigrp 1

network 10.205.1.0 0.0.0.255

network 172.25.25.0 0.0.0.255    ***VPLS network with neighbor at Datacenter established***

-------------------------------------------------

This is the routing table of the core switch, it does not change whether or not the routers IP SLA kicks in and changes the default route:

 

Gateway of last resort is 10.205.1.254 to network 0.0.0.0

D*EX   0.0.0.0/0 [170/281856] via 10.205.1.254,  01:19:28,  Vlan1

 

Your help is much appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Update - I figured it out. I simply removed the secondary static route that was configured on the router as backup. So, when the IP SLA goes down on the router it removes the primary static route from its routing table (by design). Without having a backup route to fill its place and it being EIGRP neighbors with the core switch, it just learns the routes from the Core through EIGRP. With no static route being injected by the router into EIGRP, the Core switch simply decides the best path itself and sends all traffic through the VPLS connection.

View solution in original post

4 REPLIES 4
Highlighted
Beginner

Update - I figured it out. I simply removed the secondary static route that was configured on the router as backup. So, when the IP SLA goes down on the router it removes the primary static route from its routing table (by design). Without having a backup route to fill its place and it being EIGRP neighbors with the core switch, it just learns the routes from the Core through EIGRP. With no static route being injected by the router into EIGRP, the Core switch simply decides the best path itself and sends all traffic through the VPLS connection.

View solution in original post

Highlighted

Hello,

 

I am not sure that works. There is no default route, so yes, you will be able to reach the other EIGRP networks, but not the Internet.

 

The below has two EEM scripts linked to the IP SLA. If the IP SLA is down, the connection between the router and the switch is shut down, and the default route on the switch will be added to the routing table. 

 

Router:


interface GigabitEthernet0/0
ip address 10.205.1.254 255.255.255.0
!
router eigrp 1
network 10.205.1.0 0.0.0.255
redistribute static metric 10000 100 255 1 1500
!
ip sla 1
icmp-echo 8.8.8.8 source-interface g0/1
timeout 8000
frequency 10
!
ip sla schedule 1 life forever start-time now
!
track 1 ip sla 1 reachability
!
event manager applet SHUT_EIGRP
event track 1 state down
action 1.0 cli command "enable"
action 2.0 cli command "conf t"
action 3.0 cli command "interface GigabitEthernet0/0"
action 4.0 cli command "shut"
action 5.0 cli command "end"
!
event manager applet NO_SHUT_EIGRP
event track 1 state up
action 1.0 cli command "enable"
action 2.0 cli command "conf t"
action 3.0 cli command "interface GigabitEthernet0/0"
action 4.0 cli command "no shut"
action 5.0 cli command "end"
!
ip route 0.0.0.0 0.0.0.0 *ISP Next Hop* track 1
ip route 0.0.0.0 0.0.0.0 10.205.1.1 10

------------------------------------------------------

Core Switch:

 

Interface Vlan 1
ip address 10.205.1.1 255.255.255.0
!
router eigrp 1
!
network 10.205.0.0 0.0.0.255
network 172.25.25.0 0.0.0.255 ***VPLS Network with neighbor at Datacenter established***
!
ip route 0.0.0.0 0.0.0.0 172.25.25.2 180

Highlighted

Hi Georg,

 

Thank you for the reply. I'm happy to report that it indeed does work. Since there's a gateway of last resort being redistributed into EIGRP via the Datacenter, it shares that route with the remote location thus, updating the routing table on the remote locations Router & Core Switch. The gateway of last resort now gets updated to 172.25.25.1 which is the IP of the Datacenter VPLS uplink. I've tested it live and confirmed it's working as intended.

 

Here is the output of 'show ip route' before and after the IP SLA Track goes down.

 

Core Switch Before:

Gateway of last resort is 10.205.1.254 to network 0.0.0.0

 

D*EX    0.0.0.0/0 [170/281856] via 10.205.1.254,  01:19:28,  Vlan1

 

---shut the external interface on RTR---   track 1 ip sla reachability Up -> Down

 

Core Switch After:

Gateway of last resort is 172.25.25.1 to network 0.0.0.0

 

D*EX    0.0.0.0/0 [170/282112] via 172.25.25.1,  01:45:16,  GigabithEthernet0/1

 

 

Once the SLA reachability switches back to "UP" the routing table on the core switch updates and starts sending traffic back through the local router. I made sure to test all websites are reachable and internet traffic flows properly while the SLA is in a down state.

 

I appreciate the response!

Highlighted

Hello,

 

--> Since there's a gateway of last resort being redistributed into EIGRP via the Datacenter, it shares that route with the remote location thus, updating the routing table on the remote locations Router & Core Switch.

 

If that is the case, you are absolutely right. Glad that you got it resolved.