cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
433
Views
0
Helpful
1
Replies
Highlighted
Beginner

Static Route update in EIGRP with IP SLA

image.png

 

I'm needing some configuration assistance/advice. Right now we have a remote site that's connected to our LAN via a full-mesh VPLS uplink and EIGRP configured between sites. The remote branch has its own ISP connection that we'd like to have as its primary route to the internet. I've configured an IP SLA on the external interface of the Remote Branch Router that has a static default route going to the internet. The backup route sends all traffic back to the Core switch to be routed (since EIGRP should reconverge and know to send all traffic through the VPLS connection). The issue I'm having is once the external interface goes down, the redestributed static route holds in EIGRP and the branch core switch still tries to send all internet traffic through the router. I'm not sure how to configure the router to redestribute the static routes properly so if the IP SLA kicks over, EIGRP updates and learns to send traffic through the VPLS connection until the interface comes back up.

 

Here's the config for the Router and Core switch.

 

Router:

 

Interface g0/0

ip address 10.205.1.254 255.255.255.0

 

router eigrp 1

network 10.205.1.0 0.0.0.255

redistribute static metric 10000 100 255 1 1500

 

ip sla 1

icmp-echo 8.8.8.8 source-interface g0/1

timeout 8000

frequency 10

ip sla schedule 1 life forever start-time now

track 1 ip sla 1 reachability

 

ip route 0.0.0.0 0.0.0.0 *ISP Next Hop* track 1

ip route 0.0.0.0 0.0.0.0 10.205.1.1 10

------------------------------------------------------

Core Switch:

 

Interface Vlan 1

ip address 10.205.1.1 255.255.255.0

 

router eigrp 1

network 10.205.1.0 0.0.0.255

network 172.25.25.0 0.0.0.255    ***VPLS Network with neighbor at Datacenter established***

--------------------------------------------------------

 

This is the routing table of the core switch, it does not change whether or not the routers IP SLA kicks in and changes the default route:

image.png

 

Your help is much appreciated

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

Hi

Your core switch already learns a default route from the datacenter right?

When you router is connected to ISP and everything works fine, this router advertise the default route using the redistribute static and so your core prefer that route.

So if you have an IPSLA to the default route on your router, when ISP goes down, the static route is removed and eigrp won't advertise it back to your core switch which will then take the other default route it learns from the Datacenter.

 

So there's no need to add a static route on the router that points back to the core. This won't work the way you expect.

 

If you remove the command 

ip route 0.0.0.0 0.0.0.0 10.205.1.1 10

and you trigger your ISP to go down, core switch will take the default route learned from DC. 

 

 


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

View solution in original post

1 REPLY 1
Highlighted
VIP Mentor

Hi

Your core switch already learns a default route from the datacenter right?

When you router is connected to ISP and everything works fine, this router advertise the default route using the redistribute static and so your core prefer that route.

So if you have an IPSLA to the default route on your router, when ISP goes down, the static route is removed and eigrp won't advertise it back to your core switch which will then take the other default route it learns from the Datacenter.

 

So there's no need to add a static route on the router that points back to the core. This won't work the way you expect.

 

If you remove the command 

ip route 0.0.0.0 0.0.0.0 10.205.1.1 10

and you trigger your ISP to go down, core switch will take the default route learned from DC. 

 

 


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

View solution in original post