cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
904
Views
5
Helpful
5
Replies
Lionel271
Beginner

Suspected problem with BGP route advertisement

Hi there!

 

I am experiencing a problem which I suspect involves an issue with route advertisement.

 

The setup is as follows:

 

Device A 10.0.154.2/25

    gateway 10.0.154.1

Router A interface 1 10.0.154.1/25 interface 2 10.0.154.250/29

    interface 1 is connected to network with Device A, interface 2 is connected to network with router B

    EIGRP

Router B interface 1 10.0.154.249/29 interface 2 10.0.155.234/29

    interface 1 is connected to network with router A, interface 2 is connected to network with router C

    BGP neighbor 10.0.155.233 (router C)

    EIGRP (redistribute into BGP)

Router C interface 10.0.155.233/29

    has routes to devices on 192.168.1.64/27 and 192.168.3.64/27

    exact configuration unknown, but assumed to be correct

 

The ultimate requirement is that Device A is able to reach devices on 192.168.1.64/27 and vice versa. Only the routes required to reach this device are required to be advertised into the BGP table on 10.0.155.233.

 

Both device A and router A successfully connect to 10.0.155.234 (router B), but can't connect to 10.0.155.233 (router C) or further. Traceroute hops to 10.0.155.1, then 10.0.155.249 and stops here.

 

Router B reaches 10.0.155.233 (router C), and traceroute follows the router there as received over BGP. 

 

Relevant config on router B:

router eigrp 100
  network 10.0.0.0
  network 192.168.0.0
  redistribute bgp 3000
router bgp 3000
  neighbor 10.0.155.233 remote-as 5000
  address-family ipv4
    network 10.0.152.0
    network 10.0.153.0
    network 10.0.154.0
    redistribute connected
    redistribute static
    redistribute eigrp 100
    neighbor 10.0.155.233 activate
    neighbor 10.0.155.233 route-map net1 out
route-map net1 permit 10
 match ip address 1
access-list 1 permit 10.0.154.0 0.0.0.255

#show ip bgp neighbor 10.0.155.233 advertised-routes
BGP table version is 97, local router ID is 172.16.186.250
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
 
     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.0.154.0/25 10.0.154.250   26882560         32768 ?
 *>  10.0.154.248/29
                       0.0.0.0                  0         32768 ?
 
Total number of prefixes 2 

#show ip bgp neighbor 10.0.155.233 routes           
BGP table version is 97, local router ID is 172.16.186.250
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
 
     Network          Next Hop            Metric LocPrf Weight Path
 *>  192.168.1.64/27   10.0.155.233                        0 5000 i
 *>  192.168.3.64/27   10.0.155.233                        0 5000 i
 
Total number of prefixes 2

Config on router A:

router eigrp 100
  network 10.0.0.0
  network 192.168.186.0
  network 192.168.17.0
  no auto-summary
router eigrp 200
  redistribute static
  redistribute eigrp 100
  -- unrelated internal networks --
  no auto-summary
ip route 0.0.0.0 0.0.0.0 192.168.4.137
ip route 172.16.154.80 255.255.255.248 10.0.154.249
-- more unrelated routes --

#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.4.137 to network 0.0.0.0

     10.0.0.0/16 is variably subnetted, 5 subnets, 2 masks
C       10.0.154.0/25 is directly connected, FastEthernet0/1.21
D       10.0.155.240/29 
           [90/297244672] via 10.0.154.249, 18:33:46, Tunnel0
D       10.0.155.248/29 
           [90/297244672] via 10.0.154.249, 18:33:46, Tunnel0
C       10.0.154.248/29 is directly connected, Tunnel0
D       10.0.155.232/29 
           [90/297244672] via 10.0.154.249, 18:33:46, Tunnel0
-- lots of unrelated routes removed --
     172.16.0.0/29 is subnetted, 1 subnets
S       172.16.154.80 [1/0] via 10.0.154.249
S*   0.0.0.0/0 [1/0] via 192.168.4.137

 

Can some genius shed some light on what's going wrong?

 

Thanks in advance!

 

1 ACCEPTED SOLUTION

Accepted Solutions

You're missing default-metric in EIGRP config. EIGRP does not redistribute BGP routes on R2. You need to set it in either of 3 ways:

redistribute command with route-map

redistribute command with default-metric

"standalone" default-metric EIGRP command

 

View solution in original post

5 REPLIES 5
Lionel271
Beginner

There is another issue here as well:

 

Router A is not receiving the routes to 192.168.1.64/27 and 192.168.3.64/27 from router B over EIGRP, even though redistribute bgp is enabled on router B.

 

 

This would not explain why 10.0.155.233 is inaccessible though.

You're missing default-metric in EIGRP config. EIGRP does not redistribute BGP routes on R2. You need to set it in either of 3 ways:

redistribute command with route-map

redistribute command with default-metric

"standalone" default-metric EIGRP command

 

View solution in original post

Thank you, Michal! The problem is now partially resolved.

 

I can confirm that adding a default-metric solved the route redistribution problem.

 

I'm receiving all the BGP entries over EIGRP now, but I'm still unable to reach 10.0.155.233.

 

I suspect that this issue, which is the big problem, is related to the BGP configuration itself. The route to it is advertised over EIGRP because I can see it in the routing table (and I can reach the router on 10.0.155.234).

 

I think that the router at 10.0.155.233 doesn't have a route back to the rest of the network, yet it shows in the advertised-routes table. Unfortunately, I have no access to that router, so I cannot look at the tables there. I can only troubleshoot it from the other end.

Post the updated config of both A & B routers, please. And "show ip route" output of relevant prefixes.
And I thought you were trying to reach 192.168.1.64/27 network, not 10.0.155.233.

10.0.155.233 is a router sitting in front of 192.168.1.64/27, so my reasoning was that if I can't reach that, I won't go further.

 

"show ip route" gives thousands of pages worth of output. There are about 650k entries in the BGP table :-).

 

Somehow this has starting working though. I think the problem was on the other end at all, so the only problem here appears to be the metric issue you brought up earlier.