cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
118
Views
1
Helpful
2
Replies

Troubleshoot IPv4 addressing

Andrew guory009
Community Member

I'm currently working on a troubleshooting course assignment, but I'm having trouble solving the problem. I hope to receive guidance or suggestions to help me solve it or be provided with the correct solution for me to review and gain experience.

This is a troubleshooting case about IPv4 addresses. The only protocol involved is DHCP, and it has nothing to do with OSPF or BGP. I have attached the running configuration of all devices for your review. This is the current original state, and I haven't carried out any repair work. Currently, all PCs can only ping IP addresses within their own broadcast domain, and for all other operations, they receive a mixture of "Destination Host Unreachable" and "Request timeout" errors. The only issue I have found is that R2, as the DHCP server, has an incorrect default gateway address in the DHCP pool prepared for PCs. However, after I corrected it, the default gateway address obtained by the PCs did not change accordingly. Even more strangely, the PCs still maintain a connection with the DHCP server.

R1

 

 

 

!! NETLAB+ saved configuration: time="2025-03-10 17:45:52 UTC" device="R1" hardware="C4331-S01" reservation="99587"
!
! Last configuration change at 04:33:00 UTC Tue Mar 11 2025
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
enable secret 5 $1$sudu$fcFbd3RV/zF6buEZo.KBu1
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
! 
! 
! 
! 
vtp domain MawsonLakes
vtp mode transparent
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
!
!
!
!
!
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
username admin privilege 15 secret 9 $9$mpXxbZ34CW2YVh$tsk6KQkF5oYxyqm11LYFh0WM8c1D8IQBgsvXys2j/mQ
!
redundancy
 mode none
!
!
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
!
!
! 
! 
!
!
interface Loopback0
 ip address 209.165.200.225 255.255.255.248
 ipv6 address FE80::1:3 link-local
 ipv6 address 2001:DB8:A:C::1/64
 no shutdown
!
interface GigabitEthernet0/0/0
 ip address 10.10.20.1 255.255.255.0
 negotiation auto
 ipv6 address FE80::1:1 link-local
 ipv6 address 2001:DB8:A:B::1/64
 no shutdown
!
interface GigabitEthernet0/0/1
 ip address 10.10.10.1 255.255.255.0
 ip helper-address 10.10.20.254
 negotiation auto
 ipv6 address FE80::1:2 link-local
 ipv6 address 2001:DB8:A:A::1/64
 ipv6 nd other-config-flag
 ipv6 dhcp relay destination 2001:DB8:A:B::2
 no shutdown
!
interface GigabitEthernet0/0/2
 no ip address
 negotiation auto
 no shutdown
!
interface Serial0/1/0
 no ip address
 no shutdown
!
interface Serial0/1/1
 no ip address
 no shutdown
!
interface Serial0/2/0
 no ip address
 no shutdown
!
interface Serial0/2/1
 no ip address
 no shutdown
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 negotiation auto
 no shutdown
!
!
!
ip forward-protocol nd
no ip http server
ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 Loopback0
!
!
ipv6 route ::/0 Loopback0
!
!
!
!
control-plane
!
banner motd ^C This is R1, Trouble Ticket 1.1.2.1 ^C
alias exec reset.now tclsh flash:/enarsi/reset.tcl
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login local
 transport input telnet
!
!
!
!
!
!
end

 

 

 

R2

 

 

 

!! NETLAB+ saved configuration: time="2025-03-10 17:45:53 UTC" device="R2" hardware="C4331-S01" reservation="99587"
!
! Last configuration change at 04:23:18 UTC Tue Mar 11 2025
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
enable secret 5 $1$8aA6$pEQ4kZ0583d0SrFLhEPNu.
!
no aaa new-model
!
!
!
!
!
!
!
ip dhcp excluded-address 10.10.10.1 10.10.10.100
!
ip dhcp pool LAN4_10
 network 10.10.10.0 255.255.255.0
 default-router 10.10.10.254 
 domain-name ccnp4lab.com
 dns-server 10.10.20.254 
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
! 
! 
! 
! 
vtp domain merger.com.au
vtp mode transparent
!
ipv6 unicast-routing
ipv6 dhcp pool LAN6_A
 dns-server 2001:DB8:A:B::1
 domain-name ccnp6lab.om
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
username admin privilege 15 secret 9 $9$ucl2Mak4YpASSF$w9W6LuF6VlgAKsmxfOwFY1IXV0/nz7j0OwQLOw67GhU
!
redundancy
 mode none
!
!
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
!
!
! 
! 
!
!
interface GigabitEthernet0/0/0
 ip address 10.10.20.254 255.255.255.0
 negotiation auto
 ipv6 address FE80::2:1 link-local
 ipv6 address 2001:DB8:A:B::2/64
 ipv6 dhcp server LAN6_A
 no shutdown
!
interface GigabitEthernet0/0/1
 no ip address
 negotiation auto
 no shutdown
!
interface GigabitEthernet0/0/2
 no ip address
 negotiation auto
 no shutdown
!
interface Serial0/1/0
 no ip address
 no shutdown
!
interface Serial0/1/1
 no ip address
 no shutdown
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 negotiation auto
 no shutdown
!
ip forward-protocol nd
no ip http server
ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 10.10.20.1
!
!
ipv6 route ::/0 2001:DB8:A:B::1
!
!
!
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
banner motd ^C This is R2, Trouble Ticket 1.1.2.1 ^C
alias exec reset.now tclsh flash:/enarsi/reset.tcl
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login local
 transport input telnet
!
!
!
!
!
!
end

 

 

 

D1

 

 

 

!! NETLAB+ saved configuration: time="2025-03-10 17:46:01 UTC" device="D1" hardware="C3650" reservation="99587"
!
! Last configuration change at 04:31:19 UTC Tue Mar 11 2025
!
version 16.9
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
! Call-home is enabled by Smart-Licensing.
service call-home
no platform punt-keepalive disable-kernel-core
!
hostname D1
!
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
enable secret 5 $1$9jaB$bY21CS5NvN8VPqnpyU/OB.
!
no aaa new-model
switch 1 provision ws-c3650-24ps
!
!
!
!
call-home
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
  no destination transport-method email
!
!
!
!
!
!
!
!
login on-success log
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3240170804
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3240170804
 revocation-check none
 rsakeypair TP-self-signed-3240170804
!
crypto pki trustpoint SLA-TrustPoint
 enrollment pkcs12
 revocation-check crl
!
!
crypto pki certificate chain TP-self-signed-3240170804
 certificate self-signed 01
  30820330 30820218 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33323430 31373038 3034301E 170D3235 30333131 30343237 
  31345A17 0D333030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 32343031 
  37303830 34308201 22300D06 092A8648 86F70D01 01010500 0382010F 00308201 
  0A028201 01008BBF CCE5103C 324292FF 169E34B3 7E98D4BD E0A717F8 2BE33C5C 
  3FA90EEF 8AE0E449 C0D90505 D1DD1430 D662988C 1D0606DB 9B02AEA1 131D67A1 
  0766763B 27D81CBC F95CF764 C95B707A BDC4DADE AFEF98A7 11AA2117 88274DE8 
  47DF6452 5D8C8CC9 0B64A460 22189BAE 8917AAB5 A0ACA8AE 24409F9B 7A7D7084 
  6C6C0422 0DE8F19A C8A4CAE2 D806C26C 3351DADC 480B4C6A C880EAEE B13E8779 
  4F0DB704 F4D5E383 38A5D69C 0D859DD5 C42B75C8 3CB8752C 85FC9598 B58DF812 
  19569334 2C0A2A23 81A87685 9FF94FDE 9152E004 682F5EFC 809D3027 C2234ED7 
  CBE479A4 D4F0FB98 33242697 671B529A CDC1A351 A35C869F 9F31D94E 6694D7D0 
  78BDC9C0 F1C10203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 
  301F0603 551D2304 18301680 14A16FED 91D4726C 38BAE400 E1B20159 248CF0B5 
  42301D06 03551D0E 04160414 A16FED91 D4726C38 BAE400E1 B2015924 8CF0B542 
  300D0609 2A864886 F70D0101 05050003 82010100 21AE96C2 7DC1682C 88FB2740 
  CB19CD2B 5CB530F2 A693DACE 44620382 E7DEB13A B534F4D7 E8E1883E EA628BF0 
  56DADC08 2A920F66 C5349C34 EA5A16CB FA13D7E8 C6AE7315 17BD3AFF 3A03CF7D 
  30B1FC5C 6FEB1FD2 46451E04 49F48369 50F03035 7357F271 905062DC 4A9F0BE8 
  B8B89414 41B53CF9 4E1D8A7F 8B0D19CB B6D7C007 B619DADB 7BD882D3 CAA319B9 
  72ED1094 81C2B43D 51FDEAC4 985D4744 6BE618B7 F74F8D32 2CF786BD 48201624 
  96D24122 0C9AF7F4 74F884D9 4D454241 8DA4DC47 082C20D8 A493868E 1B612A2F 
  780F634B 710DE611 C58B7348 F10B7279 D728359C 72BCDED7 35432202 21D90AB0 
  4B7FF831 BCFAC845 583575FE E7F2D6AB 460925AB
  quit
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01
  30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030 
  32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363 
  6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934 
  3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305 
  43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720 
  526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030 
  82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D 
  CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520 
  1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE 
  4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC 
  7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188 
  68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7 
  C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191 
  C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44 
  DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201 
  06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85 
  4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500 
  03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905 
  604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B 
  D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8 
  467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C 
  7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B 
  5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678 
  80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB 
  418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0 
  D697DF7F 28
  quit
!
!
!
diagnostic bootup level minimal
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!
username admin privilege 15 secret 9 $9$/4cZaqj.3zfmDE$RFP.wPanyQywu6yM50zU57J17fimX3n9jJeg20MyLrg
!
redundancy
 mode sso
!
!
!
!
!
transceiver type all
 monitoring
!
!
class-map match-any system-cpp-police-topology-control
  description Topology control
class-map match-any system-cpp-police-sw-forward
  description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
  description Inter FED, EWLC control, EWLC data
class-map match-any system-cpp-police-sys-data
  description Learning cache ovfl, High Rate App, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
  description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
  description L2 LVX control packets
class-map match-any system-cpp-police-forus
  description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
  description MCAST END STATION
class-map match-any system-cpp-police-multicast
  description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
  description L2 control
class-map match-any system-cpp-police-dot1x-auth
  description DOT1X Auth
class-map match-any system-cpp-police-data
  description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
  description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
  description Routing control and Low Latency
class-map match-any system-cpp-police-protocol-snooping
  description Protocol snooping
class-map match-any system-cpp-police-dhcp-snooping
  description DHCP snooping
class-map match-any system-cpp-police-system-critical
  description System Critical and Gold Pkt
!
policy-map system-cpp-policy
!
! 
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet1/0/1
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/2
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/3
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/4
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/5
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/6
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/7
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/8
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/9
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/10
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/11
 switchport access vlan 10
 switchport mode access
 no shutdown
!
interface GigabitEthernet1/0/12
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/13
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/14
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/15
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/16
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/17
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/18
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/19
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/20
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/21
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/22
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/23
 switchport access vlan 10
 switchport mode access
 no shutdown
!
interface GigabitEthernet1/0/24
 switchport access vlan 10
 switchport mode access
 no shutdown
!
interface GigabitEthernet1/1/1
 no shutdown
!
interface GigabitEthernet1/1/2
 no shutdown
!
interface GigabitEthernet1/1/3
 no shutdown
!
interface GigabitEthernet1/1/4
 no shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 10.10.10.2 255.255.255.0
 no shutdown
!
ip default-gateway 10.10.10.1
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
control-plane
 service-policy input system-cpp-policy
!
banner motd ^C This is D1, Trouble Ticket 1.1.2.1 ^C
alias exec reset.now tclsh flash:/enarsi/reset.tcl
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
!
!
!
end

 

 

 

Andrewguory009_0-1741631529708.pngAndrewguory009_1-1741631549885.pngAndrewguory009_2-1741631565616.png

 

1 Accepted Solution

Accepted Solutions

balaji.bandi
Hall of Fame
Hall of Fame

try below changes and let me know how it goes

R1 remove the default route
no ip route 0.0.0.0 0.0.0.0 Loopback0


R2 changge the DHCP Router address
ip dhcp pool LAN4_10
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1

Does PC1 or 2 can able to ping 209.165.200.225

Note : i am sure some IOS have default ip routing enable, check on R1 ip routing enabled

check on PC able to get ipconfig - check the gateway is 10.10.10.1 not 10.10.20.254

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

2 Replies 2

balaji.bandi
Hall of Fame
Hall of Fame

try below changes and let me know how it goes

R1 remove the default route
no ip route 0.0.0.0 0.0.0.0 Loopback0


R2 changge the DHCP Router address
ip dhcp pool LAN4_10
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1

Does PC1 or 2 can able to ping 209.165.200.225

Note : i am sure some IOS have default ip routing enable, check on R1 ip routing enabled

check on PC able to get ipconfig - check the gateway is 10.10.10.1 not 10.10.20.254

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thank you for your reply. I just tried the nanny-style solution you provided and successfully solved the problem. Here, I have a few questions to further ask you. Is the principle of this error that the "ip route 0.0.0.0” command sends all packets to Loopback0, resulting in a network failure of an information dead end? Also, how did you quickly and accurately identify this error? Are there any experiences and clues?

Review Cisco Networking for a $25 gift card