cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
285
Views
0
Helpful
4
Replies

Troubleshooting IPv6 addressing and IPv6 DHCP

Andrew guory009
Level 1
Level 1

I'm working on a course assignment, but I have encountered some obstacles and hope to get some suggestions or guiding solutions.

I tried some repair measures. The only successful repair measure was to enable SLAAC successfully, so that the PC could ping the entire network. However, I didn't record the process, which made me unable to reproduce it. And when I was able to ping successfully, I also realized that the PC did not receive the "reply" from the DHCP server.

In addition to the solutions and suggestions, I also hope to know how you investigate or use the empirical skills, as well as the principles involved behind this problem. I want to know more so that I can solve or identify similar problems by myself next time.

R1

Building configuration...


Current configuration : 2404 bytes
!
! Last configuration change at 14:40:48 UTC Thu Mar 13 2025
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!         
enable secret 5 $1$eec1$Z7PaL1EXqO148wLnAi9y20
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
!         
! 
! 
! 
vtp domain MawsonLakes
vtp mode transparent
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
!
!
!
!
!
license udi pid ISR4331/K9 sn FDO24160K4L
license accept end user agreement
license boot suite FoundationSuiteK9
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!         
!
username admin privilege 15 secret 9 $9$wXsizaeNVwl02A$aikqw3ye3uYI6AQGLZ6LZfi8tSdvuTA8QeJGQF7Hc7A
!
redundancy
 mode none
!
!
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
!         
!
! 
! 
!
!
interface Loopback0
 ip address 209.165.200.225 255.255.255.248
 ipv6 address FE80::1:3 link-local
 ipv6 address 2001:DB8:A:C::1/64
!
interface GigabitEthernet0/0/0
 ip address 10.10.20.1 255.255.255.0
 negotiation auto
 ipv6 address FE80::1:1 link-local
 ipv6 address 2001:DB8:A:B::1/64
!
interface GigabitEthernet0/0/1
 ip address 10.10.10.1 255.255.255.0
 ip helper-address 10.10.20.254
 negotiation auto
 ipv6 address FE80::1:2 link-local
 ipv6 address 2001:DB8:A:A::1/64
 ipv6 address 2001:DB8:A:A::/64 eui-64
 ipv6 dhcp relay destination 2001:DB8:A:B::2
!
interface GigabitEthernet0/0/2
 no ip address
 negotiation auto
!
interface Serial0/1/0
 no ip address
!
interface Serial0/1/1
 no ip address
!
interface Serial0/2/0
 no ip address
!
interface Serial0/2/1
 no ip address
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 negotiation auto
!         
ip forward-protocol nd
no ip http server
ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 Loopback0
!
!
ipv6 route ::/0 Loopback0
!
!
!
!
control-plane
!
banner motd ^C This is R1, Trouble Ticket 1.1.2.3 ^C
alias exec reset.now tclsh flash:/enarsi/reset.tcl
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login local
 transport input telnet
!
!
!
!
!
!
end

R2

Building configuration...


Current configuration : 2276 bytes
!
! Last configuration change at 07:38:20 UTC Thu May 9 2024
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
enable secret 5 $1$R0uh$pGx83hV/5il6QXCOQCOQS1
!
no aaa new-model
!
!
!
!
!
!
!
ip dhcp excluded-address 10.10.10.1 10.10.10.100
!
ip dhcp pool LAN4_10
 network 10.10.10.0 255.255.255.0
 default-router 10.10.10.1 
 domain-name ccnp4lab.com
 dns-server 10.10.20.1 
!
!
!
login on-success log
!         
!
!
!
!
!
!
subscriber templating
! 
! 
! 
! 
vtp domain merger.com.au
vtp mode transparent
!
ipv6 unicast-routing
ipv6 dhcp pool LAN6_A
 dns-server 2001:DB8:A:B::1
 dns-server 2001:DB8:A:B::2
 domain-name ccnp6lab.om
!
multilink bundle-name authenticated
!
!         
!
!
!
!
license udi pid ISR4331/K9 sn FDO24160K04
license boot suite FoundationSuiteK9
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
username admin privilege 15 secret 9 $9$soAi7yMBgrvzeD$iR3q1zjeVVvOBRmdVp3dlSaULGVyQARKZgdU/3buCOA
!
redundancy
 mode none
!
!
!
!
!         
!
!
! 
!
!
!
!
!
!
!
!
!
!
! 
! 
!
!
interface GigabitEthernet0/0/0
 ip address 10.10.20.254 255.255.255.0
 negotiation auto
 ipv6 address FE80::2:1 link-local
 ipv6 address 2001:DB8:A:B::2/64
 ipv6 dhcp server LAN6_A
!
interface GigabitEthernet0/0/1
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/2
 no ip address
 negotiation auto
!
interface Serial0/1/0
 no ip address
!
interface Serial0/1/1
 no ip address
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 negotiation auto
!
ip forward-protocol nd
no ip http server
ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 10.10.20.1
!
!
ipv6 route ::/0 2001:DB8:A:B::1
!
!
!
!
control-plane
!
banner motd ^C This is R2, Trouble Ticket 1.1.2.3 ^C
alias exec reset.now tclsh flash:/enarsi/reset.tcl
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login local
 transport input telnet
!
!
!
!
!
!
end

D1

Building configuration...

Current configuration : 9617 bytes
!
! Last configuration change at 14:37:53 UTC Thu Mar 13 2025
!
version 16.9
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
! Call-home is enabled by Smart-Licensing.
service call-home
no platform punt-keepalive disable-kernel-core
!
hostname D1
!
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!         
enable secret 5 $1$Cb2l$mnnbxxcsnGW4H2xKDQiQf/
!
no aaa new-model
switch 1 provision ws-c3650-24ps
!
!
!
!
call-home
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
  no destination transport-method email
!
!
!
!
!         
!
!
!
login on-success log
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-2750515143
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2750515143
 revocation-check none
 rsakeypair TP-self-signed-2750515143
!
crypto pki trustpoint SLA-TrustPoint
 enrollment pkcs12
 revocation-check crl
!
!         
crypto pki certificate chain TP-self-signed-2750515143
 certificate self-signed 01
  30820330 30820218 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 32373530 35313531 3433301E 170D3235 30333133 31343333 
  35385A17 0D333030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37353035 
  31353134 33308201 22300D06 092A8648 86F70D01 01010500 0382010F 00308201 
  0A028201 0100B2DE D80C1DED 9B2CD865 0A96981C 35BF085D 3141B2C8 FD5BB390 
  B7727D60 78D59B03 5395651F 72EF0914 F4BE8E0F C011A352 88CC4EED ED1DF950 
  FD2709DF 68D5D269 7047DC81 F6E1799A BC105C54 53EE5AF3 C3935B90 2EEBF0BE 
  D332C918 D355DB84 34180E0B 7E3C261A 766AC369 7316EC55 6ECD2DD6 D6E87880 
  892C9C22 A88CFCD7 0D3250A3 CC27541C F8C8BDF2 3D62B817 B5BBEA09 0745E36E 
  F2A795A2 95690804 633B8E81 24DC1B1E BC455546 472ED2A7 23056F0E 7A00AF77 
  0662C265 29C7EB7C BA50689B BEEFDF41 F7F84DC9 B55438A2 A99D60AF B4EDCC86 
  D2A7B049 43BB12BB 0389D089 C556BD49 29CE0DE6 E3568DF7 60A75C37 A799086D 
  89899939 3C830203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 
  301F0603 551D2304 18301680 148D8DA0 9D03EAD6 013E5085 AC514F11 0D578D5B 
  C3301D06 03551D0E 04160414 8D8DA09D 03EAD601 3E5085AC 514F110D 578D5BC3 
  300D0609 2A864886 F70D0101 05050003 82010100 2FD134CD 5C9D0D4C 4D122CF6 
  BE6FD6F0 7E85F678 F734D02D 06D503BD C8EA847F D8497A2F 6B7D2E1D 049C9686 
  9314F65D 663E0891 1CB02DC2 9C5648A2 BD504F22 E953DF4C 805CEE9A 9572B754 
  99174C54 A3EDFAAE 12FA79D6 EEDFCAA8 123617EE BCEA7A1D 2F2DA151 81DE5390 
  58BE4DEE DB236646 43FAF300 3535EF23 287E4DF2 753B64B6 CB996A1D 838A2E2F 
  D035F1E3 907C0C82 D7F62005 DAF15F87 7A237C7A E9A068CD 620DFCF7 873AC14E 
  62BDE81B D73AF1BA 1375C525 E8E08596 6B46AB53 69D791A8 6348AB15 190CA5FD 
  99013901 8AC49EF3 C6CD8DCE A42E03FA 8C576B0F 7A51E99E 1844A78E 85387D4E 
  32073621 F37C2CEA 568C0B1D 67B237B2 33A9B016
        quit
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01
  30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030 
  32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363 
  6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934 
  3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305 
  43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720 
  526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030 
  82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D 
  CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520 
  1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE 
  4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC 
  7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188 
  68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7 
  C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191 
  C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44 
  DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201 
  06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85 
  4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500 
  03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905 
  604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B 
  D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8 
  467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C 
  7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B 
  5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678 
  80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB 
  418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0 
  D697DF7F 28
        quit
!
license boot level ipservicesk9
!
!
diagnostic bootup level minimal
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!
username admin privilege 15 secret 9 $9$tctNtMMrii/NIE$7Kxy0LFOi0qfUpfYRy5ARsmFq8vvdLvkQKyCz/zPEMs
!
redundancy
 mode sso
!
!
!
!
!
transceiver type all
 monitoring
!
!
class-map match-any system-cpp-police-topology-control
  description Topology control
class-map match-any system-cpp-police-sw-forward
  description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
  description Inter FED, EWLC control, EWLC data
class-map match-any system-cpp-police-sys-data
  description Learning cache ovfl, High Rate App, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
  description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
  description L2 LVX control packets
class-map match-any system-cpp-police-forus
  description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
  description MCAST END STATION
class-map match-any system-cpp-police-multicast
  description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
  description L2 control
class-map match-any system-cpp-police-dot1x-auth
  description DOT1X Auth
class-map match-any system-cpp-police-data
  description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
  description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
  description Routing control and Low Latency
class-map match-any system-cpp-police-protocol-snooping
  description Protocol snooping
class-map match-any system-cpp-police-dhcp-snooping
  description DHCP snooping
class-map match-any system-cpp-police-system-critical
  description System Critical and Gold Pkt
!
policy-map system-cpp-policy
!
! 
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet1/0/1
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/2
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/3
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/4
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/5
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/6
 switchport mode access
 shutdown
!         
interface GigabitEthernet1/0/7
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/8
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/9
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/10
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/11
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/0/12
 switchport mode access
 shutdown 
!
interface GigabitEthernet1/0/13
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/14
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/15
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/16
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/17
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/18
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/19
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/20
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/21
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/22
 switchport mode access
 shutdown
!
interface GigabitEthernet1/0/23
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/0/24
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 10.10.10.2 255.255.255.0
!
ip default-gateway 10.10.10.1
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
control-plane
 service-policy input system-cpp-policy
!
banner motd ^C This is D1, Trouble Ticket 1.1.2.3 ^C
alias exec reset.now tclsh flash:/enarsi/reset.tcl
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!         
!
!
!
!
!
!
end

Andrewguory009_0-1741878314274.pngAndrewguory009_1-1741878324914.pngAndrewguory009_2-1741878337088.png

@balaji.bandi Thanks you for your help, if you want to and have free time, you are welcome to answering!

 

4 Replies 4

balaji.bandi
Hall of Fame
Hall of Fame

start with below guide : (if you learning then suggest to post in learning cisco community is best place to learn)

https://study-ccna.com/how-to-configure-ipv6/

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thank you for guiding the standardized posting. I will take this as a template and premise to integrate into the community.How to Ask The Cisco Community for Help

I don't quite understand what you said about this "learning cisco community". Is it that posts are labeled with this tag or there is a community with this name. I haven't found what you mentioned. Could you give a URL?

 

 

 

Harold Ritter
Spotlight
Spotlight

Hi @Andrew guory009 ,

I also realized that the PC did not receive the "reply" from the DHCP server

You need to check the routing between R1 and R2. This should be fairly easy, as you have one static route per router. Make sure the static routes are correct and this should solve this specific issue.

Regards,

Harold

Regards,
Harold Ritter, CCIE #4168 (EI, SP)

Hello,

at first glance, I agree with @Harold Ritter , your IPv6 routing does not look right. On R1, your IPv6 default route points to a local Loopback interface. What if you change that:

from: ipv6 route ::/0 Loopback0

to:


ipv6 route ::/0 2001:DB8:A:B::2

?