04-27-2015 07:25 PM - edited 03-05-2019 01:20 AM
I hope I am posting in the correct category, I apologize if it isn't.
I have purchased a 2821 router to screw around with at home so I can become more familiar with the IOS CLI. However, I cannot seem to figure why NAT is not working. Every NAT translation expires.
G0/0 is set to DHCP to receive an IP from my ISP.
G0/1 is the default gateway for my LAN
Nat statement
"ip nat inside source list NAT interface GigabitEthernet0/0 overload"
NAT ACL is "permit 0.0.0.0 0.0.0.0"
Any help would be greatly appreciated, I am kind of disappointed that I can not figure this out myself :/
Here is the rest of the configuration.
Current configuration : 1380 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Home
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
!
ip domain name PCMasterRace
ip name-server 8.8.8.8
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
no dspfarm
!
!
interface GigabitEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
!
ip http server
no ip http secure-server
ip nat inside source list NAT interface GigabitEthernet0/0 overload
!
ip access-list standard NAT
permit 0.0.0.0
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
logging synchronous
login local
transport input ssh
line vty 5 15
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end
Solved! Go to Solution.
04-28-2015 08:31 AM
hi,
could you post a brief network diagram? is there a modem/router before your 2821?
could you try:
no ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip route 0.0.0.0 0.0.0 dhcp
04-27-2015 09:41 PM
hi,
could you post a show ip interface brief and ping output to 8.8.8.8 from your 2821?
try to re-configure your NAT ACL as below:
no ip access-list standard NAT
no ip nat inside source list NAT interface GigabitEthernet0/0 overload
access-list 10 permit 192.168.2.0 0.0.0.255
ip nat inside source list 10 interface GigabitEthernet0/0 overload
04-28-2015 12:49 AM
Thank you for response, I have already tried using an ACL as specified. I tried using quad zeros when I saw that it was not working. I will try again as you are suggesting. Would a quad zero statement work in this case?
I have tried using show ip int brief and have verified that G0/0 has received an address from my modem. I am able to ping the address from both my host and router.
I have also tried pinging 8.8.8.8 but keep getting timed out. I have noticed that when I use `show ip Nat translations` both the outside local and global appear as 8.8.8.8 . I am unsure if that is normal or not. Nat is still a new concept to me.
Unfortunately, I am very busy at the moment so it may be a bit before I can test and report back.
04-28-2015 08:31 AM
hi,
could you post a brief network diagram? is there a modem/router before your 2821?
could you try:
no ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip route 0.0.0.0 0.0.0 dhcp
04-28-2015 11:59 AM
ip route 0.0.0.0 0.0.0 dhcp
Worked thank you very much! This is the first time I am hearing about DHCP being used as the next hop/exit interface. I am already glad I bought this router and I have already learned something!
04-28-2015 12:00 PM
ip route 0.0.0.0 0.0.0 dhcp
Worked thank you very much! This is the first time I am hearing about DHCP being used as the next hop/exit interface. I am already glad I bought this router and I have already learned something!
04-28-2015 12:01 PM
ip route 0.0.0.0 0.0.0 dhcp
Worked thank you very much! This is the first time I am hearing about DHCP being used as the next hop/exit interface. I am already glad I bought this router and I have already learned something!
04-28-2015 12:01 PM
ip route 0.0.0.0 0.0.0 dhcp
Worked thank you very much! This is the first time I am hearing about DHCP being used as the next hop/exit interface. I am already glad I bought this router and I have already learned something!
12-16-2016 10:39 AM
I know this thread is two years old.
But I have this line in my config
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0
And I was just hoping to get an understanding of what that means.
Actually I have this config file that is full of commands I don't really understand.
I guess I could read a reference, but I was just hoping someone could look at it and explain it to me.
04-12-2020 07:41 PM - edited 04-26-2020 06:26 PM
Hi,
I am sharing a great content which will demonstrate step by step process of Connecting Cisco 2851 Router and Cisco 3560 Switch to ISP Home router and Configuring Cisco Router using Putty and finally Accessing Internet from Laptop and Desktop PC through this network.
PuTTY command line for Router Configuration:
Where hostname of the Router is "Router"
Entering to Privileged mode:
Router>enable
Check IP Interface:
Router#show ip interface brief
Entering to Global Configuration mode:
Router#configure terminal
Entering GE0/0 Interface:
Router(config)#interface gigabitEthernet 0/0
Making Interface up:
Router(config-if)#no shutdown
Assigning IP address from DHCP:
Router(config-if)# ip address dhcp
Ping to Google DNS server:
Router#ping 8.8.8.8
Entering GE0/1 Interface:
Router(config)#interface gigabitEthernet 0/1
Assigning IP address :
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Making Interface up:
Router(config-if)#no shutdown
Creating DHCP pool:
First go to global configuration mode then
Router(config)#ip dhcp pool mainuser
Router(dhcp-config)#network 192.168.2.0 /24
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
Static Routing for default Gateway
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
Configuring NAT Outside:
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Configuring NAT inside:
Router(config)#interface gigabitEthernet 0/1
Router(config-if)#ip nat inside
Router(config-if)#exit
Creating Access list:
Router(config)#ip access-list standard 1
Router(config-std-nacl)#permit any
Router(config-std-nacl)#exit
Overloading IP NAT inside source to the interface gigabitEthernet 0/0:
Router(config)#ip nat inside source list 1 interface gigabitEthernet 0/0 overload
Router(config-if)#exit
https://www.youtube.com/channel/UCmZZ2BNGXQH1HPS3uIVnr7A?sub_confirmation=1
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide