cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
709
Views
0
Helpful
3
Replies
Highlighted
Beginner

Trying to create simple UDP port forward - Error: "NAT unable to reserve ports."

I'm trying to create a new UDP port forward on an ASA 5505 running ASA Version 9.1(4) and ASDM Version 7.1(5). I have multiple TCP forwards currently in place and working, however when I try to create a UDP entry in exactly the same manner, I get the following response:

[OK] object network Scada_Server_47808

object network Scada_Server_47808
[ERROR] nat (inside,outside) static interface service udp 47808 47808
NAT unable to reserve ports.

I have tried clearing XLATE on everything, with no success. I've also tried and retried rebuilding everything, and always run into the same result.

I will post my entire configuration below:

: Saved
:
ASA Version 9.1(4)
!
hostname AVWS
enable password ewGznYg7OLcZXsx7 encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd ewGznYg7OLcZXsx7 encrypted
names
ip local pool Dorsett_Tech_VPN 10.0.10.10-10.0.10.20 mask 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
switchport access vlan 12
!
interface Ethernet0/7
switchport access vlan 999
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.7.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group Strata
ip address pppoe setroute
!
interface Vlan999
description Uplink to Spectra MGT Network
management-only
no forward interface Vlan2
nameif MGT
security-level 50
ip address 10.240.8.26 255.255.252.0
!
boot system disk0:/asa914-k8.bin
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network Suspicious_IP
host 202.39.253.11
description Possible Botnet
object network NETWORK_OBJ_192.168.7.0_24
subnet 192.168.7.0 255.255.255.0
object network Spectra-Roosevelt
subnet 10.236.3.0 255.255.255.0
object network NETWORK_OBJ_10.0.10.0_27
subnet 10.0.10.0 255.255.255.224
object network Scada_Server_80
host 192.168.7.11
description Port 80 Access
object network NVR_8080
host 192.168.7.200
description Port 8080
object network NVR_4443
host 192.168.7.200
description Port 4443
object network NVR_10554
host 192.168.7.200
description Port 10554
object network NVR_8000
host 192.168.7.200
description Port 8000
object network NVR_81
host 192.168.7.200
description Port 81
object network NVR
host 192.168.7.200
object network Scada_Server_443
host 192.168.7.11
description Port 443 Access
object network ASA
host 192.168.7.1
object network inside
object network Scada_Server_47808
host 192.168.7.11
object service 47808
service udp source eq 47808 destination eq 47808
description Scada_47808
object network inside-network
object-group service NVR_Port tcp
port-object eq 10554
port-object eq 4443
port-object eq 8000
port-object eq 81
port-object eq rtsp
port-object eq 8080
object-group network DM_INLINE_NETWORK_1
network-object object Scada_Server_443
network-object object Scada_Server_80
object-group service DM_INLINE_TCP_1 tcp
port-object eq www
port-object eq https
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
object-group service VPN tcp-udp
port-object eq 4444
access-list outside_access_in extended permit tcp any object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_TCP_1
access-list outside_access_in extended permit tcp any object NVR object-group NVR_Port
access-list outside_cryptomap extended permit ip 192.168.7.0 255.255.255.0 object Spectra-Roosevelt
access-list global_access extended permit ip any any
access-list global_access extended permit object-group TCPUDP any any eq 4444
access-list outside_access_in_1 extended permit tcp any object Scada_Server_443 eq https
access-list outside_access_in_1 extended permit tcp any object Scada_Server_80 eq www
access-list outside_access_in_1 extended permit tcp any object NVR object-group NVR_Port
access-list outside_access_in_1 extended permit ip interface outside interface inside
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu MGT 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-715.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static NETWORK_OBJ_192.168.7.0_24 NETWORK_OBJ_192.168.7.0_24 destination static NETWORK_OBJ_10.0.10.0_27 NETWORK_OBJ_10.0.10.0_27 no-proxy-arp route-lookup
!
object network Scada_Server_80
nat (inside,outside) static interface service tcp www www
object network NVR_8080
nat (inside,outside) static interface service tcp 8080 8080
object network NVR_4443
nat (inside,outside) static interface service tcp 4443 4443
object network NVR_10554
nat (inside,outside) static interface service tcp 10554 10554
object network NVR_8000
nat (inside,outside) static interface service tcp 8000 8000
object network NVR_81
nat (inside,outside) static interface service tcp 81 81
object network Scada_Server_443
nat (inside,outside) static interface service tcp https https
!
nat (inside,outside) after-auto source dynamic any interface
access-group outside_access_in_1 in interface outside
access-group global_access global
route inside 192.168.1.0 255.255.255.0 192.168.7.2 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
dynamic-access-policy-record Dorsett
network-acl global_access
network-acl outside_access_in
network-acl outside_access_in_1
webvpn
file-browsing enable
file-entry enable
http-proxy enable
url-entry enable
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable 4433
http 10.0.0.0 255.255.255.0 inside
http 192.168.7.0 255.255.255.255 inside
http 192.168.7.0 255.255.255.0 inside
http 10.240.0.0 255.255.0.0 MGT
http 10.240.8.0 255.255.252.0 MGT
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev2 ipsec-proposal AES256
protocol esp encryption aes-256
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
protocol esp encryption aes-192
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
protocol esp encryption aes
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
protocol esp encryption 3des
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal DES
protocol esp encryption des
protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map outside_map 1 match address outside_cryptomap
crypto map outside_map 1 set peer 67.213.235.147
crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map outside_map0 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map0 interface outside
crypto ca trustpool policy
crypto ikev2 policy 1
encryption aes-256
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 10
encryption aes-192
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 20
encryption aes
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 30
encryption 3des
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 40
encryption des
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 policy 10
authentication crack
encryption aes-256
hash sha
group 2
lifetime 86400
crypto ikev1 policy 20
authentication rsa-sig
encryption aes-256
hash sha
group 2
lifetime 86400
crypto ikev1 policy 30
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
crypto ikev1 policy 40
authentication crack
encryption aes-192
hash sha
group 2
lifetime 86400
crypto ikev1 policy 50
authentication rsa-sig
encryption aes-192
hash sha
group 2
lifetime 86400
crypto ikev1 policy 60
authentication pre-share
encryption aes-192
hash sha
group 2
lifetime 86400
crypto ikev1 policy 70
authentication crack
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 80
authentication rsa-sig
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 90
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 100
authentication crack
encryption 3des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 110
authentication rsa-sig
encryption 3des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 120
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 130
authentication crack
encryption des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 140
authentication rsa-sig
encryption des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 150
authentication pre-share
encryption des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 192.168.7.0 255.255.255.0 inside
ssh 10.240.0.0 255.255.0.0 MGT
ssh 10.240.8.0 255.255.252.0 MGT
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
vpdn group Strata request dialout pppoe
vpdn group Strata localname ******
vpdn group Strata ppp authentication pap
vpdn username ******* password *****

dhcpd auto_config outside
!
dhcpd address 192.168.7.20-192.168.7.50 inside
dhcpd dns 67.213.225.100 interface inside
dhcpd wins 67.213.225.101 interface inside
dhcpd auto_config outside interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics host number-of-rate 3
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
port 4444
enable inside
enable outside
dtls port 4444
anyconnect image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
anyconnect image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 2
anyconnect enable
tunnel-group-list enable
group-policy GroupPolicy_67.213.235.147 internal
group-policy GroupPolicy_67.213.235.147 attributes
vpn-tunnel-protocol ikev1 ikev2
group-policy GroupPolicy_Dorsett internal
group-policy GroupPolicy_Dorsett attributes
wins-server none
dns-server none
vpn-tunnel-protocol ssl-client
default-domain none
group-policy GroupPolicy_avws internal
group-policy GroupPolicy_avws attributes
wins-server none
dns-server value 8.8.8.8
vpn-tunnel-protocol ssl-client ssl-clientless
default-domain none
username ****** password lcPcmwRJe1BQZoEL encrypted
username ****** password beTyMDO9ikUYOde. encrypted privilege 15
username ****** password aON6aeJfGzP4bmEW encrypted
tunnel-group 67.213.235.147 type ipsec-l2l
tunnel-group 67.213.235.147 general-attributes
default-group-policy GroupPolicy_67.213.235.147
tunnel-group 67.213.235.147 ipsec-attributes
ikev1 pre-shared-key *****
ikev2 remote-authentication pre-shared-key *****
ikev2 local-authentication pre-shared-key *****
tunnel-group avws type remote-access
tunnel-group avws general-attributes
address-pool Dorsett_Tech_VPN
default-group-policy GroupPolicy_avws
tunnel-group avws webvpn-attributes
group-alias avws enable
tunnel-group Dorsett type remote-access
tunnel-group Dorsett general-attributes
address-pool Dorsett_Tech_VPN
default-group-policy GroupPolicy_Dorsett
tunnel-group Dorsett webvpn-attributes
group-alias Dorsett enable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
class class-default
user-statistics accounting
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
hpm topN enable
Cryptochecksum:d7490ee285ce0fc2f6bc22a1f6d7bf6f
: end

3 REPLIES 3
Highlighted
Enthusiast

You can't used tcp or udp port forwarding using interface IP address. You have to use separate IP address other than interface

Highlighted

I guess I'm a little confused about this, as I have current NAT rules in place in the identical manner using interface.

Highlighted

Using interface only PAT for outbound is possible.