cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10917
Views
20
Helpful
6
Replies

unable to copy run FTP (VRF Aware)

fasikaasresu
Beginner
Beginner

                   my interface is in a specific VRF

interface Loopbackx

  ip vrf forwarding  MGMTxxx

ip address xxxxxxxxxx

and the global comand

ip tftp source-interface Loopbackx is also enable

the problem is

though I can ping to the ftp server

and I can telnet to the ftp server using port 21

I am not able to copy run tftp/....../sublocation/

any help is apreciated

1 ACCEPTED SOLUTION

Accepted Solutions

jai_chandra2001
Beginner
Beginner

i tried

copy ftp://username:password@1.1.1.1 bootflash:  vrf <vrf name>

and it worked on 4500 switch

View solution in original post

6 REPLIES 6

Vasilii Mikhailovskii
Rising star
Rising star

Hello.

you are copying file via FTP, but configured source-interface for TFTP.

If the guess is wrong, could you please share your configuration and failed attempt output?

PS: FTP is using TCP 21/20, TFTP is using UDP 69. Btw, you might need to configure FTP as passive (ip ftp passive) to use TCP 21 only, because TCP20 could be blocked somewhere.

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

On the source router is tftp or FTP enabled?

Tftp server xxxxx

Ip ftp username xxxx
ip ftp password xxx
ip ftp passive
ip ftp source-interface xxx


Res
Paul

Sent from Cisco Technical Support iPad App


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

jai_chandra2001
Beginner
Beginner

i tried

copy ftp://username:password@1.1.1.1 bootflash:  vrf <vrf name>

and it worked on 4500 switch

This solution works on 9300 as well, Thank you Jai...

You can also set the ip ftp source-interface to the interface configured on the associated vrf. (you can do this in the global configuration mode)

craiglong
Beginner
Beginner

If you're having this problem on a device that doesn't support the vrf option at the end of the copy command, try just sourcing the ftp traffic from the interface that's in the vrf. 

 

For example, on a 3850, the Managment port, Gi0/0, is in the Mgmt-vrf by default and can't be changed.  Since I didn't have an option to use the vrf at the end of the copy command like you can on a 4500, I just did an 'ip ftp source-interface Gi0/0' and the copy command knew to use that Mgmt-vrf vrf to access the ftp server.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: