cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1063
Views
0
Helpful
8
Replies

Unable to ping router from switch

jman1
Level 1
Level 1

I am unable to ping my router when I have my config as so:

 

interface GigabitEthernet0/0/1
description Data Vlan - MX64 Link
ip address 172.30.139.1 255.255.255.0
ip helper-address 172.30.101.21
no ip redirects
ip nat inside
no cdp enable
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.30.139.1
ip virtual-reassembly
!

 

When my config is like below, I can ping the router:

 

interface GigabitEthernet0/0/0.139
description Data Vlan - MX64 Link
encapsulation dot1Q 139
ip address 172.30.139.1 255.255.255.0
ip helper-address 172.30.101.21
no ip redirects
ip nat inside
no cdp enable
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.30.139.1
ip virtual-reassembly
!

 

My switch port link is configured as so:

 

interface GigabitEthernet1/0/52
description Link to ROUTER
switchport mode trunk

!

Router link:

 


interface GigabitEthernet0/0/0
description Link to Switch INSIDE
no ip address
negotiation auto
!

 

I'm trying to save some ports and direct connect to my router as apposed to having multiple connectings com into my switch and over my trunk. 

 

8 Replies 8

Tinashe Ndhlovu
Level 1
Level 1

If I understood you requirement correctly

on the switch change this

 

interface GigabitEthernet1/0/52
description Link to ROUTER
switchport mode trunk

 

To this:

 

interface GigabitEthernet1/0/52
description Link to ROUTER
switchport mode access

switchport access vlan 139

 

 

I have 3 other vlans. Do I need to add access for those as well?  Edit: Still not able to pint my router from my switch when applying the suggested config.

No. just the one vlan and you will be able to ping the router. You do have another port on the switch connecting to your router right? Carrying the other vlans... if not then I would need more detailed info regarding your setup 

That is the only connection between the switch and router.  

 

Router:

 

!
!
interface GigabitEthernet0/0/0
description Link to Switch INSIDE
no ip address
negotiation auto
!
interface GigabitEthernet0/0/0.10
description Vlan to Fiber Network
encapsulation dot1Q 10
ip address 172.20.10.139 255.255.255.0
no cdp enable
service-policy output WAN-QOS
ip virtual-reassembly
!
interface GigabitEthernet0/0/0.99
shutdown
!
interface GigabitEthernet0/0/0.104
description Imaging and Test LAN
encapsulation dot1Q 104
ip address 172.30.104.2 255.255.255.0
ip helper-address 172.30.101.21
ip helper-address 172.30.102.81
!
interface GigabitEthernet0/0/0.200
description VOICE
encapsulation dot1Q 200
ip address 10.30.139.1 255.255.255.0
ip nat inside
no cdp enable
ip virtual-reassembly
!
interface GigabitEthernet0/0/1
description Data Vlan - MX64 Link
ip address 172.30.139.1 255.255.255.0
ip helper-address 172.30.101.21
no ip redirects
ip nat inside
negotiation auto
no cdp enable
h323-gateway voip bind srcaddr 172.30.139.1
ip virtual-reassembly
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto

 

Switch:

 

!
interface FastEthernet0
no ip address
shutdown
!
interface GigabitEthernet1/0/1
description link to Charter EPLAN
switchport access vlan 10
switchport trunk native vlan 10
switchport trunk allowed vlan 10
switchport mode trunk
speed 100
duplex full
!
interface GigabitEthernet1/0/2
description Copper Link to Switch BAY2960Xb
switchport mode trunk
!
interface GigabitEthernet1/0/3
description Link to MX64
switchport access vlan 139
switchport mode access
!
interface GigabitEthernet1/0/4
switchport access vlan 139
switchport mode access
switchport voice vlan 200
spanning-tree portfast
!
interface GigabitEthernet1/0/5
switchport access vlan 139
switchport mode access
switchport voice vlan 200
spanning-tree portfast
!
interface GigabitEthernet1/0/52
description Link to ROUTER
switchport mode trunk
!

 

I want to plug my fiber network into my switch and plug the MX connection directly into my router.

 

 

Is the router not routing for the other vlans?? 

It is routing all the Vlans.

Sorry man it's late night out here explain to me exactly what you are trying to achieve... you wanna save ports where? On the switch or router? Or you don't want every vlan to have access to you router etc 

Just trying to save ports on the switch. I had this all connected and working with all my uplinks connected to the switch trunked over to the router via gi0/0/0 with sub interfaces for my vlans. It's not a big deal if I am unable to set it up via gi0/0/1 on the router but I was just curious as to why it would not work. Thanks.
Review Cisco Networking for a $25 gift card