cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
179
Views
20
Helpful
6
Replies
Highlighted
Beginner

Unable to route over the ATM Interface

Hi, 

I have very old Cisco router (878) . It ATM port is Up and working. I want to route site B to A.so I set 1.1.1.1 on site A router and set 1.1.1.2 on site B router ATM interface. 

on site B router I can see remote network. can ping any host on remote network. without packet lost.all pc on site B are using  Cisco IP LAN address as gateway.

The problem is that when I ping 1.1.1.1 on pc it has 75% packet lost! at the same time I have :

 

ping 1.1.1.2 (ok)

ping 2.2.2.2 (ok)

ping 1.1.1.1(not ok, 4 ping request but only one(sometime zero) reply. )

 

It seems that there is a trick on routing over ATM interface,

I am newbie in Cisco . Any Help?!

 

Here is my config(site B):

=========

ontroller DSL 0
 mode atm
 line-term cpe
 line-mode 2-wire line-zeroin	
 dsl-mode shdsl symmetric annex B
 line-rate auto
!
!
policy-map LLQ
!
!
bridge crb
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!



interface ATM0
 ip address 1.1.1.2
 no atm ilmi-keepalive
 pvc 0/80
  encapsulation aalin5snap
 !
 bridge-group 1
!
interface FastEthernet0
switchport access vlan 10 ! interface FastEthernet1 ! interface FastEthernet2 ! interface FastEthernet3 ! interface Vlan10 ip address 2.2.2.2 255.255.255.0 !
interface Vlan1 no ip address bridge-group 1 !
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 1.1.1.1

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Master

Re: Unable to route over the ATM Interface

It is an old config. I can not address the issue about dropping packets. But I can address the comment by Georg. Your config does not have a BVI and that is appropriate. BVI is used in Integrated Routing And Bridging. IRB allows routing of IP on some interfaces, bridging of IP on some interfaces, and allows routing between the routed domain and the bridged domain. But your config does not use IRB. Your config uses CRB. Concurrent Routing and Bridging allows routing of IP on some interfaces and bridging of IP on some interfaces, but does not support routing between the routed domain and the bridged domain.

 

CRB was an earlier technology and IRB was introduced to enhance the functionality. IRB is newer and has greater capabilities and is much more common than CRB. But CRB is what you have got and if it is working then it seems that it is good enough for your particular environment.

 

If you remove the bridge group you will significantly impact the operation of the router. If it is working now then I suggest leaving the bridge group alone.

 

As I was about to hit enter another though occurred to me. You describe this as an old router. But it is not clear whether it is continuing to operate in its original environment or whether you are attempting to use it in a new environment. If it is still operating in its original environment then my advice to leave it alone stands. But if you are attempting to use it in a new environment then perhaps we should consider whether it still needs crb or not.

 

HTH

 

Rick

View solution in original post

6 REPLIES 6
VIP Mentor

Re: Unable to route over the ATM Interface

Hello,

 

you have a bridge group but no BVI ? What is the bridge group for ?

Beginner

Re: Unable to route over the ATM Interface

Hi,

TNX for reply.

It was in old config. ATM interface and vlan1(LAN side) interface has the same bridge group,I do not have any BVI now.

should I remove bridge group?!

 

Hall of Fame Master

Re: Unable to route over the ATM Interface

It is an old config. I can not address the issue about dropping packets. But I can address the comment by Georg. Your config does not have a BVI and that is appropriate. BVI is used in Integrated Routing And Bridging. IRB allows routing of IP on some interfaces, bridging of IP on some interfaces, and allows routing between the routed domain and the bridged domain. But your config does not use IRB. Your config uses CRB. Concurrent Routing and Bridging allows routing of IP on some interfaces and bridging of IP on some interfaces, but does not support routing between the routed domain and the bridged domain.

 

CRB was an earlier technology and IRB was introduced to enhance the functionality. IRB is newer and has greater capabilities and is much more common than CRB. But CRB is what you have got and if it is working then it seems that it is good enough for your particular environment.

 

If you remove the bridge group you will significantly impact the operation of the router. If it is working now then I suggest leaving the bridge group alone.

 

As I was about to hit enter another though occurred to me. You describe this as an old router. But it is not clear whether it is continuing to operate in its original environment or whether you are attempting to use it in a new environment. If it is still operating in its original environment then my advice to leave it alone stands. But if you are attempting to use it in a new environment then perhaps we should consider whether it still needs crb or not.

 

HTH

 

Rick

View solution in original post

VIP Mentor

Re: Unable to route over the ATM Interface

Good information from Rick on the CRB.

 

On a side note, you could try and 'offload' the ATM interface config to a dialer, not sure if that would make a difference. The config would look like below (changes marked in bold):

 

controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zeroin
dsl-mode shdsl symmetric annex B
line-rate auto
!
policy-map LLQ
!
bridge crb
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/80
encapsulation aal5mux ppp dialer
!
bridge-group 1
!
interface FastEthernet0
switchport access vlan 10
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan10
ip address 2.2.2.2 255.255.255.0
!
interface Vlan1
no ip address
ip tcp adjust-mss 1452
bridge-group 1
!
interface Dialer0
ip address 1.1.1.2 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
bridge-group 1
!
dialer-list 1 protocol ip permit
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 1.1.1.1

VIP Mentor

Re: Unable to route over the ATM Interface

Hello,

 

or rather, try and use a point  to point subinterface:

 

controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zeroin
dsl-mode shdsl symmetric annex B
line-rate auto
!
policy-map LLQ
!
bridge crb
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface ATM0
no ip address
no atm ilmi-keepalive

interface ATM0.1 point-to-point
pvc 0/80
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
bridge-group 1
!
interface FastEthernet0
switchport access vlan 10
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan10
ip address 2.2.2.2 255.255.255.0
!
interface Vlan1
no ip address
ip tcp adjust-mss 1452
bridge-group 1
!
interface Dialer0
ip address 1.1.1.2 255.255.255.252

encapsulation ppp
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
bridge-group 1
!
dialer-list 1 protocol ip permit
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 1.1.1.1

Beginner

Re: Unable to route over the ATM Interface

TNX Georg , 

Great Help

It seems that I should change my topology to have a good connection.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards