cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
494
Views
0
Helpful
5
Replies
Highlighted
Participant

Unsuccessful ping, despite s0/0 is up

Two C2610 connected via Serial V.35 cables.

R2 router S0/0 IP = 10.0.0.2

R3 router S0/0 IP = 10.0.0.3 (DCE)

On both routers, int s0/0 displays

s0/0 is up, line protocol is up.

However, I ping the IP addresses locally and ping is unsuccessful. What am I missing ? Config of r2 is shown below.

Building configuration...

Current configuration : 651 bytes

!

version 12.3

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname r2

!

boot-start-marker

boot-end-marker

!

enable secret xxx

enable password xxx

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

!

!

!

interface Ethernet0/0

ip address 10.0.0.2 255.0.0.0

half-duplex

no cdp enable

!

interface Serial0/0

ip address 192.168.2.62 255.255.255.0

no fair-queue

!

router rip

network 10.0.0.0

network 192.168.2.0

!

ip http server

ip classless

!

!

!

line con 0

exec-timeout 0 0

5 REPLIES 5
Highlighted
Beginner

Please paste the sh int s0/0 output on forum

Jaison

Highlighted

Did you configure a "clock rate" on the DCE (R3) Router?

Highlighted

Dirk

When you can not ping the local interface it is frequently due to a mismatch in addressing between the two ends of the serial connection.

The reason that a mismatch of addressing can prevent ping to the local interface is because the ping to the local interface generates a ping packet which is actually transmitted over the serial, received by the remote router, and forwarded back over the serial. So if the remote router does not match up addressing with your router then ping will fail.

I notice that you message indicates that the serial addresses are 10.0.0.2 and 10.0.0.3. But the config that you posted shows that the 10.0.0.2 is on the Ethernet not on the serial. It looks like CDP is enabled on the serial interface. So a show cdp neighbor detail would be am easy way to verify whether addressing matches up correctly or not since the remote router IP address is shown in the show cdp neighbor detail output.

HTH

Rick

HTH

Rick
Highlighted

Interesting.

On r2 I did:

...

router rip

network 10.0.0.0

network 192.168.2.0

I did the same on r3.

Then I removed the 'router rip' from r3, and all of sudden ping was successful. It is working now.

Highlighted

In regards to "the ping to the local interface generates a ping packet which is actually transmitted over the serial, received by the remote router, and forwarded back over the serial." I've known this to be true for a while now, but why is this done? Is this done only on non-broadcast medium? It doesn't appear that this behavior exists on ethernet connections? Is there a document that describes Cisco's ping workflow as it relates to router architecture? Thanks.

Jason