cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2123
Views
2
Helpful
8
Replies

vlan's on layer 3 switches

tobias quartier
Level 1
Level 1

So I am wondering, if you have let's say 2 end-devices from the same vlan and you want to connect them directly to a layer 3 switch without a layer 2 switch in between. How do I create the correct SVI's for both of the ports on the layer 3 switch. I don't really understand how you configure two layer 3 switch ports to the same vlan. Do you simply just give them the same vlan-id and an ip-adress in the same range of that vlan? Sorry if this is a stupid question but I'm a bit new to networking :).

1 Accepted Solution

Accepted Solutions

M02@rt37
VIP
VIP

Hello @tobias quartier 

When connecting two end devices from the same VLAN directly to a L3 switch without an intermediate L2 switch, you need to configure the ports on the Layer 3 switch to belong to the same VLAN and set up an SVI (switch virtual interface) for that VLAN to manage Layer 3 routing. Assign the specific ports to the VLAN by configuring them as access ports and specifying the VLAN id. Then, create the VLAN on the switch if it doesn't already exist. After that, configure the SVI for the VLAN by assigning it an IP address, which will serve as the default gateway for the devices within that VLAN. This setup enables both end devices to communicate within the VLAN and access other networks through the SVI. Below are the necessary commands to configure this on a L3 switch:


configure terminal
interface GigabitEthernet0/1
switchport mode access
switchport access vlan 10
no shutdown
exit
interface GigabitEthernet0/2
switchport mode access
switchport access vlan 10
no shutdown
exit
vlan 10
name User_VLAN
exit
interface Vlan10
ip address 192.168.10.1 255.255.255.0
no shutdown

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

View solution in original post

8 Replies 8

the 2 endpoint will connect to L2 port of L3SW, this L2 port not need IP so the L3SW accept it 
then you config IP for VLAN SVI 
in end you will get three IP (or more)
two IP of endpoints 
one IP (or more) of VLAN SVI 
MHM

Martin L
VIP
VIP

First add vlan x and vlan Y to switch database (or make end port access port in vlan x which adds vlan x to database). Create SVI vlan x and Y, add IPs and no shut command.  Connect PC to access port in vlan x another PC to access port in vlan Y; The traffic received via vlan x will go to SVI x while PC in access vlan Y goes to SVI Y. This is done internally on the switch board.  Check if interface SVI x and Y are UP UP sate with command show ip interface brief. Turn On ip routing (if off) and check IP RIB with show ip routing command.  If PCx pings PC y, switch moves packets internally from access ports x to SVI x to SVI y to exit port access vlan y.  Both SVIs must be on different subnets.  

Regards, ML
**Please Rate All Helpful Responses **

So it's not possible to have both of the PC's working on the same vlan?

two endpoint in same VLAN no need VLAN SVI in SW 
two endpoint in different VLAN need VLAN SVI in SW

VLAN SVI in SW dont pass any traffic between two endpoints if are in same VLAN so it not need.
MHM

no, always possible for 2 or more PCs in the access port vlan x to communicate with each others; this is done without SVI at layer 2; SVI -layer 3- is used only if PC traffic goes out side to another vlan.i.e. vlan y.   If u do not use SVIs, then u need Router -on-a-stick concept. 

PC should have its default getaway set to IP of SVI in corresponding vlan .

Regards, ML
**Please Rate All Helpful Responses **

M02@rt37
VIP
VIP

Hello @tobias quartier 

When connecting two end devices from the same VLAN directly to a L3 switch without an intermediate L2 switch, you need to configure the ports on the Layer 3 switch to belong to the same VLAN and set up an SVI (switch virtual interface) for that VLAN to manage Layer 3 routing. Assign the specific ports to the VLAN by configuring them as access ports and specifying the VLAN id. Then, create the VLAN on the switch if it doesn't already exist. After that, configure the SVI for the VLAN by assigning it an IP address, which will serve as the default gateway for the devices within that VLAN. This setup enables both end devices to communicate within the VLAN and access other networks through the SVI. Below are the necessary commands to configure this on a L3 switch:


configure terminal
interface GigabitEthernet0/1
switchport mode access
switchport access vlan 10
no shutdown
exit
interface GigabitEthernet0/2
switchport mode access
switchport access vlan 10
no shutdown
exit
vlan 10
name User_VLAN
exit
interface Vlan10
ip address 192.168.10.1 255.255.255.0
no shutdown

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Joseph W. Doherty
Hall of Fame
Hall of Fame

If both end-devices are same VLAN, there would only be one SVI, for the VLAN, on the L3 switch.

What I suspect you have in mind, when there's a L2 switch between L3 switches, is each L3 switch may each have a SVI for the VLAN.  This because there are two logical L3 devices.  However, if the two L3 switches were one logical L3 switch (e.g. VSS, virtual stack) there would, again, be just one SVI.

Hello,

I have added EIGRP to all L3 devices, you should now have full connectivity.

Review Cisco Networking for a $25 gift card