11-22-2012 06:33 AM - edited 03-04-2019 06:12 PM
This network has 3 vlans - users & printing on the core switch. This core switch is running bgp with upstream router & this upstream routers runs vrf.
The core switch has a physical interface connected and configured with ip address towards the upstream router.
(core switch - 192.168.100.2/30 and router - 192.168.100.1/30)
Routing and connectivity works fine without vrf. When we enable vrf , the user connected with dhcp ip loses connectivity.
Is there any specific thing needed to be done for enabling connectivity to all vlans when vrf is turned on.
bgp configuration is :-
router bgp 65001
bgp log-neighbor-changes
network 10.50.20.0 mask 255.255.255.0
network 192.168.100.2 mask 255.255.255.252
network 10.58.10.0 mask 255.255.255.128
neighbor 192.168.100.1 remote-as 65005
no auto-summary
the vrf configuration used to turn it on is:-
ip vrf netone
rd 65001:100
route-target both 65005:120
router bgp 65001
address-family ipv4 vrf netone
neighbor 192.168.100.1 remote-as 65005
neighbor ip-address activate
interface gig0/2
ip address 192.168.100.1 255.255.255.252
what is wrong with this.
Thanks in advance!
Solved! Go to Solution.
11-22-2012 06:51 AM
Hello Suthomas1,
as I have explained in your previous thread the configuration of the L3 interfaces, including the gi0/2 and the three SVI interfaces need to a command that references the VRF
int gi0/2
ip vrf forwarding netone
! retype ip address and mask
ip address 192.168.100.1 255.255.255.252
the same activity should be done on the SVI interfaces
int vlan X
ip vrf forwarding netone
! retype ip address and mask
ip address x.x.x.x 255.255.255.y
!
for each SVI in VRF
also the eBGP neighbor in VRF has to be the other IP address in the subnet 192.168.100.2 not the local IPP address.
Hope to help
Giuseppe
11-22-2012 06:51 AM
Hello Suthomas1,
as I have explained in your previous thread the configuration of the L3 interfaces, including the gi0/2 and the three SVI interfaces need to a command that references the VRF
int gi0/2
ip vrf forwarding netone
! retype ip address and mask
ip address 192.168.100.1 255.255.255.252
the same activity should be done on the SVI interfaces
int vlan X
ip vrf forwarding netone
! retype ip address and mask
ip address x.x.x.x 255.255.255.y
!
for each SVI in VRF
also the eBGP neighbor in VRF has to be the other IP address in the subnet 192.168.100.2 not the local IPP address.
Hope to help
Giuseppe
11-22-2012 06:58 AM
Thanks Giuseppe. IP address went wrong during typing, it is 100.2
In one of the vlans, we have ip helper address configured, does it need any change if we configure vrf under that vlan?
thanks.
11-22-2012 08:29 AM
There is no such prerequisite if you used helper address under the interface configuration and that interface is also a member of a VRF.
Please make sure that the helper address is reachable with the source ip of that interface from that VRF routing Table.
Example -
ping ip vrf
as when the helper address is used, then the unicast packet is sent to the server from the source ip of that VLAN,
- HTH
Rahul
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide