01-30-2013 05:30 AM - edited 03-04-2019 06:53 PM
Hi, I have tried configuring LLQ to prioritise Voice over the WAN. I have done this on some of our Branch Routers and the queuing seems to be working fine. However, I have introduced the same config on our Core Router and I am seeing dropped packets on the Default Class. I have configured a priority queue for Voice Streams and another queue for Signalling traffic. There is then also the Class-Default which all other traffic will be flowing through. 25 Percent of bandwidth is taken by the Priority Queue and 5% for the Signalling Queue. Any ideas why I am seeing dropped packets in the Class-Default?
class-map match-all VOIP
match access-group 170
class-map match-all SIGNAL
match access-group 171
!
!
policy-map LLQ
class VOIP
priority percent 25
set ip precedence 5
class SIGNAL
bandwidth percent 5
set ip precedence 4
class class-default
fair-queue
!
interface FastEthernet0/0
description WAN
bandwidth 10240
ip address 1.2.3.4 255.255.255.254
ip nat inside
ip virtual-reassembly
load-interval 30
duplex full
speed 10
service-policy output LLQ
!
access-list 170 permit udp any any range 16384 31700
access-list 170 permit tcp any any eq 1720
access-list 170 deny ip any any
access-list 171 permit tcp any any eq 67
access-list 171 permit tcp any any eq 68
access-list 171 permit tcp any any eq 389
access-list 171 permit tcp any any eq 8404
access-list 171 permit tcp any any eq 1700
access-list 171 permit tcp any any eq 1701
access-list 171 permit tcp any any eq 1702
access-list 171 permit tcp any any eq 5000
access-list 171 deny ip any any
sh policy-map
Policy Map LLQ
Class VOIP
Strict Priority
Bandwidth 25 (%)
set ip precedence 5
Class SIGNAL
Bandwidth 5 (%) Max Threshold 64 (packets)
set ip precedence 4
Class class-default
Flow based Fair Queueing
Bandwidth 0 (kbps) Max Threshold 64 (packets)
sh policy-map int fa0/0
FastEthernet0/0
Service-policy output: LLQ
Class-map: VOIP (match-all)
322662 packets, 69065163 bytes
30 second offered rate 89000 bps, drop rate 0 bps
Match: access-group 170
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 25 (%)
Bandwidth 2560 (kbps) Burst 64000 (Bytes)
(pkts matched/bytes matched) 135854/29120086
(total drops/bytes drops) 0/0
QoS Set
precedence 5
Packets marked 322662
Class-map: SIGNAL (match-all)
7108 packets, 2699847 bytes
30 second offered rate 2000 bps, drop rate 0 bps
Match: access-group 171
Queueing
Output Queue: Conversation 265
Bandwidth 5 (%)
Bandwidth 512 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 2497/1004453
(depth/total drops/no-buffer drops) 0/0/0
QoS Set
precedence 4
Packets marked 7109
Class-map: class-default (match-any)
3058039 packets, 2234596119 bytes
30 second offered rate 8735000 bps, drop rate 49000 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 26/5709/0
Any help would be greatly appreciated, let me know if you need any more config/output.
Thanks
Solved! Go to Solution.
01-30-2013 08:10 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Those drops are likely due to transient congestion. (Notice how you had 26 packets queued in class-default when you did the show.)
For 10 Mbps, default queue depths can often "safely" be increased. See if your default-class will accept a larger queue limit.
01-30-2013 06:32 AM
I think your drop count is not that excessive at 5709 drops total for the default-class. But you have hard coded your interface for 10Mbps and if I read correctly the policy-map interface output for the default class shows a 30 second rate of 8735000 bps = 8.3Mbps
30 second offered rate 8735000 bps, drop rate 49000 bps
It would appear that your maxing out on the default class from time to time which is causing drops in that class. Is this an over subscribed interface?
Regards
Stephen
==========================
http://www.rConfig.com
A free, open source network device configuration management tool, customizable to your needs!
- Always vote on an answer if you found it helpful
01-30-2013 08:10 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Those drops are likely due to transient congestion. (Notice how you had 26 packets queued in class-default when you did the show.)
For 10 Mbps, default queue depths can often "safely" be increased. See if your default-class will accept a larger queue limit.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide