01-22-2015 04:27 AM - edited 03-05-2019 12:37 AM
We have two sites, with fibre broadband at both sites (40/10Mbps). One site has a UC500 that hosts 6 phones and 2 phones connect remotely via IPSec VPN on a Cisco 887VA router.
I am trying to apply QoS for the voice traffic for best performance over VPN but getting stuck as to where I should be applying the policy map.
This is a config snippet of the remote site router:
!
class-map match-all voice
match protocol skinny
match protocol sip
class-map match-all rtp
match protocol rtp
!
policy-map voip
class rtp
priority 300
class voice
priority 100
class class-default
police 500000
interface Ethernet0
no ip address
!
interface Ethernet0.101
description **BT Fibre**
encapsulation dot1Q 101
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
bandwidth 8000
ip address negotiated
no ip proxy-arp
ip mtu 1492
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp header-compression iphc-format
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password
ppp pap sent-username
ppp ipcp route default
no cdp enable
ip rtp header-compression iphc-format
!
Am I on the right path? Should I apply the service-policy to the Dialer 0 for outgoing traffic or incoming?
01-22-2015 07:09 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
It's been years since I've worked with a dialer interface, so I'm unsure where QoS should be applied. However, if you're working with bandwidth less that port bandwidth, you should shape for it, otherwise your QoS will only "engage" when the port, itself, congests. Also, normally you work to provide egress QoS on both sides.
If you can manage both sides egress, especially with shaping, there's often rarely need to "police" traffic, as you're doing in your class-default.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide