cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
521
Views
0
Helpful
3
Replies

VRF and EIGRP on Cisco IOS 12.2 (19)

restrickland
Level 1
Level 1

I'm not able to assign an autonomous system number to the address-family ipv4. the command is not in my ios version. what am I missing to allow the networks to propagate across the autonomous system and the vrf?

config

Building configuration...
!
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname TESTROUTER
!
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
ip name-server 2.2.2.2
no ip dhcp conflict logging
!
!
ip vrf NGTS
 rd 188:1
 route-target export 188:1
 route-target import 188:1
!
!
!
interface FastEthernet0/0
 no ip address
 ip route-cache flow
 duplex auto
 speed auto
!
interface FastEthernet0/0.118
 description Brooklyn Garage LAN
 encapsulation dot1Q 118
 ip address 10.118.1.254 255.255.0.0
 ip helper-address 2.2.2.2
!
interface Serial0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 ip address 192.168.3.118 255.255.255.0
 ip route-cache flow
 speed 100
 full-duplex
!
interface FastEthernet0/1.2
 encapsulation dot1Q 2
 ip vrf forwarding TESTVRF
 ip address 192.168.2.118 255.255.255.0
!
router eigrp 1
 network 10.118.0.0 0.0.255.255
 network 192.168.3.0
 no auto-summary
!
router eigrp 188
 network 192.168.2.0
 auto-summary
!
ip classless
ip http server
!


!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 logging synchronous
!
ntp clock-period 17208674
ntp server 1.1.1.1 prefer
end

3 Replies 3

Hello,

which command is not in your IOS ? Wich 12.2 version are you running ?

Router(config)# ip vrf RED
Router(config-vrf)# rd 1:1
Router(config-vrf)# exit
Router(config)# router eigrp 1
Router(config-router)# address-family ipv4 vrf RED
Router(config-router-af)# autonomous-system 101
Router(config-router-af)# network 172.16.0.0
Router(config-router-af)# default-metric 10000 100 255 1 1500
Router(config-router-af)# exit-address-family


The following examples configure a single VRF named VRF-RED in Cisco IOS Release 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE and Cisco IOS XE Release 2.5 and later releases:

Router(config)# ip vrf VRF-RED
Router(config-vrf)# rd 1:1
Router(config-vrf)# exit
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 vrf VRF-RED autonomous-system 1
Router(config-router-af)# network 10.0.0.0 0.0.0.255
Router(config-router-af)# topology base
Router(config-router-topology)# default-metric 10000 100 255 1 1500
Router(config-router-topology)# exit-af-topology
Router(config-router-af)# exit-address-family

this is the command that seems to be missing. When I do a show ver The iOS version is 12.2 (19)


Router(config-router)# address-family ipv4 vrf RED

Hello,

the command also isn't available when you use an EIGRP named configuration ?

Router(config)# router eigrp virtual-name

Which IOS are you running ?

Review Cisco Networking for a $25 gift card