11-12-2024 09:21 AM
Hi guys,
I currently have a router that doing EIGRP, below is its EIGRP:
router eigrp Prod
!
address-family ipv4 unicast autonomous-system 150
!
topology base
redistribute connected
redistribute static
exit-af-topology
network 10.10.10.0
exit-address-family
Because I don't want new route leak into current EIGRP Prod above, I just configured a new interface and put it in a VRF (before the router didn't any VRF):
vrf definition External
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
Interface g0/0/0
vrf fowarding External
ip address 172.16.16.1 255.255.255.250
no shutdown
Would this command 'redistribute connected' which under EIGRP Prod above advertise my newly 172.16.16.1/30 into EIGRP Prod even though I have this interface g0/0/0 in a VRF?
Thanks.
11-12-2024 09:27 AM
NO you need route leaking between VRF and global RIB otherwise the prefix will not redistrubte
MHM
11-12-2024 10:14 AM
Thanks. Just for my learning:
If I don't have a VRF configured for my new interface g0/0/0, would this 'redistribute connected' command in EIGRP Prod advertise my prefix 172.16.16.0/20 into it?
Does EIGRP have command to do route leaking between VRF?
11-12-2024 10:28 AM
If I don't have a VRF configured for my new interface g0/0/0, would this 'redistribute connected' command in EIGRP Prod advertise my prefix 172.16.16.0/20 into it? Yes
Does EIGRP have command to do route leaking between VRF? NO you need bgp for leaking
MHM
11-13-2024 12:39 AM
Hello
You need to add that interface into its own address VRF AS
Example::
router eigrp Prod
address-family ipv4 unicast vrf External autonomous-system 150
af-interface g0/0/0
network 172.16.16.1 0.0.0.0
11-13-2024 09:27 AM
Hi Paul, i dont want to advertise this prefix into existing EIGRP Prod.
Thanks.
11-14-2024 12:16 AM
Hello
So what do you want to do with it, either way its in it own vrf so the other eigrp routes in the eigrp process wont be able to reach it just other hosts in the same vrf will be able to either dynamically via eigrp or statically.
12-04-2024 11:28 AM
is this issue solved ?
MHM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide