cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1273
Views
0
Helpful
6
Replies

vrf route leaking

1.jpeg.jpg

 

 

 

 

please help

i need to go to vrf internet from global routing table in R6

 

need to ping 1.1.1.1 from R6 ???????????

 

 

R1

!

ip vrf Internet

rd 65:65

!

interface FastEthernet0/0

ip address 172.16.234.1 255.255.255.0

!

interface FastEthernet1/0

no ip address

!

interface FastEthernet1/0.3018

encapsulation dot1Q 3018

ip vrf forwarding Internet

ip address 10.40.82.162 255.255.255.252

!

interface FastEthernet1/0.3019

encapsulation dot1Q 3019

ip address 10.40.82.158 255.255.255.252

!

interface FastEthernet1/1

ip vrf forwarding Internet

ip address 122.116.89.161 255.255.255.224

!

router eigrp 100

redistribute connected

redistribute static

network 10.40.82.156 0.0.0.3

auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.16.234.254

ip route vrf Internet 0.0.0.0 0.0.0.0 10.40.82.161

 

====================================

R6

 

interface FastEthernet0/0

ip address 10.40.82.157 255.255.255.252

duplex half

!

interface FastEthernet1/0

ip address 172.16.55.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

shutdown

duplex auto

speed auto

!

router eigrp 100

redistribute connected

redistribute static

network 10.40.82.0 0.0.0.255

auto-summary

!

ip forward-protocol nd

ip route 172.16.66.0 255.255.255.0 172.16.55.254

==================================================

R3

 

interface FastEthernet0/0

ip address 172.16.234.254 255.255.255.0

duplex half

!

interface FastEthernet1/0

ip address 172.16.151.254 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.16.234.1

 

=======================================

 

Internet

 

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Loopback2

ip address 2.2.2.2 255.255.255.255

!

interface Loopback3

ip address 3.3.3.3 255.255.255.0

!

interface Loopback4

ip address 4.4.4.4 255.255.255.0

!

interface Loopback5

ip address 5.5.5.5 255.255.255.0

!

interface FastEthernet0/0

ip address 10.40.82.161 255.255.255.252

duplex half

!

interface FastEthernet1/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.40.82.162

 

6 Replies 6

Muhammad Awais Khan
Cisco Employee
Cisco Employee

Hi,

 

You need to do Route leaking at R1 between Global Routing Table and VRF Internet. You can add below config just to make reachability between 1.1.1.1 and R6:

 

At R1: 

ip vrf Internet

rd 65:65
route-target export 65:65
route-target import 65:65

ip route 1.1.1.1 255.255.255.255 FastEthernet1/0.3018
ip route vrf internet 10.40.82.156 255.255.255.252 FastEthernet1/0.3019

 

Please refer to below document for Route leaking between global Routing table and VRF.

 

https://www.cisco.com/c/en/us/support/docs/multiprotocol-label-switching-mpls/multiprotocol-label-switching-vpns-mpls-vpns/47807-routeleaking.html

not working

R6#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Hi,

 

Can you share routing tables of R1 at R6, including routing table of veg Internet 

R6#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.40.82.158 to network 0.0.0.0

172.16.0.0/24 is subnetted, 3 subnets
D EX 172.16.234.0 [170/30720] via 10.40.82.158, 00:02:19, FastEthernet0/0
C 172.16.55.0 is directly connected, FastEthernet1/0
S 172.16.66.0 [1/0] via 172.16.55.254
10.0.0.0/30 is subnetted, 1 subnets
C 10.40.82.156 is directly connected, FastEthernet0/0
D*EX 0.0.0.0/0 [170/30720] via 10.40.82.158, 00:02:19, FastEthernet0/0

==========================


R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.234.254 to network 0.0.0.0

172.16.0.0/24 is subnetted, 3 subnets
C 172.16.234.0 is directly connected, FastEthernet0/0
D EX 172.16.55.0
[170/30720] via 10.40.82.157, 00:02:38, FastEthernet1/0.3019
D EX 172.16.66.0
[170/30720] via 10.40.82.157, 00:02:38, FastEthernet1/0.3019
10.0.0.0/30 is subnetted, 1 subnets
C 10.40.82.156 is directly connected, FastEthernet1/0.3019
S* 0.0.0.0/0 [1/0] via 172.16.234.254
===============================================
Internet#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.40.82.162 to network 0.0.0.0

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback2
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback3
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback4
5.0.0.0/24 is subnetted, 1 subnets
C 5.5.5.0 is directly connected, Loopback5
10.0.0.0/30 is subnetted, 1 subnets
C 10.40.82.160 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 10.40.82.162

Hi,

 

There is no Route entry showing in R1 for 1.1.1.1, i belive we may need to add next hop also in addition to interface for the routes related tovrf interfaces. can you update previously added route to below for 1.1.1.1 :

 

ip route 1.1.1.1 255.255.255.255 FastEthernet1/0.3018 10.40.82.161

 

Also send output for show ip route vrf internet at R1. 

Hello
You need to tell the vrf router about its networks in the vrf  and as such it will then allow communication between global routing table and the vrf

Example to allow internet vrf to reach R6 using your existing static/dynamic routing
Internet rtr-
no ip route 0.0.0.0 0.0.0.0 10.40.82.162
ip route 10.40.82.156 255.255.255.252 10.40.82.162<static route for R6 subnet
ip route 122.116.89.160 255.255.255.224 10.40.82.162<static route for R2 subnet
ip route 172.16.55.0 255.255.255.0 10.40.82.162 <static route for R6 subnet


R6 -
no ip route 172.16.66.0 255.255.255.0 172.16.55.254

router eigrp 100
no auto-summary


R1 - vrf rtr
router eigrp 100
no redistribute connected
no redistribute static
no auto-summary

 

no ip route 0.0.0.0 0.0.0.0 172.16.234.254
no ip route vrf Internet 0.0.0.0 0.0.0.0 10.40.82.161

interface FastEthernet1/0.3019
encapsulation dot1Q 3019
ip summary-address eigrp 100 0.0.0.0 0.0.0.0 1 < default route for r6 via eigrp

ip route 0.0.0.0 0.0.0.0 FastEthernet1/0.3018 10.40.82.161 <default route towards internet rtr for global route table
ip route 10.40.82.160 255.255.255.252 FastEthernet1/0.3018 <static route for global route table to know about its vrf interface
ip route 172.16.151.0 255.255.255.0 172.16.234.254 <static route for global route tablet to know about its vrf interface
ip route vrf Internet 0.0.0.0 0.0.0.0 10.40.82.161 global <default route towards internet rtr for vrf route table
ip route vrf Internet 10.40.82.156 255.255.255.252 10.40.82.157 global<static vrf route for R6 subnet
ip route vrf Internet 172.16.55.0 255.255.255.0 10.40.82.157 global<static vrf route for R6 subnet


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking products for a $25 gift card