cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
730
Views
0
Helpful
1
Replies

vrf to vrf leaking

typeonegative
Level 1
Level 1

Hello,

I have encountered such problem, that everything works, until I do the following:

route-map TEST permit 10

!

ip vrf lt

import ipv4 unicast map TEST

!

After few seconds:

ip vrf lt

no import ipv4 unicast map TEST

After these changes I don't see vrf srv routes in vrf lt, but in vrf srv I see vrf lt's routes.

Any ideas? It works only when I recreate vrf lt or just change RD of vrf lt.

=======================================

Configuration is like this:

ip vrf lt

rd 1:1

route-target export 1:1

route-target import 1:1

route-target import 2:2

!

ip vrf srv

rd 2:2

route-target export 2:2

route-target import 2:2

route-target import 1:1

!

interface Loopback1

ip vrf forwarding lt

ip address 20.0.0.1 255.255.255.0

!

interface FastEthernet0/0

ip vrf forwarding lt

ip address 10.0.0.1 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

ip vrf forwarding srv

ip address 30.0.0.2 255.255.255.252

duplex auto

speed auto

!

router bgp 1

bgp router-id 1.1.1.1

bgp log-neighbor-changes

!

address-family ipv4

no auto-summary

no synchronization

exit-address-family

!

address-family ipv4 vrf srv

redistribute connected

neighbor 30.0.0.1 remote-as 3

neighbor 30.0.0.1 activate

no synchronization

exit-address-family

!

address-family ipv4 vrf lt

redistribute connected

neighbor 10.0.0.2 remote-as 2

neighbor 10.0.0.2 activate

no synchronization

network 20.0.0.0 mask 255.255.255.0

exit-address-family

!

1 Reply 1

typeonegative
Level 1
Level 1

One more output of debug:

R1(config-vrf)#import ipv4 unicast map LT

R1(config-vrf)#

*Mar  1 00:02:28.087: RT(lt): del 30.0.0.0/30 via 0.0.0.0, bgp metric [20/0]

*Mar  1 00:02:28.091: RT(lt): delete subnet route to 30.0.0.0/30

*Mar  1 00:02:28.095: RT(lt): NET-RED 30.0.0.0/30

*Mar  1 00:02:28.095: RT(lt): delete network route to 30.0.0.0

*Mar  1 00:02:28.099: RT(lt): NET-RED 30.0.0.0/8

*Mar  1 00:02:28.103: RT(lt): del 100.0.0.0/24 via 30.0.0.1, bgp metric [20/0]

*Mar  1 00:02:28.103: RT(lt): delete subnet route to 100.0.0.0/24

*Mar  1 00:02:28.107: RT(lt): NET-RED 100.0.0.0/24

*Mar  1 00:02:28.111: RT(lt): delete network route to 100.0.0.0

*Mar  1 00:02:28.111: RT(lt): NET-RED 100.0.0.0/8

R1(config-vrf)#no import ipv4 unicast map LT

Still no output ;-)

Review Cisco Networking for a $25 gift card