cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1215
Views
0
Helpful
28
Replies

WAN Load Balancing

christopher_tan
Level 1
Level 1

Hello all,

I would like to get some solution on below.

1. I have a single router which connect to two different provider internet circuit (circuit A and circuit B)

2. WAN facing running BGP

3. LAN facing running eigrp

4. LAN have two public subnet (100.1.1.0/24 and 200.2.2.0/24)

5. The issue i facing is, all traffics seems to use only one circuit A for incoming/outgoing. Nothing on circuit B

Attach diagram and router configuration.

Please help suggest a way to load balance both circuits for two public subnets.

Thanks.

Regards,

Christopher

28 Replies 28

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

Try the following

!
router bgp 64520
maximum-paths 2
!

Now running 'sh ip route bgp' should show two (equals cost) paths for the prefixes being advertisd by the 9498 AS .

cheers,

Seb.

added "maximum-paths 2", but traffics still on one link.

Hello,

Check the output of show IP BGP "arbitrary route" to make sure you are receiving routes from both ISPs. As an example, show ip bgp 8.8.8.8. If you are receiving route from only one ISP,  contact them to solve the issue.

If you are receiving routes from both ISP, try to follow the comment of Seb.

Masoud

received route from both ISP.

(Circuit A) -- Origin IGP, localpref 100, valid, external

(Circuit B) -- Origin IGP, localpref 100, valid, external, best

Hello

"What source and destination should i use?"

Any scr ip within your site your on to any received bgp ip prefix


"received route from both ISP."

Apply the following
router bgp xx
maximum-paths 2

res
Paul




Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

add "maximum-paths 2" without removing?

no neighbor 10.1.1.2 route-map LAN1 out
no neighbor 20.1.1.2 route-map LAN2 out

Hello,

You do not need to remove any command. Just add maximum-paths 2 under bgp section

Masoud

Hello

You can leave the route-maps in the BGP process, but they are negating each other, So hence why i mentioned removing them.


res

Paul 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello,

Route from Curcuit B has been selected as a best route, so only that route sits inside the routing table.

Please share one  more time the output of

show ip bgp 8.8.8.8

show ip route 8.8.8.8

Do not omit any lines. Repalce with x if you think some parts of output are sensitive.

Hello

Your Prefix-list and RM contradict each other and you are applying local preference to both ebgp peers?

Are you trying to establish load balancing this way?


ip prefix-list LAN1 seq 5 permit 100.1.1.0/24 <------------------------Same as Lan 3
ip prefix-list LAN2 seq 5 permit 200.2.2.0/24 <------------------------Same as Lan 3

ip prefix-list LAN3 seq 5 permit 100.1.1.0/24
ip prefix-list LAN3 seq 10 permit 200.2.2.0/24

route-map PREPEND permit 10                <------------------------Not being used
 set as-path prepend 64520 64520 64520



router bgp xx
maximum-paths 2
no neighbor 10.1.1.2 route-map LAN1 out
no neighbor 20.1.1.2 route-map LAN2 out

Clear ip bgp * soft

sh ip bgp
Sh ip route

Per-destination load sharing  - Default

show ip cef exact-route (scr) (dst)
(scr)  -> (dst) => IP adj out of  GigabitEthernet0/1

show ip cef exact-route (scr) (dst)
(scr)  -> (dst) => IP adj out of  GigabitEthernet0/1

show ip cef exact-route (scr) (dst)
(scr)  -> (dst) => IP adj out of  GigabitEthernet0/1


Per-packet load sharing

interface GigabitEthernet0/1
ip load-sharing per-packet

interface GigabitEthernet0/2
ip load-sharing per-packet

show ip cef exact-route (scr) (dst)
(scr)  -> (dst) => IP adj out of  GigabitEthernet0/1

show ip cef exact-route (scr) (dst)
(scr)  -> (dst) => IP adj out of  GigabitEthernet0/2


show ip cef exact-route (scr) (dst)
(scr)  -> (dst) => IP adj out of  GigabitEthernet0/1


etc..


res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi Paul,

Refer to below:

show ip cef exact-route (scr) (dst)
(scr)  -> (dst) => IP adj out of  GigabitEthernet0/1

show ip cef exact-route (scr) (dst)
(scr)  -> (dst) => IP adj out of  GigabitEthernet0/2

What source and destination should i use?

MANI .P
Level 1
Level 1

Christopher_tan 

   I understand you have two ISP's & you public IP Pool 100.1.1.0/24 , 200.2.2.0/24.

ISP1 : 10.1.1.1 at your end &  10.1.1.2 at ISP end .

ISP2 : 10.1.1.1 at your end &  10.1.1.2 at ISP end .

------------------------------------------------------------------------

Bandwidth load balancing :

Only IP Pool 100.1.1.0 /24 send all the traffic thru ISP1 & when ISP1 link down that traffic will move to ISP2 .

Only IP Pool 200.2.2.0/24  send all the traffic thru ISP2 & when ISP2 link down that traffic will move to ISP1 .

eg : 100.1.1.0/24 -----> ISP1 Primary and ISP2Secondary

        200.2.2.0/24 -----> ISP2 Primary and ISP1 Secondary 

-------------------------------------------------------------------------

step : 1 to create the prefix list  or acl

step:2 to create the route map with weight (two different value  )

step : 3 apply the route map in Bgp ( Inbound )

----------------------------------------

Please let me know any supporting document or any assistance .... 

Hi,

You exactly correct on my requirement.

ISP1 : 10.1.1.1 at your end &  10.1.1.2 at ISP end .

ISP2 : 20.1.1.1 at your end &  20.1.1.2 at ISP end .

will following commands works?

ip prefix-list LAN1 seq 5 permit 100.1.1.0/24
ip prefix-list LAN1 seq 10 permit 200.2.2.0/24

ip prefix-list LAN2 seq 5 permit 200.2.2.0/24
ip prefix-list LAN2 seq 10 permit 100.1.1.0/24

ip prefix-list LAN3 seq 5 permit 100.1.1.0/24
ip prefix-list LAN3 seq 10 permit 200.2.2.0/24

!

router bgp 64520

neighbor 10.1.1.2 route-map LAN1 out

neighbor 20.1.1.2 route-map LAN2 out

route-map PREPEND permit 10
 set as-path prepend 64520 64520 64520
!
route-map LAN2 permit 10
 match ip address prefix-list LAN2
!
route-map LAN2 permit 30
 match ip address prefix-list LAN3
 set local-preference 25
 set as-path prepend 64520 64520 64520
!
route-map LAN1 permit 10
 match ip address prefix-list LAN1
!
route-map LAN1 permit 30
 match ip address prefix-list LAN3
 set local-preference 25
 set as-path prepend 64520 64520 64520

Please advice the correct way if above not correct.

Appreciate your time.

Thanks.

Hello

Just to confirm -

100.1.1.0/24
200.2.2.0/24

Are these your lan subnets or are these ebgp routes advertied to you?

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking products for a $25 gift card