cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
93
Views
0
Helpful
1
Replies
Beginner

Weird configuration with route statements

Hello All,

 

my name is Kyle and I have secured a new job and am starting to manage my new network. 

I am a bit confused as to how my routing statements should be setup on my switches.

I have tried to loosely setup our network in packet tracer to see where I am messing up my route statements at. 

I have uploaded a loose copy of our network diagram  here : 

https://imgur.com/0InhBhy 

 

 

I have applied the ip addresses listed above each device to VLAN 1 on all the 3560's.

 

I have entered route statements on each 3560 pointing to the ip address on the vlan of the switch i want the traffic to go to.

 

so as an example on Switch 1 I entered 10.10.158.0 255.255.255.0 10.10.157.251

 

then on switch 2 I entered 10.10.158.0 255.255.255.0 10.10.158.248

 

all ports are in the default VLAN of VLAN 1. The links in between are trunk links.

 

Is this not correct? I am not able to get connectivity between my two PC's in my packet tracer example

 

 

 

Everyone's tags (1)
1 REPLY 1
Highlighted
VIP Advisor

Re: Weird configuration with route statements

Hi there,
There is something not right with your configuration.
You only mention VLAN1 in your topology, yet your static route statements show the subnet 10.10.158.0/24 which implies that you must also have 10.10.157.0/24 which will need to be in a VLAN of its own.

It is hard to determine from your diagram, but either switch2 or switch3 must have a Layer3 interface in both VLANs. It is this switch which you should configure as the VLAN/ subnet gateway.

 

For example, say it is switch2. The config should look like:

!
vlan1,2
!
int vlan 1 
ip address 10.10.157.251 255.255.255.0
!
int vlan 2
ip address 10.10.158.251 255.255.255.0
!
int fa0/1
switchport mode trunk
switchport trunk allowed vlan 1
no shut
!
int fa0/24
switchport mode trunk 
switchport trunk allowed vlan 2
no shut
!
ip routing
!


Now on switch 1:

!
int fa0/1
switchport mode trunk
switchport trunk allowed vlan 1
no shut
!
int fa0/24
switchport mode access
switchport access vlan 1
not shut
!
ip route 10.10.158.251 255.255.255.0 10.10.157.251
!

Switch3:

!
vlan 2
!
int range fa0/1, fa0/24
switchport mode trunk
switchport trunk allowed vlan 2
no shut
!
ip route 10.10.157.251 255.255.255.0 10.10.158.251
!

Switch4:

!
int fa0/1
switchport mode trunk
switchport trunk allowed vlan 2
no shut
!
int fa0/24
switchport mode access
switchport access vlan 2
not shut
!
ip route 10.10.157.251 255.255.255.0 10.10.158.251
!

Now for the PCs, they need the following gateways configured:

PC0 : 10.10.157.251
PC1 : 10.10.158.251

What we have achieved is a Layer2 network (VLAN1) from Switch2 towards PC0 and also extended the Layer2 network (VLAN2) from switch2 to PC1 via switches 3 and 4. Switch2 acts as the Layer3 gateway for both subnets and it is there that we do the inter-VLAN routing.

 

cheers,

Seb.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards