cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
175
Views
0
Helpful
1
Replies

Weird issue on route-map

cinmar1957
Level 1
Level 1

Hi All,

(2) Lease Line (1MB & 4MB via BGP)

(1) ADSL 40MB Speed.

I am trying to send all HTTP Traffic to ADSL(40MB) using route-map. And all SMTP to BGP(4MB).

I have running configuration below, but its weird since, when browsing/HTTP request, users using mobile phones they get the speed ADSL 40MB but when local users connected to laptops/desktop (both wireless/cable) they get BGP speed 4MB.

note: mobile and laptop connect to the same wireless ap.

Any ideas what could be the problem.

!
interface GigabitEthernet0/0
description ROUTERONASTICK
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.5
description SERVERSNETWORK
encapsulation dot1Q 5
ip address 192.168.5.1 255.255.255.0
ip helper-address 192.168.5.11
ip nbar protocol-discovery
ip flow ingress
ip nat inside
ip virtual-reassembly in

ip policy route-map REROUTE-HTTP
!
interface GigabitEthernet0/0.10
description PRIVATE
encapsulation dot1Q 10 NATIVE
ip address 192.168.10.1 255.255.255.0
ip helper-address 192.168.5.11
ip nbar protocol-discovery
ip flow ingress
ip nat inside
ip virtual-reassembly in

 ip policy route-map REROUTE-HTTP

!
interface GigabitEthernet0/1
description MAIN_LEASELINE
ip address 111.11.11.11 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1/0
description ADSL
no ip address
ip flow egress
ip virtual-reassembly in
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 10
no cdp enable
!
interface FastEthernet0/1/1
description BACKUP_LEASELINE
ip address 222.22.22.22 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0/0
no ip address
!
interface GigabitEthernet0/0/1
no ip address
!
interface GigabitEthernet0/0/2
description BACKUP
switchport access vlan 40
no ip address
!
interface GigabitEthernet0/0/3
description MAIN
switchport access vlan 50
no ip address
!
interface Vlan1
no ip address
!
interface Vlan40
ip address 33.33.33.33 255.255.255.248
ip flow ingress
!
interface Vlan50
ip address 44.44.44.44 255.255.255.248
ip flow ingress
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in max-fragments 64 max-reassemblies 512
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 10
ppp authentication pap callin
ppp pap sent-username myuser mypass
ppp ipcp dns request accept
ppp ipcp address accept
no cdp enable
!
!
router bgp 65XXX
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.248
network 44.44.44.44 mask 255.255.255.248
neighbor 11.11.11.11 remote-as 53XX
neighbor 11.11.11.11 update-source GigabitEthernet0/1
neighbor 11.11.11.11 route-map MAINLL in
neighbor 22.22.22.22 remote-as 53XX
neighbor 22.22.22.22 update-source FastEthernet0/1/1
neighbor 22.22.22.22 route-map BACKUPLL in
maximum-paths 2
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip dns server
ip nat inside source route-map ADSL interface Dialer1 overload
ip nat inside source route-map BACKUP interface FastEthernet0/1/1 overload
ip nat inside source route-map MAIN interface GigabitEthernet0/1 overload
!
ip access-list extended ADSL-TRAFFIC
permit tcp 192.168.5.0 0.0.0.255 eq www any
permit tcp 192.168.5.0 0.0.0.255 any eq www
permit tcp 192.168.10.0 0.0.0.255 eq www any
permit tcp 192.168.10.0 0.0.0.255 any eq www
deny ip any any
ip access-list extended LL-TRAFFIC
deny tcp 33.33.33.33 0.0.0.7 eq www any
deny tcp 33.33.33.33 0.0.0.7 any eq www
deny tcp 44.44.44.44 0.0.0.7 eq www any
deny tcp 44.44.44.44 0.0.0.7 any eq www
permit ip any any
ip access-list extended SMTP-TRAFFIC
permit tcp 192.168.5.0 0.0.0.255 any eq smtp
permit tcp 192.168.10.0 0.0.0.255 any eq smtp
deny ip any any
!
access-list 1 permit any
!
route-map MAIN permit 10
match ip address LL-TRAFFIC
match interface GigabitEthernet0/1
!
route-map MAINLL permit 10
set local-preference 110
!
route-map BACKUP permit 10
match ip address LL-TRAFFIC
match interface FastEthernet0/1/1
!
route-map BACKUPLL permit 10
set local-preference 90
!
route-map ADSL permit 10
match ip address ADSL-TRAFFIC
match interface Dialer1
!
route-map REROUTE-HTTP permit 10
match ip address ADSL-TRAFFIC
set interface Dialer1
!
route-map REROUTE-HTTP permit 20
!

1 Reply 1

Jon Marshall
Hall of Fame
Hall of Fame

Assuming all clients are either 192.168.5.x or 192.168.10.x traffic should be sent via your ADSL link according to your configuration.

You may need to use "debug ip policy" to see what your PBR is doing.

Obviously as with any debug command you need to be careful.

Jon

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card