cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
305
Views
0
Helpful
2
Replies

Why are these routes belong to the VPNV4 address-family?

rookie R
Level 1
Level 1

Hi all!

rookieR_0-1705812580656.png

My configuration:

 

R6

!
vrf definition VRF1
rd 10006:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
vrf definition VRF2
rd 10006:2
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!

interface Loopback100
vrf forwarding VRF1
ip address 192.168.106.6 255.255.255.255
!
interface Loopback200
vrf forwarding VRF2
ip address 192.168.206.6 255.255.255.255
!

interface Ethernet0/1.100
encapsulation dot1Q 100
vrf forwarding VRF1
ip address 192.168.100.6 255.255.255.0
!
interface Ethernet0/1.200
encapsulation dot1Q 200
vrf forwarding VRF2
ip address 192.168.200.6 255.255.255.0
!

router bgp 10006
bgp router-id 192.168.67.6
bgp log-neighbor-changes
!
address-family ipv4 vrf VRF1
network 192.168.106.6 mask 255.255.255.255
neighbor 192.168.100.7 remote-as 10007
neighbor 192.168.100.7 activate
exit-address-family
!
address-family ipv4 vrf VRF2
network 192.168.206.6 mask 255.255.255.255
neighbor 192.168.200.7 remote-as 10007
neighbor 192.168.200.7 activate
exit-address-family
!

 

 

 

R7

!
vrf definition VRF1
rd 10007:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
vrf definition VRF2
rd 10007:2
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!

interface Loopback100
vrf forwarding VRF1
ip address 192.168.107.7 255.255.255.255
!
interface Loopback200
vrf forwarding VRF2
ip address 192.168.207.7 255.255.255.255
!

interface Ethernet0/1.100
encapsulation dot1Q 100
vrf forwarding VRF1
ip address 192.168.100.7 255.255.255.0
!
interface Ethernet0/1.200
encapsulation dot1Q 200
vrf forwarding VRF2
ip address 192.168.200.7 255.255.255.0
!

router bgp 10007
bgp router-id 192.168.67.7
bgp log-neighbor-changes
!
address-family ipv4 vrf VRF1
network 192.168.107.7 mask 255.255.255.255
neighbor 192.168.100.6 remote-as 10006
neighbor 192.168.100.6 activate
exit-address-family
!
address-family ipv4 vrf VRF2
network 192.168.207.7 mask 255.255.255.255
neighbor 192.168.200.6 remote-as 10006
neighbor 192.168.200.6 activate
exit-address-family
!

 

My question is: Why did R6 and R7 form BGP neighbors in the vpnv4 address-family? And why do all the routes belong to vpnv4 address-family

From what I know, the output below means that these two routers formed BGP neighbors in the vpnv4 address-family, I saw a post that said, 'The "VPNv4 address family" is used in MPLS Layer3 VPN deployments. ' .  However, none of my routers are in the MPLS Layer 3 VPN environment. Why did these two form neighbors in the vpnv4 address-family? Plus, all the routes are in the vpnv4 address-family routing table, I thought the vpnv4 routing table is only used in conjunction with the RT to transfer the ipv4 routes in the vrf in each PE between PEs.

rookieR_0-1705814497037.png

rookieR_1-1705815720049.png

 

Thanks so much!

 

 

 

 

2 Replies 2

balaji.bandi
Hall of Fame
Hall of Fame

The Post you referred more elaborated explanation why VPNv4 use case.

If you do not want to VPNv4  or MPLS VPN - then you should use normal BGP to for peering

My question is: Why did R6 and R7 form BGP neighbors in the vpnv4 address-family? And why do all the routes belong to vpnv4 address-family

 Since you have configured in that way with VRF.

below post explain you IPV4 vs VPNV4 -

https://community.cisco.com/t5/switching/i-am-not-clear-on-the-difference-between-ipv4-and-vpnv4-address/td-p/2463679

If you like to have normal BGP configuration you can use below example  - iBGP / They are different AS then use EBGP with different AS number

R1
router bgp 65100
neighbor 10.1.12.2 remote-as 65100

R2
router bgp 65100
neighbor 10.1.12.1 remote-as 65100

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

M02@rt37
VIP
VIP

Hello @rookie R 

In your BGP configuration, you have specified the address-family ipv4 vrf under the BGP configuration for each VRF. This configuration enables BGP to exchange VPNv4 routes for the specific VRF. VPNv4 routes carry both the IPv4 prefixes and the VPNv4 attributes, such as Route Distinguisher (RD) and Route Target (RT), necessary for MPLS Layer 3 VPN deployments.

Because you not mentioned MPLS configuration, I think you just want BGP peering per vrf without L3VPN. So modify configuration, as example :

router bgp 10006
bgp router-id 192.168.67.6
bgp log-neighbor-changes

vrf VRF1
rd 10006:1
address-family ipv4
network 192.168.106.6 mask 255.255.255.255
neighbor 192.168.100.7 remote-as 10007
neighbor 192.168.100.7 activate
exit-address-family
!
vrf VRF2
rd 10006:2
address-family ipv4
network 192.168.206.6 mask 255.255.255.255
neighbor 192.168.200.7 remote-as 10007
neighbor 192.168.200.7 activate
exit-address-family
!

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.
Review Cisco Networking for a $25 gift card