05-30-2022 09:45 AM
trying to glbp balance pings between 2 switches weighting set to 50 each switch
source pings from A1 not balancing
Siwitch D1 (left side) receiving all the pings
ICMP ping seems to be part of VLAN 99
any suggestions?
Switch D1 RUN
!
!
!
no ip domain-lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
track 1 interface Loopback0 line-protocol
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
shutdown
ipv6 address FE80::D1:2 link-local
ipv6 address 2001:DB8:172::1/64
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
duplex half
no negotiation auto
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface GigabitEthernet1/0
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface Vlan99
ip address 192.168.99.1 255.255.255.0
ipv6 address FE80::D1:1 link-local
ipv6 address 2001:DB8:99::1/64
glbp 1 ip 192.168.99.254
glbp 1 priority 120
glbp 1 preempt
glbp 1 weighting 50
glbp 1 weighting track 1 decrement 90
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, d
Switch D2 RUN
ch>
Switch>\
% Unknown command or computer name, or unable to find computer address
Switch>
Switch>enable
Switch#sh run
Building configuration...
Current configuration : 3316 bytes
!
! Last configuration change at 16:38:35 UTC Mon May 30 2022
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
duplex half
no negotiation auto
!
interface GigabitEthernet0/2
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface GigabitEthernet1/0
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface Vlan99
ip address 192.168.99.2 255.255.255.0
ipv6 address FE80::D2:1 link-local
ipv6 address 2001:DB8:99::2/64
glbp 1 ip 192.168.99.254
glbp 1 priority 50
glbp 1 preempt
glbp 1 weighting 50
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
banner exec ^C
05-30-2022 10:06 AM
Are you pinging from the same source IP all the time ?
If so then it will only use one of the routers because GLBP load balances per host, it does not load balance the packets from the same host.
Jon
05-30-2022 10:51 PM
John I AM pinging from the same source all the time I did not think of this
05-30-2022 10:31 AM
please do tracreroute not ping to find that router will shift form trace route to other.
05-30-2022 11:10 AM
Hi
Try to take preempt off.
05-30-2022 02:36 PM
Hello
@Flavio Miranda wrote:
Try to take preempt off.
Would not suggest to remove preemption, it is indeed disabled by default but without it you have no resiliency, which negates the point of an FHRP like glbp
05-30-2022 02:40 PM - edited 05-30-2022 02:41 PM
Hello
You can see the AVG is D1 switch however both forwarders (D1 & D2) are showing a "listen " state which is not correct.
The reason is probably down to both switches set with the same weight value and tracking on a Loopback that which will always be active!
Change the weighting so D1 is preferred as not only AVG but also the AVF and also track an physical interface preferably one that is upstream and not logical.
Example:
D1
glbp 1 weighting 110 lower 96 upper 105
glbp 1 weighting track 1
D2
no weight 50 (default will than be 100)
05-30-2022 10:45 PM - edited 05-30-2022 10:49 PM
I changed the wighting evenly and priority evenly
Switch D1
Switch D2
and traffic is not load sharing
Shutting down Loopback 0 manually has made both forwarders active for D2, whereas AVG remains active for D1
I ping the virtual gateway 192.168.99.254 500X and it is still pinging through the D1 gateway, which is the ACTIVE AVG and is inactive for both Forwarders
On D1 no show GLBP BRIEF it says unknown for active router
For D2 it says local router
I ping 500X to 192.168.99.254 and all traffic still going through .254 virtual gateway D1 which is tied to int VLAN 99, which is shutdown
I change priority on switch D2 to highest priority and no shut int VLAN 99 on switch D1
interface Vlan99
ip address 192.168.99.2 255.255.255.0
ipv6 address FE80::D2:1 link-local
ipv6 address 2001:DB8:99::2/64
glbp 1 ip 192.168.99.254
glbp 1 priority 255
glbp 1 preempt
and now I check glbp brief on D2
and according to output D2 is active AVG and active AVF
I ping repeat 500x to 192.168.99.254 the virtual gateway tied to glbp 1 to each int vlan 99
all pings still going through D1
I will post A1 run next, there is no default routes
I do remove the link completely betweek D1 and A1
and traffic is forwarded through D2 switch finally
Here is show run for A1
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
duplex half
no negotiation auto
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
duplex half
no negotiation auto
!
interface GigabitEthernet0/2
media-type rj45
duplex half
no negotiation auto
!
interface GigabitEthernet0/3
media-type rj45
duplex half
no negotiation auto
!
interface GigabitEthernet1/0
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
media-type rj45
negotiation auto
!
interface Vlan1
no ip address
!
interface Vlan99
ip address 192.168.99.3 255.255.255.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
I check show run for D1 one last time and nothing seems out of place.
At this point I am going to move along in my reading studies and try another cisco GLBP lab at the end of the next chapter
!
05-31-2022 01:00 AM - edited 05-31-2022 01:02 AM
Hello
You have the same group priority which isn't correct.
Now im not so sure what you are expecting to see upon failover, when the AVG fails the same vmac address that was given out by the primary AF will then be serviced by the secondary VF.until the redirect interval has timed out, so you will see the same arp for a period after failover,
sh glbp detail | in In Redirect
05-31-2022 01:18 AM
Is this now about how to failover rather than load balancing because the original question was about load balancing and as far as I know from the same source IP it won't load balance, to test that you would need multiple clients.
Jon
05-31-2022 01:22 AM
So in my situation I wanted to get better understanding, and keeping in mind what Paul said above about ARP timeouts, I figured I was still doing something wrong
GLBP seems to be giving me headache
I recognized something though that I forgot. STP is running on these trunk links. So When I shut down int vlan 99 as before I was monitoring trunk links from AS 1 to DS1 and DS 2 but not DS2 to DS3 trunk no monitoring
so on DS1 I yet again shut down Interface Vlan 99 to see where traffic would go
Then I ping from all hosts and check the trunk link between D1 and D2 and traffic is flowing across D1 to D2 trunk link
And now I turn on int VLAN 99
do pings again
No traffic from D1 to D2 trunk link
I check interace vlan 99 counters after pinging from 4 PCS to 192.168.99.254 virtual address. The counters for D1 go up 2-300 every minute or 2 while the packet counters for Int Vlan 99 on D2 go up about 20-50 every 1-2 minutes during this ping cycle
It seems to be GLBP is working
Now I want to test weights
and make weight 25 on D1 and weight 240 on D2
The 'priority' of 255 and 120 should not matter as this is the priority set for the AVG which controls the AVF which control/balance traffic, in this case the weight should matter
I turn off Loopback 0 for D1 to decrement weight value
I ping from 4x VPCS and traffic flowing across trunk link to D2
the packets are in fact going up for D2 Int VLAN 99 counter by hundreds and by 1x digits for D1 int VLAN 99
D1 int vlan 99packets
Trial 1
65944
65985
65993
Trial 2
66035 -- start pings from 4 VPCS
66075
66102
66120
D2 interface 99 packets
Trial 1
83367
83502
84xx
Trial 2
84116 -- start pings from 4 VPCS
84300
84581
84948
This leads me to believe weights are working as intended
I
05-31-2022 01:25 AM - edited 05-31-2022 01:26 AM
I also have question of GLBP use case in real world. Given the virtual mac addresses are handed out based on either round-robin, weighted or host-dependent
I am wondering is GLBP mostly used for edge where hosts disconnect and connect often? Is it also usable in areas where maybe many ARP requests?
05-31-2022 01:28 AM
It is used primarily where you would use HSRP ie. for end devices so yes pretty much what you say.
Jon
05-31-2022 01:52 AM - edited 05-31-2022 01:53 AM
Hello
So resilience and LB are different thing, GLBP has 3 LB settings ( Round Robin – default /Hosted and Weighted)
The latter is used for links that have differing BW as such you can weight the traffic according to the BW off those links, so if one link has twice the amount of BW throughput you would weight that interface with double the amount of its counterpart that has twice less
For this to work you would need to set LB to be weighted.
glbp x load-balancing weighted
05-31-2022 01:56 AM
Hi Paul
I know they are different things it's just that the original post asked about load balancing and from the same source IP it won't do that.
Jon
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide