cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Choose one of the topics below for SD-WAN Resources to help you on your journey with SD-WAN

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC!
We will not comment or assist with your TAC case in these forums.

552
Views
5
Helpful
3
Replies
Highlighted
Beginner

Does autonegotiate setting actually work on vEdge? vshell / ethtool says no.

All:

 

 Does the autonegotiate setting on an interface actually work on vEdge (16.x or 17.x?)   

 

I'm working with a large US national carrier on a Layer2 issue with their DWDM Transponder/Muxsponder shelf client cards and noticed it actually has no impact when you examine interface in vShell with ethtool(8):

 

VEDGE_AutoNeg_TShoot_Error.png

vedge#
vedge#
vedge# conf t
Entering configuration mode terminal
vedge(config)# no vpn 0 interface ge0/0 autonegotiate
vedge(config)# commit no-confirm
Commit complete.
vedge(config)#
vedge#
vedge# vshell
vedge:~$ ethtool ge0_0 | grep -i auto
Cannot get wake-on-lan settings: Operation not permitted
Supports auto-negotiation: No
Advertised auto-negotiation: No
Auto-negotiation: on

vedge:~$ exit
exit
vedge# conf t
Entering configuration mode terminal
vedge(config)# vpn 0 interface ge0/0 autonegotiate
vedge(config-interface-ge0/0)# commit no-confirm
Commit complete.
vedge(config-interface-ge0/0)# do vshell
vedge:~$ ethtool ge0_0 | grep -i auto
Cannot get wake-on-lan settings: Operation not permitted
Supports auto-negotiation: No
Advertised auto-negotiation: No
Auto-negotiation: on
vedge:~$

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

When you are using a fiber SFP, you are able to to configure "no autonegotiate" on the interface even though autonegotiation for 1000BaseT fiber is always enforced at the register level. According to the IEEE 802.3 standard for 1000BASE fiber, autonegotiation is a requirement.

View solution in original post

3 REPLIES 3
Highlighted
Cisco Employee

When you are using a fiber SFP, you are able to to configure "no autonegotiate" on the interface even though autonegotiation for 1000BaseT fiber is always enforced at the register level. According to the IEEE 802.3 standard for 1000BASE fiber, autonegotiation is a requirement.

View solution in original post

Highlighted

Thank you for providing a definitive response.

 

It is good to have a place to point for gospel that references RFC /  IEEE documents.

 

Please connect up with engineering / TAC teams on case 687564198.

Highlighted

Quick follow-up, does the IEEE / 802.x standard for 10GB-LR and 10GB-SR (802.3ae 2002-06 10 Gigabit Ethernet over fiber; 10GBASE-SR, 10GBASE-LR, 10GBASE-ER, 10GBASE-SW, 10GBASE-LW, 10GBASE-EW) also enforce that auto-negotiation must been enabled?

 

I noticed that on Viptela 17.x, the autonegotation config stanza is not valid on 10gb interfaces:

 

vedge200# conf t
Entering configuration mode terminal
vedge200(config)# no vpn 0 interface ge2/0 autonegotiate
vedge200(config)# no vpn 0 interface 10ge0/0 autonegotiate
-----------------------------------------------^
syntax error: expecting
b-yb17-a02:~$ ethtool xge0_0 |grep -i neg
Supports auto-negotiation: No  <---------------------------- !!!!!!!!!!!????
Advertised auto-negotiation: No  <---------------------------- !!!!!!!!!!!????
Auto-negotiation: on   <------------------------------------- !!!!!!!!!!!????

 

Content for Community-Ad