04-08-2011 02:15 AM
Hi everyone.
I've set up a new Data Center for a customer with the classical Nexus infrastructure as shown in the picture.
N7k-01 and N7k-02 are sharing HSRP on vlan xxx. Also N5k01 and N5k02 have an address on the same xxx vlan for management purpose.
Everything seems to work properly except when I try to ping N5k02 from N7k01 (and vice versa).
The ping result is this:
N7K-1# ping 172.x.y.5
PING 172.x.y.5 (172.x.y.5): 56 data bytes
64 bytes from 172.x.y.5: icmp_seq=0 ttl=254 time=1.116 ms
64 bytes from 172.x.y.5: icmp_seq=0 ttl=253 time=1.803 ms (DUP!)
64 bytes from 172.x.y.5: icmp_seq=1 ttl=254 time=0.711 ms
64 bytes from 172.x.y.5: icmp_seq=1 ttl=253 time=1.176 ms (DUP!)
64 bytes from 172.x.y.5: icmp_seq=2 ttl=254 time=0.748 ms
64 bytes from 172.x.y.5: icmp_seq=2 ttl=253 time=1.227 ms (DUP!)
64 bytes from 172.x.y.5: icmp_seq=3 ttl=254 time=0.646 ms
64 bytes from 172.x.y.5: icmp_seq=3 ttl=253 time=1.182 ms (DUP!)
64 bytes from 172.x.y.5: icmp_seq=4 ttl=254 time=0.631 ms
The issue stops when interface vlan 301 on N7k-2 is shutted down or when interface 1/10 on Nk5-2 is shutted down.
If interface 1/9 on N5k-2 is DOWN and interface 1/10 is UP I still have duplicate response to ping.
I'm going mad with this!!!
Here's the configuration of VPC and interfaces:
N7k1#
feature vpc
vpc domain 1
role priority 100
peer-keepalive destination 172.a.b.34 source 172.a.b.33
interface Vlan301
no shutdown
description *** VLAN MANAGMENT IN-BAND ***
ip address 172.x.y.2/26
ip router ospf 2 area 0.0.0.0
hsrp version 2
hsrp 301
authentication text vlan301
preempt
priority 200
ip 172.x.y.1
interface port-channel1
description *** Link to N7k-02 ***
switchport
switchport mode trunk
vpc peer-link
spanning-tree port type network
interface port-channel5
description Link to N5K
switchport
switchport mode trunk
vpc 5
spanning-tree port type normal
interface Ethernet10/1
description Link to N5K-1 e1/9
switchport
switchport mode trunk
udld enable
channel-group 5 mode active
no shutdown
interface Ethernet10/2
description Link to N5K-2 e1/10
switchport
switchport mode trunk
udld enable
channel-group 5 mode active
no shutdown
------------------------------------- VPC PEER LINK -------------------------------------
interface Ethernet10/9
description *** Link to N7K-02 e10/9 ***
switchport
switchport mode trunk
channel-group 1 mode active
no shutdown
interface Ethernet10/10
description *** Link to N7K-02 e10/10 ***
switchport
switchport mode trunk
channel-group 1 mode active
no shutdown
------------------------------------------------------------------------------------------------------
N7k-2#
feature vpc
vpc domain 1
role priority 200
peer-keepalive destination 172.a.b.33 source 172.a.b.34
interface Vlan301
no shutdown
description *** VLAN MANAGMENT IN-BAND ***
ip address 172.x.y.3/26
ip router ospf 2 area 0.0.0.0
hsrp version 2
hsrp 301
authentication text vlan301
preempt
priority 150
ip 172.x.y.1
interface port-channel1
description *** Link to N7k-01 ***
switchport
switchport mode trunk
vpc peer-link
spanning-tree port type network
interface port-channel5
description Link to N5K
switchport
switchport mode trunk
vpc 5
spanning-tree port type normal
interface Ethernet10/2
description Link to N5K-2 e1/9
switchport
switchport mode trunk
udld enable
channel-group 5 mode active
no shutdown
interface Ethernet10/1
description Link to N5K-1 e1/10
switchport
switchport mode trunk
udld enable
channel-group 5 mode active
no shutdown
------------------------------------- VPC PEER LINK -------------------------------------
interface Ethernet10/9
description *** Link to N7K-01 e10/9 ***
switchport
switchport mode trunk
channel-group 1 mode active
no shutdown
interface Ethernet10/10
description *** Link to N7K-01 e10/10 ***
switchport
switchport mode trunk
channel-group 1 mode active
no shutdown
------------------------------------------------------------------------------------------------------
N5k-1
feature vpc
vpc domain 10
role priority 100
peer-keepalive destination 172.a.b.36 source 172.a.b.35
interface Vlan301
no shutdown
description *** VLAN MANAGEMENT IN BAND ***
ip address 172.x.y.4/26
interface port-channel1
description *** Link to N5K-02 Rack-4C ***
switchport mode trunk
vpc peer-link
interface port-channel5
description *** Link to N7K ***
switchport mode trunk
vpc 5
spanning-tree port type normal
interface Ethernet1/9
description *** Link to N7K-01 e10/1 Rack-3C ***
switchport mode trunk
udld enable
channel-group 5 mode passive
interface Ethernet1/10
description *** Link to N7K-02 e10/1 Rack-4C ***
switchport mode trunk
udld enable
channel-group 5 mode passive
------------------------------------- VPC PEER LINK -------------------------------------
interface Ethernet1/19
description *** Link to N5K-02 e1/19 Rack-4C ***
switchport mode trunk
udld enable
channel-group 1 mode active
interface Ethernet1/20
description *** Link to N5K-02 e1/20 Rack-4C ***
switchport mode trunk
udld enable
channel-group 1 mode active
------------------------------------------------------------------------------------------------------
N5k-2
feature vpc
vpc domain 10
role priority 200
peer-keepalive destination 172.a.b.35 source 172.a.b.36
interface Vlan301
no shutdown
description *** VLAN MANAGEMENT IN BAND ***
ip address 172.x.y.5/26
interface port-channel1
description *** Link to N5K-01 Rack-3C ***
switchport mode trunk
vpc peer-link
interface port-channel5
description *** Link to N7K ***
switchport mode trunk
vpc 5
spanning-tree port type normal
interface Ethernet1/9
description *** Link to N7K-02 e10/2 Rack-4C ***
switchport mode trunk
udld enable
channel-group 5 mode passive
interface Ethernet1/10
description *** Link to N7K-01 e10/2 Rack-3C ***
switchport mode trunk
udld enable
channel-group 5 mode passive
------------------------------------- VPC PEER LINK -------------------------------------
interface Ethernet1/19
description *** Link to N5K-01 e1/19 Rack-4C ***
switchport mode trunk
udld enable
channel-group 1 mode active
interface Ethernet1/20
description *** Link to N5K-01 e1/20 Rack-3C ***
switchport mode trunk
udld enable
channel-group 1 mode active
------------------------------------------------------------------------------------------------------
Solved! Go to Solution.
04-08-2011 02:45 AM
Try to add the peer-gateway command on the NX7K vpc domain
let us know the result
Bye
04-08-2011 02:45 AM
Try to add the peer-gateway command on the NX7K vpc domain
let us know the result
Bye
04-08-2011 03:01 AM
IT WORKS PROPERLY FINALLY!!!!
THANKS A LOT!!
I'll keep monitoring and testing the switches just in case
THANKS AGAIN!!!!
12-18-2011 04:37 PM
Domenico, so what did actually fix your issue? the peer-gateway command?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide