cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
720
Views
15
Helpful
5
Replies

UCS C220 M3 iSCSI Boot mit Broadcom Netextreme 5709 4-Port

Hi

I seem to be in big trouble with my UCS C220 M3. After initiating an update of vCenter/VMware 5.1 (only patches and updates, no upgrade to 5.5) my UCS got stuck after the first reboot not being able to find the iSCSI boot LUN on my NetApp Filer. I have a second UCS that does not have any issues that lets me test that the NetApp itself is reachable.

The error message I get on CIMC KVM is "Logging in the 1st iSCSI Target ... Failed (Establish TCP Connection with target failed)

When I started the whole action my CIMC and Firmware Level was 1.4.7b, the Broadcom Adapter was (and still is) on v7.4.2.

I decided to upgrade CIMC to 2.0.8 after consulting the UCS interop matrix, the problems remained. I have checked the iSCSI Boot configuration ten times. IP addresses, initiator names, targets etc. seem to be ok.

I took a Wireshark trace in front of the UCS. What I found was that the Broadcom adapter sends out ARPs, I see the replies but then nothing else happens. After a while the ARP request are repeated and the story goes on and on. I expect that a TCP session would be opened to the iSCSI target but this does not happen.

Is there any possibility to test the Broadcom card as long as the system is not really running? Does somebody have a similar installation running and can me tell what firmware levels seem to work better for my environment.

Any ideas would be greatly appreciated.

Thanks

Mat

5 Replies 5

Walter Dey
VIP Alumni
VIP Alumni

Hi Matthias

I don't believe that this has to do with CIMC !

Check the interop tool at http://www.cisco.com/web/techdoc/ucs/interoperability/matrix/matrix.html

It will show the following for ESXi V5.1

Manufacturer     = Broadcom

Adapter Driver   = 2.2.3e.v50.1/2.74.07.v50.1
Adapter Firmware = 7.4.0
Boot Code / BIOS = 7.4.12

Note 23: saying that iSCSI boot is carried out with inbox drivers and the async needs to be installed from the OS

The C220-M3(SFF/LFF) server requires release 1.4.7a [use HUU 1.4.7a.1].

Kirk J
Cisco Employee
Cisco Employee

Greetings.

I don't remember what the Broadcom optionrom utility looks like, but I am wondering if it has jumbo frames enabled.  I've had a few cases where jumbo frame issues would allow the initial ESXi install, but could not boot up after the 1st restart.  It seems the ESXi installer (at least through 5.5) always uses 1500 MTU.  On 1st real boot up, a potential MTU issue may keep iSCSI from initiating.

If you boot up to your esxi install ISO does it still see the boot lun?

Thanks,

Kirk..

Hi Walter (good to see you again), hi Kirk

thanks for your input, I finally managed (with more than a little help from a friend) to get the UCS up again. However the circumstances remain unclear. The configuration I had before was a PortChannel for iSCSI (and NFS). In the past I was able to boot over this configuration, now it does not work anymore unless I take one interface in the PortChannel down.

I did the same tests for my other UCS with Firmware Level 1.4.7a. Before it was able to boot over the PortChannel, now this does not work anymore. So in either way, it was no the upgrade that broke my system, it must be something else, perhaps on the switch side.

I completely see that the setup cannot work this way, but as I don't have the full documentation of the initial setup I can't reproduce the reasons why and how this was built (apart from having a resilient solution always looks better, even if you can't boot anymore ;-). I will only use one adapter in the future so there will be no issues anymore.

One question to Walter: am I right that the 2.0.8 release is OK if I want to go to VMware 5.1 U3. 1.4.7 is the minimum release for 5.1 as I understand it. Or do I have to change my firmware again to be in a stable situation?

I wish you both a happy new year and thanks again for the replies

Matthias

Hoi Matthias

am I right that the 2.0.8 release is OK if I want to go to VMware 5.1 U3 ?

Yes !

Manufacturer     = Broadcom

Adapter Driver   = 2.2.5f.v50.9(NIC), 2.711.10.v50.2(iSCSI)
Adapter Firmware = 7.4.0
Boot Code / BIOS = v7.4.1(PXE)/v7.4.2(iSCSI)

Note 4: Boot from SAN or Boot from iSCSI or Boot from LSI RAID requires Cisco Customized ISO image available for download at www.vmware.com.

Wuensche Dir alles Gute fuer 2016 !

Tschuess Walter.

Hallo Walter

Dir ebenfalls ein glückliches und erfolgreiches 2016 ! Vielen Dank für den geistigen Beistand, zuweilen ist eine Zweitmeinung in der Interpretation von Tools sehr hilfreich.

Gruss

Matthias