cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
888
Views
0
Helpful
7
Replies
Highlighted
Beginner

Unable to get aToken from Cisco Support API

Hello,

 

I'm tryining to use Cisco Support API for PSS.

 

After reading :

Devnet getting started : https://developer.cisco.com/docs/support-apis/#!getting-started-with-cisco-support-apis-for-pss

API Console User guide : https://apiconsole.cisco.com/files/APIx_Platform_User_Guide.pdf

API Token Access : https://apiconsole.cisco.com/files/Token_Access.pdf

 

I am able to see my application under https://apiconsole.cisco.com/apps/myapps with a client ID and client secret.

 

I'm triying to get a token using postman with :

Authorization Type : OAuth2.0

Grant type : Client Credential

Access token URL : https://cloudsso.cisco.com/as/authorization.oauth2

and give client ID and secret as my request parameters.

 

With postman I can't receive a token.

 

According to the Token Access documentation, I tried with a web browser using this URL :

https://cloudsso.cisco.com/as/authorization.oauth2?response_type=code&client_id=[my app client_id]

 

I've got : 

Error

Oops

Looks like something is not right. Please contact your administrator.


404 - Not Found

 

Does someone know how to deal with that ?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

It should be: 

https://cloudsso2.cisco.com/as/token.oauth2

cheers,

Seb.

View solution in original post

7 REPLIES 7
Highlighted
VIP Advisor

Hi there,

Going back to your Postman issue, in the body of the POST request are you specifying the grant_type key-value pair along with the client_id and client_secret?:

grant_type: client_credentials

 

cheers,

Seb.

 

Highlighted

Hi,

 

At first no, I didn't use this parameter.

 

I've just try this one with postman that generate this GET URL : https://cloudsso.cisco.com/as/authorization.oauth2?response_type=code&grant_type=client_credentials&client_id=*******&client_secret=**********

 

But I still see the same error.

 

I attach the view of my postman.

Highlighted

Change the REST method (the dropdown to the left of the URL) from GET to POST and you will receive the correct response containing the access_token .

 

cheers,

Seb.

Highlighted

It seems that I have the same result.

 

How to check my client ID and secret ?

 

This URL is correct : https://cloudsso.cisco.com/as/authorization.oauth2  ?

 

I've attached the screenshot for this request with POST method.

Highlighted

It should be: 

https://cloudsso2.cisco.com/as/token.oauth2

cheers,

Seb.

View solution in original post

Highlighted

Yes that better with this URL ! :-)

Many thanks !!!
Highlighted

Do you know if this changed again? I am getting errors when trying to use it.

This widget could not be displayed.