cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1078
Views
0
Helpful
5
Replies

CIsco hyperflex - the number of heartbeat HA datastores for this host is 1...

alanraczek11
Beginner
Beginner

Hello

We have 3 vSphere 6.5 servers in an HX cluster. Recently we went through the process of upgrading vCenter server to

v6.7. The separate PSC's were decommissioned as the ones that were present were merged in hte new vCenter version.

RIght now I get the warning: "The number of heartbeat HA datastores for this host is 1, which is less than the required:2 .

I pretty much adopted this systemand I am new to hyperflex. For the life of me I cannot find HA configured, I looked at the top level in vCenter, clicked configure and then HA, it looks like it is not configured. I see HA under "Monitor" but not "Configure".

What am I missing? Been over this 6.7 interface for 3 hours and I can't find HA configured. I don't see anything Hyperflex under inventories either.

 

TY

5 Replies 5

alanraczek11
Beginner
Beginner

Forgot to mention the ESXi's are still 6.5.

 

...AR

Kirk J
Cisco Employee
Cisco Employee

HA and DRS are configured at the Cluster object level in the vcenter GUI view.

That alert is normal.  Vcenter HA likes more than 1 datastore, and complains if you don't have more than 1.

 

Kirk...

Kirk,

 

Thank you. I'd like to get rid of this warning and be done with it.

 

...Alan

RedNectar
VIP
VIP

Hi @alanraczek11 ,

Sorry for the slow reply - I had the same problem yesterday. Ther answer is documented in the VMware KB, but in case someone ends up here I'll repeat it below.

I hope you've fixed it by now anyway.

This is a problem with Hyperflex and vCenter - VMware doesn't understand that the datastore is a distributed datastore and even if you created another one it wouldn't be better HA

So here's the fix in vCentre - stolen directly from https://kb.vmware.com/s/article/2004739

  1. Log in to vCenter Server.
  2. Right-click the cluster and click Edit Settings.
  3. Click vSphere HA > Advanced Options.
  4. Under Option, add an entry for das.ignoreInsufficientHbDatastore.
  5. Under Value, type true.
  6. Click Cluster Features.
  7. De-select Turn on vSphere HA and click OK.
  8. Wait for all the hosts in the cluster to deconfigure HA, then right-click the cluster and click Edit Settings.
  9. Click Cluster Features.
  10. Click Turn on vSphere HA.
  11. Click OK.

I hope this helps


Don't forget to mark answers as correct if it solves your problem. This helps others find the correct answer if they search for the same problem


RedNectar aka Chris Welsh.
Forum Tips: 1. Paste images inline - don't attach. 2. Always mark helpful and correct answers, it helps others find what they need.

 

Thanks RedNectar. It is different in version 6.7U3 of vCenter though. I found an article on setting advanced options but I still do not have the ability to change anything.I follow the article and go to vSPhere Availability and I should be able to "Add" an advanced option but I do not see an add button. Perhaps I do not have the rights.

 

...Alan

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: