cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

606
Views
0
Helpful
3
Replies
Gilberto Marcos
Beginner

MDS 9509 UPGRADE

Hello every one.

One of my customers wants that two of their 9509 been upgraded. I am new working with this MDS and I am little concern about the MDS version I should recommend and use for this purpose.

Actually the 9509 MDS have:

  kickstart image file is: m9500-sf2ek9-kickstart-mz.5.2.1.bin
  system image file is:  m9500-sf2ek9-mz.5.2.1.bin

I am considering upgrade them to the 5.2(8e) following the:

Recommended Releases for Cisco MDS 9000 Series Switches guide

But reading the release notes I found that the following configuration should be removed:

We recommend that you delete any SPAN configuration, Fibre Channel tunnel, or tunnel-ID map configuration from your switch before you start the upgrade to NX-OS Release 5.2(8e). You can save the SPAN destination and SPAN target configuration and then reconfigure the SPAN session following the upgrade. All SPAN destination and SPAN target ports are reinitialized after the upgrade.

So the FCIP that the customer has should be removed before the upgrade.

Because of this situation I am wondering if I could use the 6.2(13a) version that does not shows that recommendation.

I have seen that the upgrade could be done by issu.

Here is the question: Do I have to consider anything else like license, etc.?

Regards


 

3 REPLIES 3
Manish Gogna
Cisco Employee

Hi Gilberto,

Yes, you can go for the upgrade to 6.2(13a) from the 5.2.1 version.

All the upgrade considerations and steps are included in the release notes of the NX-OS version. Here is the release note for version 6.2(13a):

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/mds9000/sw/6_2/release/notes/nx-os/mds_nxos_rn_6_2_13a.html


This is a non disruptive upgrade as the link mentions, each supervisor will be upgraded individually.

>>  Download the kickstart and the system image from Cisco.com:

  https://software.cisco.com/download/release.html?mdfid=277382585&softwareid=282088130&release=7.3%280%29D1%281%29&relind=AVAILABLE&rellifecycle=&reltype=latest


  https://software.cisco.com/download/release.html?mdfid=277382585&softwareid=282088129&release=7.3%280%29D1%281%29&relind=AVAILABLE&rellifecycle=ED&reltype=latest


>> First copy over the kickstart and the system images to the bootflash.

>> Run the incompatibility check command:

show incompatibility system bootflash:SYSTEMIMAGENAME

If all is fine then -

>>  Install the images

Manish

Hello Manish.

Thank you for answer.

I am thinking about licensing. The license that the MDS have would work with the new version?

or I have to re host them?

Regards

Hi Gilberto,

There is no mandatory license rehost requirement for this upgrade. On the MDS switches a license is either permanent or it expires on a fixed date. You may check it as per the following doc

http://www.cisco.com/en/US/products/ps5989/products_configuration_guide_chapter09186a0080662c89.html#wp1414420

Manish