Hello.
Let me first present you the case 
I am having IPTV boxes, that needs to be on single vlan per IPTV box.
SG500 is on router mode
SG 300 x2 are on switch mode
SF300 is on router mode (as I have 1 vlan /port, SG500 cannot handle more than 256 vlans addressed)
1/ Each of these must reach a DHCP server to get an IP address
2/ Once it is done, they connect to the decrypt server to receive their configuration
3/ And then, they try to get UDP stream on multicast to display something on the TV
Parts 1 and 2 are completed. But the hard part is part 3
I had very very big issue with this, mostly because SG500 is acting like a HUB with some parameters with multicast
To make it act like a real multicast router, I had to lock some parameters
I'll only paste the configuration concerning Multicast & routes :
SF300 :
vlan database
vlan 10-610
ip igmp snooping vlan 10
ip igmp snooping vlan 10 querier
interface vlan 10
ip address 192.168.1.23 255.255.255.192
bridge multicast mode ipv4-group
!
interface vlan 19
ip address 192.168.2.70 255.255.255.248
ip dhcp relay enable
bridge multicast mode ipv4-group
!
interface fastethernet9
switchport mode access
switchport access vlan 19
switchport access multicast-tv vlan 10
!
interface Gigabitethernet1
switchport mode access
switchport access vlan 10
!
ip default-gateway 192.168.1.20
SG300 : No specific configuration as they are L2
SG500 :
vlan database
vlan 10-610
bridge multicast filtering
ip igmp snooping
ip igmp snooping groups vlan 10 239.1.1.1
ip igmp snooping vlan 10
ip igmp snooping vlan 10 querier
interface vlan 10
ip address 192.168.1.20 255.255.255.192
bridge multicast mode ipv4-group
!
interface Gigabitethernet1/1/3
switchport mode access
switchport access vlan 10
!
interface Gigabitethernet1/1/20
switchport mode access
switchport access vlan 10
!
interface Gigabitethernet1/1/25
switchport mode access
switchport access vlan 10
!
ip route 192.168.2.64 /29 192.168.1.23
With this setup, Multicast is not flooded.
Computer on the SG500 is able to get multicast TV stream with a VLC and by entering udp://@239.1.1.1:1234
BUT : IPTV BOX are not able to !
When i'm putting the port fa9 on the SF300 on the vlan 10 in access port mode, the IPTV BOX is able to receive the stream ! (as it already acquired an IP address minutes ago)
the command "sh ip igmp snooping mrouter" on the SF300 tells me that the port Gi1 is the mrouter port, but nothing else.
What am I missing in this ?
Routing is OK in every direction, I can ping anybody from anywhere.
Is it something about vlan tagging ?