Showing results for 
Search instead for 
Did you mean: 

SG220 port down and "Port has not finish RTCT yet"




I'm having problems with a SG220 (with few months) that from port Gi45 to Gi48 when i plug a cable it doesn't UP the port. When i connect the same cable (from my laptop) to any other port it works perfectly.


As i found this strange, i tried to run the copper test on the interface and i get the error: "Port has not finish RTCT yet"


Does this mean a hardware failure or something? All port security settings are disabled and i tried already 'playing' with the flow control and change the speed setting on the interface.


Thank you all,

25 Replies 25

Aleksandra Dargiel
Cisco Employee
Cisco Employee


Did you manage to recover from this situation? I have not seen this problem yet but it would be interesting to recreate if possible.



Well i don't have much experience in Cisco switchs but from what i saw so far the SG220 are a piece of garbage. :/

Besides this problem, i have from time to time a switch that reboots 'magically' with no logs or alarms registered, Cisco support logged to the switch and saw nothing explaining this problem...

I believe the port issues remain happening...

I have a new SG220-50 and I have had a device reboot after clicking the etherlike link in the web gui.  The device is new and I haven't changed any of the default settings.  I also noticed that some ports (attached to devices) are flipping between up/down state for no apparent reason.  I bought Cisco because they were supposed to be bullet proof but now I'm having second thoughts...

We've had similar problems with the SG220-50P.  Spontaneous reboots, ports going down.   They replaced one unit but still reboots every month or so, or maybe more.

Well after getting a Cisco support logged to the switch, checking every configuration they concluded that nothing was wrong with the device.

Last week... reboot again.

It's simply garbage. I was replacing 4 switchs from Zyxel because I told they were crap... well... now Zyxel are my backup switchs because Cisco... well.

I had also an approach from Cisco after this support to follow the problem but it ended up of being a commercial approach to sell video conference stuff.

As for now I will not buy any further Cisco SG in the future. My trust on this went from 10 to 0.

Hi nrsanto and jwilson, I'm with the e-Support team here in San Jose. I'd surely like to understand your experiences with the SG220 a little more, and hope we can resolve the issues you've experienced. You can email me at and I'd be happy to work with you. Have you had any additional troubleshooting besided your earlier post to this discussion? What did they check? What was the state of the switch when you called them?





Same here, 2 SG 220 50 Ports Switch with random reboots and high package error on some ports.. I never had issues with low cost switches before replacement

What about Firmware 1.0.17 and random reboots, any experience?

We are experiencing the same problem. the SG220-50P randomly reboots with no logs.  Firmware version  Have opened case with support Center.  they are replaced the switch 2 times.  Now we are on our third.  We collected logs and show techs and still nothing.  Case is at Level 2 and we have not resolution.  case # SR 636550983.  

Did the case reach any conclusion or they keep changing your hardware to gain some time?

Not with the 48 port POE switch.  They had us send the 48 port to an engineering team and replaced it with two 24 POE switches.  This resolved the issue.  It seems to be a flaw with the 48 port model only.

I have four of these and have had the same issue since day one. Switches would reboot at random, staying up for at best two weeks. Nothing in the logs except the ports coming back up. We use the POE to power the phones so those all crash on a reboot, understandably this is unpopular with staff.

I had a couple of calls with Cisco support who went through every aspect of the configuration and logs and couldn't find any issues.

Eventually switching off spanning tree (not ideal) fixed the issue. Immediately no issues whatsoever. Switch it back on and we get random reboots again.

So after a year of no issues I suddenly have switched rebooting again. They also seem to be dropping POE power to all ports but not rebooting. Nothing has changed on the network.

Good feature set for a cheap switch, but still a cheap switch. I've heard good things about HP...

Lumilux69, Also, please open a case with the Support Center:

Hi Glenn

I have an open case, I received 2 brand new switches as replacement.

Result: They are rebooting as well!!! Not so frequent, but they do a reboot.

With the new firmware release you fix LED issues (very important) instead resolve the reboot issue.

Cisco should replace this product with a different modell, because you cannot use it in a live environment.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Switch products supported in this community
Cisco Business Product Family
  • CBS110
  • CBS220
  • CBS250
  • CBS350
Cisco Switching Product Family
  • 110
  • 200
  • 220
  • 250
  • 300
  • 350
  • 350X
  • 550X
Recognize Your Peers