cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
772
Views
0
Helpful
1
Replies

Static Route not used as default by VLANs

DanBu32941
Level 1
Level 1

Hello Professionals,

 

Device: SG300-28MP 28-port Gigabit Max-PoE Managed Switch

Firmware: 1.4.11.5

 

I have added VLAN 10 and 20 with 192.168.[VLAN].254 /24 with access ports for VLAN 10: GE1, GE2 and VLAN 20: GE20

 

Also I have added two trunk ports GE25 and GE26 allowed VLANs both 10,20

GE25 IP: 192.168.254.254 with uplink IP 192.168.254.253 /24

GE26 IP: 192.168.178.254 with uplink IP 192.168.178.1 /24

 

The GE25/26 are for testing two devices and figure out, the problem is on that side and not the Cisco itself.

 

If I ping the uplinks IP out of the Web-Based Management Interface it works if I select "Auto" but if I select one of the VLANs it doesn't work. Doing the ping from a client connected to GE20 with default GW 192.168.20.254 (the VLAN Interface) I can ping other VLAN Interface like 192.168.10.254 and also the trunks IP 192.168.254.254 but neither the uplink nor later hops. Pinging the uplinks IPs from the uplink-routers works (there is a working route back).

 

The goal: Clients at ports of VLAN 10,20 should ping and access the internet through the uplinks.

 

Please finde enclosed running-config (... edited hostname and pass...):

config-file-header
... edited hostname
v1.4.11.5 / R800_NIK_1_4_220_026
CLI v1.0
set system mode router 

file SSD indicator plaintext
@
spanning-tree loopback-guard
vlan database
vlan 10,20 
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
ip dhcp server 
ip dhcp pool network "VLan 10"
address low 192.168.10.1 high 192.168.10.254 255.255.255.0 
exit
ip dhcp pool network "VLan 20"
address low 192.168.20.1 high 192.168.20.254 255.255.255.0 
exit
no boot host auto-config 
no boot host auto-update 
hostname ... (edited)
username admin password encrypted ... (edited) privilege 15 
!
interface vlan 1
 no ip address dhcp 
 bridge multicast forward-all add gi25-26 
!
interface vlan 10
 ip address 192.168.10.254 255.255.255.0 
 bridge multicast forward-all add gi25-26 
!
interface vlan 20
 ip address 192.168.20.254 255.255.255.0 
 bridge multicast forward-all add gi25-26 
!
interface gigabitethernet1
 switchport mode access 
 switchport access vlan 10 
!
interface gigabitethernet2
 switchport mode access 
 switchport access vlan 10 
!
interface gigabitethernet20
 switchport mode access 
 switchport access vlan 20 
!
interface gigabitethernet25
 ip address 192.168.254.254 255.255.255.0 
 storm-control broadcast enable 
 storm-control broadcast level 10 
 spanning-tree link-type point-to-point 
 switchport trunk allowed vlan add 10,20 
 macro description router
 macro auto smartport type router $native_vlan 1 
!
interface gigabitethernet26
 ip address 192.168.178.254 255.255.255.0 
 switchport trunk allowed vlan add 10,20 
!
exit
macro auto disabled 
ip igmp snooping vlan 1 mrouter interface gi25-26 
ip igmp snooping vlan 10 mrouter interface gi25-26 
ip igmp snooping vlan 20 mrouter interface gi25-26 
ip default-gateway 192.168.178.1 
ip default-gateway 192.168.254.253 

The bridge multicast stuff is from clicking around within the GUI ... sorry.

 

Maybe the best way to help is to send a minimalistic running-config I can use to test with my basic setup.

(adding VLANs & Interfaces and also default-route or default-network)

I noticed my device cannot do OSPF .. and I got response iOS doesn't know the command ip routing or default-network which I should enter as described in a tutorial. Maybe there is a basic problem ? Hope someone can see my mistake - I am confused at the moment.

In my understanding I have to use default-network instead of static routes with default-route if I use VLANs with IPs for their Interfaces. But I cannot enter the corresponding commands.

 

My greatest wish would be a working config I simple can test with my minimalistic setup. But also hints are welcome

 

Thanks for your time

Daniel

1 Accepted Solution

Accepted Solutions

DanBu32941
Level 1
Level 1

Solved myself: Routing back was not done in both of the routers.

View solution in original post

1 Reply 1

DanBu32941
Level 1
Level 1

Solved myself: Routing back was not done in both of the routers.